Bug 298807 - Kmail crashed when chaning IMAP accounts
Summary: Kmail crashed when chaning IMAP accounts
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-25 13:26 UTC by Otter
Modified: 2012-04-25 14:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Otter 2012-04-25 13:26:29 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2) "release 494"
Qt Version: 4.8.1
Operating System: Linux 3.1.10-1.9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
I am not using Kmail on a daily basis any longer because of issues like this.  I do try every 3 to 4 days in the hope that simple issues like this are being corrected.  I started Kmail and watched as it loaded emails.  I went to switch from one IMAP account to  another and received this crash.  If there is a fix for this could someone direct me to it?

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f597513e760 (LWP 4627))]

Thread 4 (Thread 0x7f5956b60700 (LWP 4649)):
#0  0x00007f596cfc6e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f5971957c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f5971957c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f596cfc2f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f597264910d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f595625f700 (LWP 4651)):
#0  0x00007f597263fff3 in poll () from /lib64/libc.so.6
#1  0x00007f596cab3a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f596cab3f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f5972db72e6 in QEventDispatcherGlib::processEvents (this=0x7f59500008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f5972d87012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5972d87267 in QEventLoop::exec (this=0x7f595625ee20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f5972c87547 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f5972c8a56b in QThreadPrivate::start (arg=0x649b40) at thread/qthread_unix.cpp:298
#8  0x00007f596cfc2f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f597264910d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f5908995700 (LWP 5111)):
#0  0x00007f596cfc71eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f5972c8a9df in wait (time=30000, this=0x15966f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1596668, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f5972c7ddef in QThreadPoolThread::run (this=0x15a7410) at concurrent/qthreadpool.cpp:141
#4  0x00007f5972c8a56b in QThreadPrivate::start (arg=0x15a7410) at thread/qthread_unix.cpp:298
#5  0x00007f596cfc2f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f597264910d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f597513e760 (LWP 4627)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x30671e0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f596df8e909 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x30671e0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f5972da12b6 in QObject::event (this=0x30671e0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f597379c0d4 in notify_helper (e=0x7f58f00046f0, receiver=0x30671e0, this=0x638880) at kernel/qapplication.cpp:4554
#10 QApplicationPrivate::notify_helper (this=0x638880, receiver=0x30671e0, e=0x7f58f00046f0) at kernel/qapplication.cpp:4526
#11 0x00007f59737a0f53 in QApplication::notify (this=0x7fff49eb6d90, receiver=0x30671e0, e=0x7f58f00046f0) at kernel/qapplication.cpp:4415
#12 0x00007f59744e0886 in KApplication::notify (this=0x7fff49eb6d90, receiver=0x30671e0, event=0x7f58f00046f0) at /usr/src/debug/kdelibs-4.8.2/kdeui/kernel/kapplication.cpp:311
#13 0x00007f5972d8822c in QCoreApplication::notifyInternal (this=0x7fff49eb6d90, receiver=0x30671e0, event=0x7f58f00046f0) at kernel/qcoreapplication.cpp:876
#14 0x00007f5972d8baca in sendEvent (event=0x7f58f00046f0, receiver=0x30671e0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#16 0x00007f5972db6e53 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x63b150) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f596cab358d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f596cab3d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f596cab3f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f5972db727f in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f597383f76e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f5972d87012 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f5972d87267 in QEventLoop::exec (this=0x7fff49eb6d20, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f5972d8bdc5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007f597258f23d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 298609, bug 298427, bug 298350, bug 298320, bug 297907.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-04-25 14:10:10 UTC

*** This bug has been marked as a duplicate of bug 286307 ***