Bug 296009 - Kontact crash if i want to open a mail
Summary: Kontact crash if i want to open a mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 18:14 UTC by martin0976
Modified: 2012-03-26 22:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.86 KB, text/plain)
2012-03-20 21:21 UTC, John Layt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description martin0976 2012-03-14 18:14:52 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1) "release 481"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I just want open a one weak old Email. Nothing more............

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1445df2760 (LWP 14507))]

Thread 4 (Thread 0x7f142d81e700 (LWP 14508)):
#0  0x00007f143dc77e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1442606c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f1442606c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f143dc73f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f14432f810d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f142cf05700 (LWP 14509)):
#0  0x00007f14432eeff3 in poll () from /lib64/libc.so.6
#1  0x00007f143d764a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f143d764f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f1443a65956 in QEventDispatcherGlib::processEvents (this=0x7f14280008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f1443a35682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1443a358d7 in QEventLoop::exec (this=0x7f142cf04e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f1443936537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f144393955b in QThreadPrivate::start (arg=0x7786a0) at thread/qthread_unix.cpp:298
#8  0x00007f143dc73f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f14432f810d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f13dfbb0700 (LWP 14520)):
#0  0x00007f143dc781eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f14439399cf in wait (time=30000, this=0xdb1a90) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xdb1a38, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f144392cddf in QThreadPoolThread::run (this=0xdc4fe0) at concurrent/qthreadpool.cpp:141
#4  0x00007f144393955b in QThreadPrivate::start (arg=0xdc4fe0) at thread/qthread_unix.cpp:298
#5  0x00007f143dc73f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f14432f810d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1445df2760 (LWP 14507)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff9f3afba0) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff9f3afeb0) at access/qabstractnetworkcache.cpp:240
#8  0x00007f143ebb15cc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x21962a0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007f143ebb2d24 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x21962a0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007f143ec3e379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x21962a0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007f1443a4f926 in QObject::event (this=0x21962a0, e=<optimized out>) at kernel/qobject.cpp:1204
#12 0x00007f1444449e84 in notify_helper (e=0x7f13d0015120, receiver=0x21962a0, this=0x63df10) at kernel/qapplication.cpp:4550
#13 QApplicationPrivate::notify_helper (this=0x63df10, receiver=0x21962a0, e=0x7f13d0015120) at kernel/qapplication.cpp:4522
#14 0x00007f144444ed03 in QApplication::notify (this=0x7fff9f3b0930, receiver=0x21962a0, e=0x7f13d0015120) at kernel/qapplication.cpp:4411
#15 0x00007f144518e656 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#16 0x00007f1443a3689c in QCoreApplication::notifyInternal (this=0x7fff9f3b0930, receiver=0x21962a0, event=0x7f13d0015120) at kernel/qcoreapplication.cpp:876
#17 0x00007f1443a3a13a in sendEvent (event=0x7f13d0015120, receiver=0x21962a0) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#19 0x00007f1443a654c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007f143d76458d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f143d764d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f143d764f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f1443a658ef in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f14444ed2de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f1443a35682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f1443a358d7 in QEventLoop::exec (this=0x7fff9f3b08c0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f1443a3a435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000403919 in ?? ()
#30 0x00007f144323e23d in __libc_start_main () from /lib64/libc.so.6
#31 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 295112, bug 294125, bug 292500, bug 288324, bug 287874.

Reported using DrKonqi
Comment 1 John Layt 2012-03-20 21:21:18 UTC
Created attachment 69773 [details]
New crash information added by DrKonqi

kontact (4.8.0) on KDE Platform 4.8.1 (4.8.1) "release 481" using Qt 4.8.0

- What I was doing when the application crashed:

I receive html emails from a certain online retailer.  If I view two of these emails in a session then I always crash on viewing the second email.  I can view other html or text emails without it crashing, but as soon as I view one of their mails for a second time KMail2 crashes.  I can forward the emails if required.  It has been suggested by Volker this is a Qt 4.8 related bug.

-- Backtrace (Reduced):
#6  QList (l=..., this=0x7ffff2a1b570) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7ffff2a1b880) at access/qabstractnetworkcache.cpp:240
#8  0x00007f2433fd45cc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x1e18f30, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007f2433fd5d24 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x1e18f30, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007f2434061379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x1e18f30, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
Comment 2 Christophe Giboudeaux 2012-03-26 22:19:07 UTC

*** This bug has been marked as a duplicate of bug 286307 ***