Bug 298127 - Crash on closing Rekonq
Summary: Crash on closing Rekonq
Status: RESOLVED DUPLICATE of bug 269490
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: 0.7.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-14 16:19 UTC by ogre
Modified: 2012-05-31 18:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ogre 2012-04-14 16:19:06 UTC
Application: rekonq (0.7.0)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic x86_64
Distribution: Linux Mint 11 Katya

-- Information about the crash:
- What I was doing when the application crashed:

 I clicked the X button to close the program and i closed. I wasn't editing bookmarks so it has nothing to do with that "famous" bug.
  I also wasn't looking at YouTube or any flash content that I can remember.

The crash can be reproduced some of the time.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2123e23780 (LWP 3564))]

Thread 7 (Thread 0x7f210edd0700 (LWP 3671)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f21228ae832 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007f211e02fd8c in start_thread (arg=0x7f210edd0700) at pthread_create.c:304
#3  0x00007f212369804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f210d805700 (LWP 3751)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f212328a2a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f21235a3180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f212328a2d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f21235b1254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f211e02fd8c in start_thread (arg=0x7f210d805700) at pthread_create.c:304
#4  0x00007f212369804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f20fed7d700 (LWP 3901)):
#0  0x00007f211aa6784e in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f211aa68122 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f211aa68639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f211e958446 in QEventDispatcherGlib::processEvents (this=0x2108350, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f211e92c882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f211e92cabc in QEventLoop::exec (this=0x7f20fed7cdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f211e843924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007f211e90ec2f in QInotifyFileSystemWatcherEngine::run (this=0x20ff550) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f211e846175 in QThreadPrivate::start (arg=0x20ff550) at thread/qthread_unix.cpp:320
#9  0x00007f211e02fd8c in start_thread (arg=0x7f20fed7d700) at pthread_create.c:304
#10 0x00007f212369804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f20fcb56700 (LWP 4008)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f211e84682b in wait (this=<value optimized out>, mutex=0x1c762d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1c762d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f212080b0b4 in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f212080d723 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f212080d73c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f212080c53f in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00007f212080c5cb in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#8  0x00007f211e846175 in QThreadPrivate::start (arg=0x47e23d0) at thread/qthread_unix.cpp:320
#9  0x00007f211e02fd8c in start_thread (arg=0x7f20fcb56700) at pthread_create.c:304
#10 0x00007f212369804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f20e3c25700 (LWP 4061)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f211e84682b in wait (this=<value optimized out>, mutex=0x1c762d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1c762d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f212080b0b4 in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f212080d723 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f212080c53f in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f212080c5cb in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#7  0x00007f211e846175 in QThreadPrivate::start (arg=0x47df130) at thread/qthread_unix.cpp:320
#8  0x00007f211e02fd8c in start_thread (arg=0x7f20e3c25700) at pthread_create.c:304
#9  0x00007f212369804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f20e3424700 (LWP 4062)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f211e84682b in wait (this=<value optimized out>, mutex=0x1c762d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1c762d0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f212080b0b4 in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007f212080d723 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00007f212080c53f in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00007f212080c5cb in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#7  0x00007f211e846175 in QThreadPrivate::start (arg=0x46ccf50) at thread/qthread_unix.cpp:320
#8  0x00007f211e02fd8c in start_thread (arg=0x7f20e3424700) at pthread_create.c:304
#9  0x00007f212369804d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2123e23780 (LWP 3564)):
[KCrash Handler]
#6  0x00007f211f011699 in QRasterWindowSurface::~QRasterWindowSurface (this=0x47d5b30, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:104
#7  0x00007f211f011719 in QRasterWindowSurface::~QRasterWindowSurface (this=0x47d5b30, __in_chrg=<value optimized out>) at painting/qwindowsurface_raster.cpp:108
#8  0x00007f211f02bcd2 in QWidgetBackingStore::~QWidgetBackingStore (this=0x47d5d20, __in_chrg=<value optimized out>) at painting/qbackingstore.cpp:883
#9  0x00007f211ee65789 in QWidgetBackingStoreTracker::destroy (this=0x47d5c70) at kernel/qwidget.cpp:210
#10 0x00007f211ee658d9 in QWidgetPrivate::deleteExtra (this=0x1ff6b60) at kernel/qwidget.cpp:1776
#11 0x00007f211ee65b1c in QWidgetPrivate::~QWidgetPrivate (this=0x1ff6b60, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:337
#12 0x00007f211f26255d in ~QMenuPrivate (this=0x1ff6b60, __in_chrg=<value optimized out>) at widgets/qmenu_p.h:171
#13 QMenuPrivate::~QMenuPrivate (this=0x1ff6b60, __in_chrg=<value optimized out>) at widgets/qmenu_p.h:183
#14 0x00007f211e944645 in cleanup (this=0x1d37290, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x1d37290, __in_chrg=<value optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x1d37290, __in_chrg=<value optimized out>) at kernel/qobject.cpp:818
#17 0x00007f211ee67f80 in QWidget::~QWidget (this=0x1d37290, __in_chrg=<value optimized out>) at kernel/qwidget.cpp:1508
#18 0x00007f212141be89 in KMenu::~KMenu() () from /usr/lib/libkdeui.so.5
#19 0x00007f2121278776 in KActionMenu::~KActionMenu() () from /usr/lib/libkdeui.so.5
#20 0x00007f2120e28d39 in KBookmarkActionMenu::~KBookmarkActionMenu() () from /usr/lib/libkio.so.5
#21 0x00007f211e93fc14 in QObjectPrivate::deleteChildren (this=0x1d2ae30) at kernel/qobject.cpp:1964
#22 0x00007f211e9445f4 in QObject::~QObject (this=0x1d94300, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#23 0x00007f21239efcf9 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_rekonq.so
#24 0x00007f211e93fc14 in QObjectPrivate::deleteChildren (this=0x1b86140) at kernel/qobject.cpp:1964
#25 0x00007f211e9445f4 in QObject::~QObject (this=0x7fff7f85f8b0, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#26 0x00007f211ee25122 in QApplication::~QApplication (this=0x7fff7f85f8b0, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1080
#27 0x00007f21239a126f in Application::~Application() () from /usr/lib/kde4/libkdeinit/libkdeinit4_rekonq.so
#28 0x00007f2123a25900 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_rekonq.so
#29 0x00007f21235d0eff in __libc_start_main (main=0x400730 <_start+256>, argc=1, ubp_av=0x7fff7f860238, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff7f860228) at libc-start.c:226
#30 0x0000000000400659 in _start ()

This bug may be a duplicate of or related to bug 269490.

Possible duplicates by query: bug 295018, bug 294229, bug 294100, bug 294033, bug 292398.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-05-31 18:57:26 UTC

*** This bug has been marked as a duplicate of bug 269490 ***