Bug 297997 - Muon Software Center crashes on startup
Summary: Muon Software Center crashes on startup
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: muon
Classification: Unclassified
Component: muon (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-12 20:42 UTC by Robert
Modified: 2012-04-12 21:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert 2012-04-12 20:42:15 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build Identifier: 

This is a fresh install of Kubuntu.  Every time I try to start Muon Software Center, the applicaiton crashes.  Muon Package Manager operates properly.  I have redone the install twice to verify.

Crash report:
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-17-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Fresh install of Kubuntu on system.  Tried to start Muon Software Center to install additional aapplications, but application crashes everytime.  Was able to use Muon Package Manager to install latest updates for installed applications, but this does not change the response of the Software Center.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd59e6cc780 (LWP 8404))]

Thread 2 (Thread 0x7fd589c9d700 (LWP 8408)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007fd589c9caf0 in ?? ()
#2  0x00007fffa0e9c7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7fd59e6cc780 (LWP 8404)):
[KCrash Handler]
#6  0x00007fd59d38da5e in QtPrivate::QStringList_contains (that=0x7fffa0e05d20, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffa0e05d20) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x21a7f90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x21a7f90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa0e062f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fd59d439eba in QMetaObject::activate (sender=0x225c790, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x225c790, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa0e06450) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fd59d439eba in QMetaObject::activate (sender=0x21a7f90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffa0e06450) at kernel/qobject.cpp:3278
#13 0x00007fd59e2afe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x21c4450) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fd59e2aff8e in MuonMainWindow::initObject (this=0x21a7f90) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x21a7f90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x21a7f90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa0e06520) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fd59d439eba in QMetaObject::activate (sender=0x22577c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fd59d441f7f in QSingleShotTimer::timerEvent (this=0x22577c0) at kernel/qtimer.cpp:308
#19 0x00007fd59d43d789 in QObject::event (this=0x22577c0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fd59ba60474 in notify_helper (e=0x7fffa0e06a90, receiver=0x22577c0, this=0x2073660) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x2073660, receiver=0x22577c0, e=0x7fffa0e06a90) at kernel/qapplication.cpp:4458
#22 0x00007fd59ba652e1 in QApplication::notify (this=0x7fffa0e06d90, receiver=0x22577c0, e=0x7fffa0e06a90) at kernel/qapplication.cpp:4365
#23 0x00007fd59cc45466 in KApplication::notify (this=0x7fffa0e06d90, receiver=0x22577c0, event=0x7fffa0e06a90) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fd59d426afc in QCoreApplication::notifyInternal (this=0x7fffa0e06d90, receiver=0x22577c0, event=0x7fffa0e06a90) at kernel/qcoreapplication.cpp:787
#25 0x00007fd59d453d62 in sendEvent (event=0x7fffa0e06a90, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x20711d0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fd59d451514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fd597b06a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fd597b07258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fd597b07429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fd59d451ed6 in QEventDispatcherGlib::processEvents (this=0x204c6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fd59bb0810e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fd59d425cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fd59d425ef7 in QEventLoop::exec (this=0x7fffa0e06d20, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fd59d42a789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fffa0e07008) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 297053, bug 296988, bug 296898, bug 296854, bug 296828.

Report to https://bugs.kde.org

Reproducible: Always
Comment 1 Jonathan Thomas 2012-04-12 21:29:05 UTC

*** This bug has been marked as a duplicate of bug 291262 ***