Bug 295112 - Kmail crash on html heavy emails
Summary: Kmail crash on html heavy emails
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-01 04:34 UTC by Donald J. Stewart
Modified: 2012-03-08 21:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Donald J. Stewart 2012-03-01 04:34:45 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.2.1-gentoo-r2 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
Kontact and Kmail can open a html-heavy email, but when attempting to delete the email, it crashes Kontact every time

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1eeb1eb760 (LWP 15250))]

Thread 8 (Thread 0x7f1ed3ce6700 (LWP 15251)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f1ee79eb1c4 in scavengerThread (this=0x7f1ee83d4100) at wtf/FastMalloc.cpp:2495
#2  WTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f1ee83d4100) at wtf/FastMalloc.cpp:1618
#3  0x00007f1ee300fccc in start_thread (arg=0x7f1ed3ce6700) at pthread_create.c:301
#4  0x00007f1ee872907d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 7 (Thread 0x7f1ed33e5700 (LWP 15252)):
#0  0x00007f1ee8720423 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1ee2278d70 in g_main_context_poll (n_fds=1, fds=0x1f819c0, timeout=-1, context=0x1f7fe30, priority=<optimized out>) at gmain.c:3402
#2  g_main_context_iterate (context=0x1f7fe30, block=1, dispatch=1, self=<optimized out>) at gmain.c:3084
#3  0x00007f1ee2279221 in g_main_context_iteration (context=0x1f7fe30, may_block=1) at gmain.c:3152
#4  0x00007f1ee9b32ec6 in QEventDispatcherGlib::processEvents (this=0x1dda460, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f1ee9b03752 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f1ee9b03a05 in QEventLoop::exec (this=0x7f1ed33e4e20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f1ee9a03d15 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f1ee9a06327 in QThreadPrivate::start (arg=0x1f797a0) at thread/qthread_unix.cpp:298
#9  0x00007f1ee300fccc in start_thread (arg=0x7f1ed33e5700) at pthread_create.c:301
#10 0x00007f1ee872907d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 6 (Thread 0x7f1e8a796700 (LWP 15256)):
#0  syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:39
#1  0x00007f1ee9a057b3 in _q_futex (val2=0, addr2=0x0, timeout=0x0, val=2, op=0, addr=0x2345010) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=0x2345010, timeout=<optimized out>) at thread/qmutex_unix.cpp:113
#3  0x00007f1ee9a01a6d in QMutex::lockInternal (this=<optimized out>) at thread/qmutex.cpp:450
#4  0x00007f1edcf3d8b1 in QMutexLocker (m=0x2344578, this=0x7f1e8a795d90) at /usr/include/qt4/QtCore/qmutex.h:102
#5  Soprano::Client::SocketHandler::~SocketHandler (this=0x240e1a0, __in_chrg=<optimized out>) at /var/tmp/portage/dev-libs/soprano-2.7.4/work/soprano-2.7.4/client/clientconnection.cpp:58
#6  0x00007f1edcf3d979 in Soprano::Client::SocketHandler::~SocketHandler (this=0x240e1a0, __in_chrg=<optimized out>) at /var/tmp/portage/dev-libs/soprano-2.7.4/work/soprano-2.7.4/client/clientconnection.cpp:61
#7  0x00007f1ee9a04ab7 in QThreadStorageData::finish (p=0x2401d58) at thread/qthreadstorage.cpp:203
#8  0x00007f1ee9a05a10 in QThreadPrivate::finish (arg=0x24025e0) at thread/qthread_unix.cpp:321
#9  0x00007f1ee9a0632f in ~__pthread_cleanup_class (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/pthread.h:545
#10 QThreadPrivate::start (arg=0x24025e0) at thread/qthread_unix.cpp:273
#11 0x00007f1ee300fccc in start_thread (arg=0x7f1e8a796700) at pthread_create.c:301
#12 0x00007f1ee872907d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7f1e8959d700 (LWP 15264)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007f1ee86ca9ea in _L_lock_9832 () from /lib64/libc.so.6
#2  0x00007f1ee86c8df1 in *__GI___libc_free (mem=0x7f1ee89d5ea0) at malloc.c:3736
#3  0x00007f1ee9b1ad76 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#4  ~QScopedPointer (this=0x3208858, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#5  QObject::~QObject (this=0x3208850, __in_chrg=<optimized out>) at kernel/qobject.cpp:817
#6  0x00007f1ee3fa5ad3 in ~QWriteNotifier (this=0x3208850, __in_chrg=<optimized out>) at socket/qnativesocketengine.cpp:1166
#7  QWriteNotifier::~QWriteNotifier (this=<optimized out>, __in_chrg=<optimized out>) at socket/qnativesocketengine.cpp:1166
#8  0x00007f1ee3fa5251 in QNativeSocketEngine::close (this=<optimized out>) at socket/qnativesocketengine.cpp:873
#9  0x00007f1ee3f97b59 in QAbstractSocketPrivate::resetSocketLayer (this=0x7f1e84008650) at socket/qabstractsocket.cpp:511
#10 0x00007f1ee3f9d6b6 in QAbstractSocket::disconnectFromHostImplementation (this=0x7f1e840085f8) at socket/qabstractsocket.cpp:2565
#11 0x00007f1ee3f9dbed in QAbstractSocket::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qabstractsocket.cpp:168
#12 0x00007f1ee9b0d887 in QMetaMethod::invoke (this=0x7f1e8959cb10, object=0x7f1e840085f8, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1641
#13 0x00007f1ee9b0e647 in QMetaObject::invokeMethod (obj=0x7f1e840085f8, member=<optimized out>, type=Qt::DirectConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#14 0x00007f1ee3f98514 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., type=Qt::DirectConnection, member=0x7f1ee3fcf878 "disconnectFromHostImplementation", obj=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs.h:418
#15 QAbstractSocket::disconnectFromHost (this=<optimized out>) at socket/qabstractsocket.cpp:2474
#16 0x00007f1ee3f985bb in QAbstractSocket::close (this=0x7f1e840085f8) at socket/qabstractsocket.cpp:2452
#17 0x00007f1ee3fa8d5b in QLocalSocket::close (this=0x7f1e84005df0) at socket/qlocalsocket_unix.cpp:436
#18 0x00007f1ee3fa1ebb in QLocalSocket::~QLocalSocket (this=0x7f1e84005df0, __in_chrg=<optimized out>) at socket/qlocalsocket.cpp:348
#19 0x00007f1ee3fa1f09 in QLocalSocket::~QLocalSocket (this=0x7f1e84005df0, __in_chrg=<optimized out>) at socket/qlocalsocket.cpp:353
#20 0x00007f1edcf3d8d5 in Soprano::Client::SocketHandler::~SocketHandler (this=0x7f1e84009370, __in_chrg=<optimized out>) at /var/tmp/portage/dev-libs/soprano-2.7.4/work/soprano-2.7.4/client/clientconnection.cpp:60
#21 0x00007f1edcf3d979 in Soprano::Client::SocketHandler::~SocketHandler (this=0x7f1e84009370, __in_chrg=<optimized out>) at /var/tmp/portage/dev-libs/soprano-2.7.4/work/soprano-2.7.4/client/clientconnection.cpp:61
#22 0x00007f1ee9a04ab7 in QThreadStorageData::finish (p=0x3319438) at thread/qthreadstorage.cpp:203
#23 0x00007f1ee9a05a10 in QThreadPrivate::finish (arg=0x2f4b8c0) at thread/qthread_unix.cpp:321
#24 0x00007f1ee9a0632f in ~__pthread_cleanup_class (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/pthread.h:545
#25 QThreadPrivate::start (arg=0x2f4b8c0) at thread/qthread_unix.cpp:273
#26 0x00007f1ee300fccc in start_thread (arg=0x7f1e8959d700) at pthread_create.c:301
#27 0x00007f1ee872907d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f1e837fe700 (LWP 15267)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007f1ee86ca9ea in _L_lock_9832 () from /lib64/libc.so.6
#2  0x00007f1ee86c8df1 in *__GI___libc_free (mem=0x7f1ee89d5ea0) at malloc.c:3736
#3  0x00007f1ee22746cc in g_source_unref_internal (source=0x36d6470, context=0x36d4db0, have_lock=0) at gmain.c:1702
#4  0x00007f1ee9b3321a in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x36d46f0, __in_chrg=<optimized out>) at kernel/qeventdispatcher_glib.cpp:375
#5  0x00007f1ee9b33369 in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x36d46f0, __in_chrg=<optimized out>) at kernel/qeventdispatcher_glib.cpp:403
#6  0x00007f1ee9a05a67 in QThreadPrivate::finish (arg=<optimized out>) at thread/qthread_unix.cpp:330
#7  0x00007f1ee9a0632f in ~__pthread_cleanup_class (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/pthread.h:545
#8  QThreadPrivate::start (arg=0x36ce560) at thread/qthread_unix.cpp:273
#9  0x00007f1ee300fccc in start_thread (arg=0x7f1e837fe700) at pthread_create.c:301
#10 0x00007f1ee872907d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f1e82ffd700 (LWP 15268)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007f1ee86ca9ea in _L_lock_9832 () from /lib64/libc.so.6
#2  0x00007f1ee86c8df1 in *__GI___libc_free (mem=0x7f1ee89d5ea0) at malloc.c:3736
#3  0x00007f1ee22746cc in g_source_unref_internal (source=0x36d38b0, context=0x36d2fc0, have_lock=0) at gmain.c:1702
#4  0x00007f1ee9b3321a in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x36d2af0, __in_chrg=<optimized out>) at kernel/qeventdispatcher_glib.cpp:375
#5  0x00007f1ee9b33369 in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x36d2af0, __in_chrg=<optimized out>) at kernel/qeventdispatcher_glib.cpp:403
#6  0x00007f1ee9a05a67 in QThreadPrivate::finish (arg=<optimized out>) at thread/qthread_unix.cpp:330
#7  0x00007f1ee9a0632f in ~__pthread_cleanup_class (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/pthread.h:545
#8  QThreadPrivate::start (arg=0x36d24b0) at thread/qthread_unix.cpp:273
#9  0x00007f1ee300fccc in start_thread (arg=0x7f1e82ffd700) at pthread_create.c:301
#10 0x00007f1ee872907d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f1e825f6700 (LWP 15269)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:97
#1  0x00007f1ee86ca9ea in _L_lock_9832 () from /lib64/libc.so.6
#2  0x00007f1ee86c8df1 in *__GI___libc_free (mem=0x7f1ee89d5ea0) at malloc.c:3736
#3  0x00007f1ee22746cc in g_source_unref_internal (source=0x36b6e40, context=0x36d7de0, have_lock=0) at gmain.c:1702
#4  0x00007f1ee9b3321a in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x36d77e0, __in_chrg=<optimized out>) at kernel/qeventdispatcher_glib.cpp:375
#5  0x00007f1ee9b33369 in QEventDispatcherGlib::~QEventDispatcherGlib (this=0x36d77e0, __in_chrg=<optimized out>) at kernel/qeventdispatcher_glib.cpp:403
#6  0x00007f1ee9a05a67 in QThreadPrivate::finish (arg=<optimized out>) at thread/qthread_unix.cpp:330
#7  0x00007f1ee9a0632f in ~__pthread_cleanup_class (this=<optimized out>, __in_chrg=<optimized out>) at /usr/include/pthread.h:545
#8  QThreadPrivate::start (arg=0x3626b40) at thread/qthread_unix.cpp:273
#9  0x00007f1ee300fccc in start_thread (arg=0x7f1e825f6700) at pthread_create.c:301
#10 0x00007f1ee872907d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f1eeb1eb760 (LWP 15250)):
[KCrash Handler]
#6  0x00007f1ee86845c5 in *__GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f1ee868586a in *__GI_abort () at abort.c:93
#8  0x00007f1ee86bec94 in __libc_message (do_abort=2, fmt=0x7f1ee879d140 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:198
#9  0x00007f1ee86c4065 in malloc_printerr (action=3, str=0x7f1ee879a31f "free(): invalid pointer", ptr=<optimized out>) at malloc.c:6283
#10 0x00007f1ee86c8dfc in *__GI___libc_free (mem=<optimized out>) at malloc.c:3738
#11 0x00007f1ee3f5d36a in QList (l=..., this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qlist.h:122
#12 QNetworkCacheMetaData::rawHeaders (this=<optimized out>) at access/qabstractnetworkcache.cpp:240
#13 0x00007f1ee3f439e7 in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x4302fa0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#14 0x00007f1ee3f450f1 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4302fa0, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#15 0x00007f1ee3fc6395 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4302fa0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#16 0x00007f1ee9b18f7e in QObject::event (this=0x4302fa0, e=<optimized out>) at kernel/qobject.cpp:1195
#17 0x00007f1ee8eaf014 in QApplicationPrivate::notify_helper (this=0x1dbdb70, receiver=0x4302fa0, e=0x3bc0a00) at kernel/qapplication.cpp:4550
#18 0x00007f1ee8eb3b7f in QApplication::notify (this=<optimized out>, receiver=0x4302fa0, e=0x3bc0a00) at kernel/qapplication.cpp:4411
#19 0x00007f1eea596376 in KApplication::notify (this=0x7fff6fa63a90, receiver=0x4302fa0, event=0x3bc0a00) at /var/tmp/portage/kde-base/kdelibs-4.8.0-r1/work/kdelibs-4.8.0/kdeui/kernel/kapplication.cpp:311
#20 0x00007f1ee9b046e3 in QCoreApplication::notifyInternal (this=0x7fff6fa63a90, receiver=0x4302fa0, event=0x3bc0a00) at kernel/qcoreapplication.cpp:876
#21 0x00007f1ee9b07c0f in sendEvent (event=0x3bc0a00, receiver=0x4302fa0) at kernel/qcoreapplication.h:231
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1d92670) at kernel/qcoreapplication.cpp:1500
#23 0x00007f1ee9b32ce3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#24 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#25 0x00007f1ee2278862 in g_main_dispatch (context=0x1dc4600) at gmain.c:2441
#26 g_main_context_dispatch (context=0x1dc4600) at gmain.c:3011
#27 0x00007f1ee2279040 in g_main_context_iterate (context=0x1dc4600, block=1, dispatch=1, self=<optimized out>) at gmain.c:3089
#28 0x00007f1ee2279221 in g_main_context_iteration (context=0x1dc4600, may_block=1) at gmain.c:3152
#29 0x00007f1ee9b32e6f in QEventDispatcherGlib::processEvents (this=0x1dbc870, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007f1ee8f52c3e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f1ee9b03752 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f1ee9b03a05 in QEventLoop::exec (this=0x7fff6fa639e0, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007f1ee9b08093 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#34 0x0000000000404497 in main (argc=1, argv=0x7fff6fa640b8) at /var/tmp/portage/kde-base/kontact-4.8.0/work/kontact-4.8.0/kontact/src/main.cpp:218

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-08 21:53:34 UTC

*** This bug has been marked as a duplicate of bug 286307 ***