Bug 296901 - kmail crashes on opening mail
Summary: kmail crashes on opening mail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-27 17:57 UTC by Mathias Homann
Modified: 2012-03-30 13:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Homann 2012-03-27 17:57:20 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1) "release 483"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
switching to "next unread" by hotkey


(why do i have to add random text just to make the report longer?)

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f36a29da760 (LWP 8096))]

Thread 9 (Thread 0x7f3689fa2700 (LWP 8098)):
#0  0x00007f369a877e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f369f206c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f369f206c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f369a873f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f369fef810d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f36896a1700 (LWP 8099)):
#0  0x00007f369feeeff3 in poll () from /lib64/libc.so.6
#1  0x00007f369a364a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f369a364f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f36a0665956 in QEventDispatcherGlib::processEvents (this=0x7f36840008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f36a0635682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f36a06358d7 in QEventLoop::exec (this=0x7f36896a0e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f36a0536537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f36a053955b in QThreadPrivate::start (arg=0x8ad0d0) at thread/qthread_unix.cpp:298
#8  0x00007f369a873f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f369fef810d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f3631873700 (LWP 8171)):
#0  0x00007f369a3641aa in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f369a364ab2 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f369a364f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f36a0665956 in QEventDispatcherGlib::processEvents (this=0x7f36280008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f36a0635682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f36a06358d7 in QEventLoop::exec (this=0x7f3631872df0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f36a0536537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f36a061548f in QInotifyFileSystemWatcherEngine::run (this=0x1136420) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f36a053955b in QThreadPrivate::start (arg=0x1136420) at thread/qthread_unix.cpp:298
#9  0x00007f369a873f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f369fef810d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f363b146700 (LWP 11924)):
#0  0x00007f369a8781eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f36a05399cf in wait (time=30000, this=0x1092a40) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x10929e8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f36a052cddf in QThreadPoolThread::run (this=0x10a68f0) at concurrent/qthreadpool.cpp:141
#4  0x00007f36a053955b in QThreadPrivate::start (arg=0x10a68f0) at thread/qthread_unix.cpp:298
#5  0x00007f369a873f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f369fef810d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f363c3db700 (LWP 11926)):
#0  0x00007f369a8781eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f36a05399cf in wait (time=30000, this=0x157c5b0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x158ae88, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f36a052cddf in QThreadPoolThread::run (this=0x15892c0) at concurrent/qthreadpool.cpp:141
#4  0x00007f36a053955b in QThreadPrivate::start (arg=0x15892c0) at thread/qthread_unix.cpp:298
#5  0x00007f369a873f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f369fef810d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f3625514700 (LWP 11928)):
#0  0x00007f369a8781eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f36a05399cf in wait (time=30000, this=0x7f3620006740) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f36200066e8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f36a052cddf in QThreadPoolThread::run (this=0x7f3620006990) at concurrent/qthreadpool.cpp:141
#4  0x00007f36a053955b in QThreadPrivate::start (arg=0x7f3620006990) at thread/qthread_unix.cpp:298
#5  0x00007f369a873f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f369fef810d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f3624d13700 (LWP 11930)):
#0  0x00007f369a8781eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f36a05399cf in wait (time=30000, this=0x7f3620006740) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f36200066e8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f36a052cddf in QThreadPoolThread::run (this=0x7f362000a970) at concurrent/qthreadpool.cpp:141
#4  0x00007f36a053955b in QThreadPrivate::start (arg=0x7f362000a970) at thread/qthread_unix.cpp:298
#5  0x00007f369a873f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f369fef810d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f3617fff700 (LWP 11932)):
#0  0x00007f369a8781eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f36a05399cf in wait (time=30000, this=0x7f3620006740) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f36200066e8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f36a052cddf in QThreadPoolThread::run (this=0x7f362000e940) at concurrent/qthreadpool.cpp:141
#4  0x00007f36a053955b in QThreadPrivate::start (arg=0x7f362000e940) at thread/qthread_unix.cpp:298
#5  0x00007f369a873f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f369fef810d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f36a29da760 (LWP 8096)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x4df3bc0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f369b83e379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x4df3bc0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f36a064f926 in QObject::event (this=0x4df3bc0, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f36a1049e84 in notify_helper (e=0x7f36200119b0, receiver=0x4df3bc0, this=0x639630) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x639630, receiver=0x4df3bc0, e=0x7f36200119b0) at kernel/qapplication.cpp:4522
#11 0x00007f36a104ed03 in QApplication::notify (this=0x7fffe2b45b80, receiver=0x4df3bc0, e=0x7f36200119b0) at kernel/qapplication.cpp:4411
#12 0x00007f36a1d8e656 in KApplication::notify (this=0x7fffe2b45b80, receiver=0x4df3bc0, event=0x7f36200119b0) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#13 0x00007f36a063689c in QCoreApplication::notifyInternal (this=0x7fffe2b45b80, receiver=0x4df3bc0, event=0x7f36200119b0) at kernel/qcoreapplication.cpp:876
#14 0x00007f36a063a13a in sendEvent (event=0x7f36200119b0, receiver=0x4df3bc0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#16 0x00007f36a06654c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f369a36458d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f369a364d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f369a364f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f36a06658ef in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f36a10ed2de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f36a0635682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f36a06358d7 in QEventLoop::exec (this=0x7fffe2b45b10, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f36a063a435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007f369fe3e23d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 296658, bug 296624, bug 296617, bug 296613, bug 296485.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-30 13:42:45 UTC

*** This bug has been marked as a duplicate of bug 286307 ***