Bug 296658 - KMail crash when closing email
Summary: KMail crash when closing email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 02:41 UTC by Bryan Zimmerman
Modified: 2012-03-26 06:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bryan Zimmerman 2012-03-24 02:41:06 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-12-generic i686
Distribution: Linux Mint 12 Lisa

-- Information about the crash:
It's difficult for me to say exactly what caused the crash, but it appeared to happen either right after I closed an email that I was reading or when I clicked on another email to read it.

Once in the Crash Reporting Assistant, I can't find a way to display my crash backtrace so I can compare it against others to see if there is a duplicate.  I'll have to remember to copy it into another text editor in the future so I can do the comparison.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76ea730 (LWP 25886))]

Thread 6 (Thread 0xb5bdbb70 (LWP 25887)):
#0  0x009a5416 in __kernel_vsyscall ()
#1  0x00bbba5c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x007cf09c in __pthread_cond_wait (cond=0x3644430, mutex=0x3644418) at forward.c:139
#3  0x02f23883 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0x02f2399f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0x00bb7d31 in start_thread (arg=0xb5bdbb70) at pthread_create.c:304
#6  0x007c146e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 5 (Thread 0xb52b2b70 (LWP 25888)):
#0  0x009a5416 in __kernel_vsyscall ()
#1  0x007b27ae in __GI___poll (fds=0x9860a20, nfds=1, timeout=8412) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x06c6f34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x06c60896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x06c60c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x073aa1c7 in QEventDispatcherGlib::processEvents (this=0x985f200, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x07375d1d in QEventLoop::processEvents (this=0xb52b22b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x07375fb9 in QEventLoop::exec (this=0xb52b22b0, flags=...) at kernel/qeventloop.cpp:204
#8  0x0725f9dc in QThread::exec (this=0x985edd8) at thread/qthread.cpp:501
#9  0x0725facb in QThread::run (this=0x985edd8) at thread/qthread.cpp:568
#10 0x07262e70 in QThreadPrivate::start (arg=0x985edd8) at thread/qthread_unix.cpp:298
#11 0x00bb7d31 in start_thread (arg=0xb52b2b70) at pthread_create.c:304
#12 0x007c146e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 4 (Thread 0xb30bdb70 (LWP 8646)):
#0  0x009a5416 in __kernel_vsyscall ()
#1  0x00bbbe04 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0x007cf0f4 in __pthread_cond_timedwait (cond=0x9bf72d8, mutex=0x9bf72c0, abstime=0xb30bd288) at forward.c:152
#3  0x0726336f in wait (time=30000, this=0x9bf72c0) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0x9bf7268, mutex=0x9bf7264, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0x07255504 in QThreadPoolThread::run (this=0x9c02798) at concurrent/qthreadpool.cpp:141
#6  0x07262e70 in QThreadPrivate::start (arg=0x9c02798) at thread/qthread_unix.cpp:298
#7  0x00bb7d31 in start_thread (arg=0xb30bdb70) at pthread_create.c:304
#8  0x007c146e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 3 (Thread 0xb23b5b70 (LWP 8649)):
#0  0x009a5416 in __kernel_vsyscall ()
#1  0x00bbbe04 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0x007cf0f4 in __pthread_cond_timedwait (cond=0xc075878, mutex=0xc075860, abstime=0xb23b5288) at forward.c:152
#3  0x0726336f in wait (time=30000, this=0xc075860) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0xc075830, mutex=0xc07582c, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0x07255504 in QThreadPoolThread::run (this=0xb2655018) at concurrent/qthreadpool.cpp:141
#6  0x07262e70 in QThreadPrivate::start (arg=0xb2655018) at thread/qthread_unix.cpp:298
#7  0x00bb7d31 in start_thread (arg=0xb23b5b70) at pthread_create.c:304
#8  0x007c146e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xae6ffb70 (LWP 8650)):
#0  0x009a5416 in __kernel_vsyscall ()
#1  0x00bbbe04 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:236
#2  0x007cf0f4 in __pthread_cond_timedwait (cond=0xc075878, mutex=0xc075860, abstime=0xae6ff288) at forward.c:152
#3  0x0726336f in wait (time=30000, this=0xc075860) at thread/qwaitcondition_unix.cpp:84
#4  QWaitCondition::wait (this=0xc075830, mutex=0xc07582c, time=30000) at thread/qwaitcondition_unix.cpp:158
#5  0x07255504 in QThreadPoolThread::run (this=0xb25b0400) at concurrent/qthreadpool.cpp:141
#6  0x07262e70 in QThreadPrivate::start (arg=0xb25b0400) at thread/qthread_unix.cpp:298
#7  0x00bb7d31 in start_thread (arg=0xae6ffb70) at pthread_create.c:304
#8  0x007c146e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76ea730 (LWP 25886)):
[KCrash Handler]
#7  0x00000008 in ?? ()
#8  0x08503f44 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xc4005c0, hm=..., sc=-1079461432, rp=..., pu=8, db=..., contentLength=-4154844356) at access/qnetworkaccesshttpbackend.cpp:827
#9  0x0859ad0d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xc4005c0, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xb4906668) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#10 0x07389411 in QMetaCallEvent::placeMetaCall (this=0xb4935480, object=0xc4005c0) at kernel/qobject.cpp:525
#11 0x0739248b in QObject::event (this=0xc4005c0, e=0xb4935480) at kernel/qobject.cpp:1195
#12 0x0102f844 in notify_helper (e=0xb4935480, receiver=0xc4005c0, this=0x9785128) at kernel/qapplication.cpp:4555
#13 QApplicationPrivate::notify_helper (this=0x9785128, receiver=0xc4005c0, e=0xb4935480) at kernel/qapplication.cpp:4527
#14 0x01034c7d in QApplication::notify (this=0xb4935480, receiver=0xc4005c0, e=0xb4935480) at kernel/qapplication.cpp:4284
#15 0x002f9051 in KApplication::notify (this=0xbfa8c254, receiver=0xc4005c0, event=0xb4935480) at ../../kdeui/kernel/kapplication.cpp:311
#16 0x0737718e in QCoreApplication::notifyInternal (this=0xbfa8c254, receiver=0xc4005c0, event=0xb4935480) at kernel/qcoreapplication.cpp:876
#17 0x0737b2e8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9755ab8) at kernel/qcoreapplication.cpp:1500
#19 0x0737b61c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#20 0x073a9d74 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0x978a178) at kernel/qeventdispatcher_glib.cpp:279
#22 0x06c6025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0x06c60990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0x06c60c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0x073aa167 in QEventDispatcherGlib::processEvents (this=0x9756818, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0x010e4fda in QGuiEventDispatcherGlib::processEvents (this=0x9756818, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x07375d1d in QEventLoop::processEvents (this=0xbfa8c1b4, flags=...) at kernel/qeventloop.cpp:149
#28 0x07375fb9 in QEventLoop::exec (this=0xbfa8c1b4, flags=...) at kernel/qeventloop.cpp:204
#29 0x0737b6ca in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x0102d6a4 in QApplication::exec () at kernel/qapplication.cpp:3816
#31 0x0804ac91 in main (argc=) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 296624, bug 296617, bug 296613, bug 296485, bug 296042.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-03-26 06:21:13 UTC

*** This bug has been marked as a duplicate of bug 286307 ***