Bug 296042 - kmail crash upon changing folders
Summary: kmail crash upon changing folders
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-15 07:26 UTC by datweety
Modified: 2012-03-26 22:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.85 KB, text/plain)
2012-03-15 13:15 UTC, Thomas Tanghus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description datweety 2012-03-15 07:26:20 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1) "release 481"
Qt Version: 4.8.0
Operating System: Linux 3.2.9 x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
changing from "sent-folder" to a user folder causes 100% crash, when doing this 3 times. Just klicking onto a folder with (at the moment) one mail inside.
Procedure:
folder - sent folder - same folder - sent folder - same folder - crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f416f4e0780 (LWP 17177))]

Thread 7 (Thread 0x7f4156b04700 (LWP 17178)):
#0  0x00007f416735ea14 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f416bcecc12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f416bcecc49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f416735adaa in start_thread () from /lib64/libpthread.so.0
#4  0x00007f416c9e70ed in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f41561eb700 (LWP 17179)):
#0  0x00007f416c9df1d3 in poll () from /lib64/libc.so.6
#1  0x00007f4166daca98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f4166dacf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f416d15f956 in QEventDispatcherGlib::processEvents (this=0x7f41500008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f416d12f682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f416d12f8d7 in QEventLoop::exec (this=0x7f41561eae00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f416d030537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f416d03355b in QThreadPrivate::start (arg=0x78cac0) at thread/qthread_unix.cpp:298
#8  0x00007f416735adaa in start_thread () from /lib64/libpthread.so.0
#9  0x00007f416c9e70ed in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f4108ed3700 (LWP 17186)):
#0  0x00007f416735ed81 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f416d0339cf in wait (time=30000, this=0xe2c9f0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xe2c968, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f416d026ddf in QThreadPoolThread::run (this=0xe40810) at concurrent/qthreadpool.cpp:141
#4  0x00007f416d03355b in QThreadPrivate::start (arg=0xe40810) at thread/qthread_unix.cpp:298
#5  0x00007f416735adaa in start_thread () from /lib64/libpthread.so.0
#6  0x00007f416c9e70ed in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f4103b90700 (LWP 17231)):
#0  0x00007f416735ed81 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f416d0339cf in wait (time=30000, this=0x12dafb0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x12c9248, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f416d026ddf in QThreadPoolThread::run (this=0x12db9c0) at concurrent/qthreadpool.cpp:141
#4  0x00007f416d03355b in QThreadPrivate::start (arg=0x12db9c0) at thread/qthread_unix.cpp:298
#5  0x00007f416735adaa in start_thread () from /lib64/libpthread.so.0
#6  0x00007f416c9e70ed in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f4101efe700 (LWP 17238)):
#0  0x00007f416735ed81 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f416d0339cf in wait (time=30000, this=0x7f40f400a020) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f40f4009fc8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f416d026ddf in QThreadPoolThread::run (this=0x7f40f400a2c0) at concurrent/qthreadpool.cpp:141
#4  0x00007f416d03355b in QThreadPrivate::start (arg=0x7f40f400a2c0) at thread/qthread_unix.cpp:298
#5  0x00007f416735adaa in start_thread () from /lib64/libpthread.so.0
#6  0x00007f416c9e70ed in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f41016fd700 (LWP 17239)):
#0  0x00007f416735ed81 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f416d0339cf in wait (time=30000, this=0x7f40f400a020) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f40f4009fc8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f416d026ddf in QThreadPoolThread::run (this=0x7f40f400e340) at concurrent/qthreadpool.cpp:141
#4  0x00007f416d03355b in QThreadPrivate::start (arg=0x7f40f400e340) at thread/qthread_unix.cpp:298
#5  0x00007f416735adaa in start_thread () from /lib64/libpthread.so.0
#6  0x00007f416c9e70ed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f416f4e0780 (LWP 17177)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x1cd3a60, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f4168324379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x1cd3a60, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f416d149926 in QObject::event (this=0x1cd3a60, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f416db43e84 in notify_helper (e=0x7f40f4005350, receiver=0x1cd3a60, this=0x63f9d0) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x63f9d0, receiver=0x1cd3a60, e=0x7f40f4005350) at kernel/qapplication.cpp:4522
#11 0x00007f416db48d03 in QApplication::notify (this=0x7fff86a72d30, receiver=0x1cd3a60, e=0x7f40f4005350) at kernel/qapplication.cpp:4411
#12 0x00007f416e888656 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#13 0x00007f416d13089c in QCoreApplication::notifyInternal (this=0x7fff86a72d30, receiver=0x1cd3a60, event=0x7f40f4005350) at kernel/qcoreapplication.cpp:876
#14 0x00007f416d13413a in sendEvent (event=0x7f40f4005350, receiver=0x1cd3a60) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#16 0x00007f416d15f4c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f4166dac58d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f4166dacd88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f4166dacf59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f416d15f8ef in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f416dbe72de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f416d12f682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f416d12f8d7 in QEventLoop::exec (this=0x7fff86a72cc0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f416d134435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in main (argc=1, argv=0x7fff86a73358) at /usr/src/debug/kdepim-4.8.1/kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 296009.

Possible duplicates by query: bug 296009, bug 295978, bug 295786, bug 295112, bug 294125.

Reported using DrKonqi
Comment 1 Thomas Tanghus 2012-03-15 13:15:42 UTC
Created attachment 69641 [details]
New crash information added by DrKonqi

kontact (4.8.0) on KDE Platform 4.8.1 (4.8.1) using Qt 4.8.0

- What I was doing when the application crashed:

I selected another message - or I might have deleted a message so that it selected the next message by it self.

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x6377170, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fa77b52d299 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x6377170, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fa780367ba6 in QObject::event (this=0x6377170, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007fa780d42104 in notify_helper (e=0xcad5230, receiver=0x6377170, this=0x1be2bf0) at kernel/qapplication.cpp:4555
#10 QApplicationPrivate::notify_helper (this=0x1be2bf0, receiver=0x6377170, e=0xcad5230) at kernel/qapplication.cpp:4527
Comment 2 Christophe Giboudeaux 2012-03-26 22:19:23 UTC

*** This bug has been marked as a duplicate of bug 286307 ***