Bug 294125 - Crash when sending eMail with KMail2 / Kontakt in KDE 4.8
Summary: Crash when sending eMail with KMail2 / Kontakt in KDE 4.8
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 06:17 UTC by Denny
Modified: 2012-02-15 07:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Denny 2012-02-15 06:17:11 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 "release 2"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Just sending a (signed) eMail. Nothing special at all. Since KDE 4.8 upgrade, the regular crashes of Kontact/KMail are back. The situation has been a lot better already in 4.6/4.7

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9a2a38a760 (LWP 23111))]

Thread 3 (Thread 0x7f9a11d4d700 (LWP 23112)):
#0  0x00007f9a22216e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9a26ba2c12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f9a26ba2c49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f9a22212f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9a2789263d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9a11434700 (LWP 23113)):
#0  0x00007f9a21d02c45 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f9a21d0392d in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9a21d03f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9a28000956 in QEventDispatcherGlib::processEvents (this=0x7f9a0c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9a27fd0682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9a27fd08d7 in QEventLoop::exec (this=0x7f9a11433e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9a27ed1537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9a27ed455b in QThreadPrivate::start (arg=0x63f690) at thread/qthread_unix.cpp:298
#8  0x00007f9a22212f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9a2789263d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9a2a38a760 (LWP 23111)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff12d79bd0) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff12d79ee0) at access/qabstractnetworkcache.cpp:240
#8  0x00007f9a231505cc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0xae94330, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007f9a23151d24 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xae94330, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007f9a231dd379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xae94330, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007f9a27fea926 in QObject::event (this=0xae94330, e=<optimized out>) at kernel/qobject.cpp:1204
#12 0x00007f9a289e4e84 in notify_helper (e=0x7f998800b9b0, receiver=0xae94330, this=0x63e180) at kernel/qapplication.cpp:4550
#13 QApplicationPrivate::notify_helper (this=0x63e180, receiver=0xae94330, e=0x7f998800b9b0) at kernel/qapplication.cpp:4522
#14 0x00007f9a289e9d03 in QApplication::notify (this=0x7fff12d7a960, receiver=0xae94330, e=0x7f998800b9b0) at kernel/qapplication.cpp:4411
#15 0x00007f9a29728786 in KApplication::notify (this=0x7fff12d7a960, receiver=0xae94330, event=0x7f998800b9b0) at /usr/src/debug/kdelibs-4.8.0/kdeui/kernel/kapplication.cpp:311
#16 0x00007f9a27fd189c in QCoreApplication::notifyInternal (this=0x7fff12d7a960, receiver=0xae94330, event=0x7f998800b9b0) at kernel/qcoreapplication.cpp:876
#17 0x00007f9a27fd513a in sendEvent (event=0x7f998800b9b0, receiver=0xae94330) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#19 0x00007f9a280004c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007f9a21d0358d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f9a21d03d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f9a21d03f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f9a280008ef in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f9a28a882de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f9a27fd0682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f9a27fd08d7 in QEventLoop::exec (this=0x7fff12d7a8f0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f9a27fd5435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000403919 in ?? ()
#30 0x00007f9a277da23d in __libc_start_main () from /lib64/libc.so.6
#31 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 292500, bug 288324, bug 287874.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-02-15 07:30:48 UTC

*** This bug has been marked as a duplicate of bug 286307 ***