Bug 295786 - kontact crash when switching from akregator to kmail
Summary: kontact crash when switching from akregator to kmail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-11 19:09 UTC by Jürgen Richtsfeld
Modified: 2012-03-26 22:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Richtsfeld 2012-03-11 19:09:00 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.2.0-18-generic x86_64
Distribution: Ubuntu precise (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

i switchted from the news reader to the mail part of kontact. I've seen the most recently read email (a html mail) for a short time, then kontact crashed.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f56c77557c0 (LWP 2963))]

Thread 3 (Thread 0x7f56ab04a700 (LWP 3027)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f56c3f5bddc in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f56c3f5bf09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f56aa731700 (LWP 3035)):
#0  0x00007f56c4c84ab3 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f56c53fc95f in qt_safe_select (nfds=12, fdread=0x7f56a4000ac8, fdwrite=0x7f56a4000d60, fdexcept=0x7f56a4000ff8, orig_timeout=0x7f56aa730cf0) at kernel/qcore_unix.cpp:93
#2  0x00007f56c5401e02 in QEventDispatcherUNIXPrivate::doSelect (this=0x7f56a4000910, flags=..., timeout=0x7f56aa730cf0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007f56c54022f3 in QEventDispatcherUNIX::processEvents (this=0x7f56a40008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007f56c53cf2d2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f56c53cf527 in QEventLoop::exec (this=0x7f56aa730dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f56c52cef97 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f56c52d1fbb in QThreadPrivate::start (arg=0x1d90c00) at thread/qthread_unix.cpp:298
#8  0x00007f56bf422e9a in start_thread (arg=0x7f56aa731700) at pthread_create.c:308
#9  0x00007f56c4c8b74d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f56c77557c0 (LWP 2963)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x65f0570, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f56c02f81a9 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x65f0570, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f56c53e9a96 in QObject::event (this=0x65f0570, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f56c5dc56b4 in notify_helper (e=0x7f564000a010, receiver=0x65f0570, this=0x1d9b9a0) at kernel/qapplication.cpp:4555
#10 QApplicationPrivate::notify_helper (this=0x1d9b9a0, receiver=0x65f0570, e=0x7f564000a010) at kernel/qapplication.cpp:4527
#11 0x00007f56c5dca533 in QApplication::notify (this=0x7fffed6b63a0, receiver=0x65f0570, e=0x7f564000a010) at kernel/qapplication.cpp:4416
#12 0x00007f56c6afe906 in KApplication::notify (this=0x7fffed6b63a0, receiver=0x65f0570, event=0x7f564000a010) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f56c53d04ec in QCoreApplication::notifyInternal (this=0x7fffed6b63a0, receiver=0x65f0570, event=0x7f564000a010) at kernel/qcoreapplication.cpp:876
#14 0x00007f56c53d42ba in sendEvent (event=0x7f564000a010, receiver=0x65f0570) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1d5a380) at kernel/qcoreapplication.cpp:1500
#16 0x00007f56c5402280 in QEventDispatcherUNIX::processEvents (this=<optimized out>, flags=...) at kernel/qeventdispatcher_unix.cpp:898
#17 0x00007f56c5e6e948 in QEventDispatcherX11::processEvents (this=0x1d5bc10, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#18 0x00007f56c53cf2d2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#19 0x00007f56c53cf527 in QEventLoop::exec (this=0x7fffed6b6330, flags=...) at kernel/qeventloop.cpp:204
#20 0x00007f56c53d45b7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#21 0x0000000000403629 in main (argc=3, argv=0x7fffed6b69c8) at ../../../kontact/src/main.cpp:218

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 295112, bug 294125, bug 293735, bug 293656, bug 293458.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-26 22:18:39 UTC

*** This bug has been marked as a duplicate of bug 286307 ***