Bug 295978 - kmail/kontact crashes on "next mail"
Summary: kmail/kontact crashes on "next mail"
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 06:35 UTC by Mathias Homann
Modified: 2012-03-26 22:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Homann 2012-03-14 06:35:09 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1) "release 481"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.4-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

switched from one mail to another with a keyboard shotcut that I've set up for "next unread"

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f597d4ff760 (LWP 8834))]

Thread 4 (Thread 0x7f5964aca700 (LWP 8835)):
#0  0x00007f597539be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f5979d2ac12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f5979d2ac49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f5975397f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f597aa1c10d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f59641c1700 (LWP 8837)):
#0  0x00007fffd9dff8de in ?? ()
#1  0x00007f5972e73d9a in clock_gettime () from /lib64/librt.so.1
#2  0x00007f597b0b3a24 in do_gettime (frac=0x7f59641c0bc8, sec=0x7f59641c0bc0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f597b18a0bd in QTimerInfoList::updateCurrentTime (this=0x7f595c0020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f597b18a3f3 in QTimerInfoList::timerWait (this=0x7f595c0020d0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f597b188e2c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f59641c0c8c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f5974e87b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#8  0x00007f5974e8892d in ?? () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f5974e88f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f597b189956 in QEventDispatcherGlib::processEvents (this=0x7f595c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f597b159682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f597b1598d7 in QEventLoop::exec (this=0x7f59641c0e20, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f597b05a537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f597b05d55b in QThreadPrivate::start (arg=0x655ef0) at thread/qthread_unix.cpp:298
#15 0x00007f5975397f05 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f597aa1c10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f5908ce7700 (LWP 9013)):
#0  0x00007fffd9dff8de in ?? ()
#1  0x00007f5972e73d9a in clock_gettime () from /lib64/librt.so.1
#2  0x00007f597b0b3a24 in do_gettime (frac=0x7f5908ce6b78, sec=0x7f5908ce6b70) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f597b18a0bd in QTimerInfoList::updateCurrentTime (this=0x7f59040020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f597b18a3f3 in QTimerInfoList::timerWait (this=0x7f59040020d0, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f597b188e2c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f5908ce6c5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f597b188ed5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f5974e87b22 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#9  0x00007f5974e8892d in ?? () from /usr/lib64/libglib-2.0.so.0
#10 0x00007f5974e88f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#11 0x00007f597b189956 in QEventDispatcherGlib::processEvents (this=0x7f59040008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f597b159682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f597b1598d7 in QEventLoop::exec (this=0x7f5908ce6df0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f597b05a537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007f597b13948f in QInotifyFileSystemWatcherEngine::run (this=0x14d7500) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f597b05d55b in QThreadPrivate::start (arg=0x14d7500) at thread/qthread_unix.cpp:298
#17 0x00007f5975397f05 in start_thread () from /lib64/libpthread.so.0
#18 0x00007f597aa1c10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f597d4ff760 (LWP 8834)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x708a420, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f5976362379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x708a420, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f597b173926 in QObject::event (this=0x708a420, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f597bb6de84 in notify_helper (e=0x7f58ec004130, receiver=0x708a420, this=0x639630) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x639630, receiver=0x708a420, e=0x7f58ec004130) at kernel/qapplication.cpp:4522
#11 0x00007f597bb72d03 in QApplication::notify (this=0x7fffd9d9d780, receiver=0x708a420, e=0x7f58ec004130) at kernel/qapplication.cpp:4411
#12 0x00007f597c8b2656 in KApplication::notify (this=0x7fffd9d9d780, receiver=0x708a420, event=0x7f58ec004130) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#13 0x00007f597b15a89c in QCoreApplication::notifyInternal (this=0x7fffd9d9d780, receiver=0x708a420, event=0x7f58ec004130) at kernel/qcoreapplication.cpp:876
#14 0x00007f597b15e13a in sendEvent (event=0x7f58ec004130, receiver=0x708a420) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60da60) at kernel/qcoreapplication.cpp:1500
#16 0x00007f597b1894c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f5974e8858d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f5974e88d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f5974e88f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f597b1898ef in QEventDispatcherGlib::processEvents (this=0x60d320, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f597bc112de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f597b159682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f597b1598d7 in QEventLoop::exec (this=0x7fffd9d9d710, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f597b15e435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000403919 in ?? ()
#27 0x00007f597a96223d in __libc_start_main () from /lib64/libc.so.6
#28 0x0000000000403e51 in _start ()

Possible duplicates by query: bug 295786, bug 295112, bug 294125, bug 293735, bug 293656.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-26 22:18:51 UTC

*** This bug has been marked as a duplicate of bug 286307 ***