Bug 296545 - It crashed after I start it
Summary: It crashed after I start it
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-22 11:04 UTC by Hartwig
Modified: 2012-03-22 11:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hartwig 2012-03-22 11:04:52 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I'm only start the programm, after that, it crashed. I don't know why

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d1930 (LWP 2583))]

Thread 2 (Thread 0xb555eb70 (LWP 2587)):
#0  0x00918d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00aea7d5 in do_gettime (frac=0xb555e020, sec=0xb555e018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00bbd4b6 in QTimerInfoList::updateCurrentTime (this=0x9b4e594) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00bbd80a in QTimerInfoList::timerWait (this=0x9b4e594, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00bbc053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb555e12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00bbc0ed in timerSourcePrepare (source=0x9b4e560, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x02aa388c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x02aa4637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x02aa4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00bbcb37 in QEventDispatcherGlib::processEvents (this=0x9a55308, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00b8d1dd in QEventLoop::processEvents (this=0xb555e2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00b8d421 in QEventLoop::exec (this=0xb555e2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00a9090b in QThread::exec (this=0x9b472e0) at thread/qthread.cpp:498
#14 0x00b6de2d in QInotifyFileSystemWatcherEngine::run (this=0x9b472e0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00a937b3 in QThreadPrivate::start (arg=0x9b472e0) at thread/qthread_unix.cpp:331
#16 0x0089bd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x011d646e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d1930 (LWP 2583)):
[KCrash Handler]
#7  0x00ae7e11 in QtPrivate::QStringList_contains (that=0xbfcdbb44, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfcdbb44) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x99e4338) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x99e4338, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcdbd64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00b94b7d in metacall (argv=0xbfcdbd64, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x99e4338) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x99e4338, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfcdbd64) at kernel/qmetaobject.cpp:232
#13 0x00ba3a6a in QMetaObject::activate (sender=0x9a3d5a8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9a3d5a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9a3d5a8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcdbea8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00b94b7d in metacall (argv=0xbfcdbea8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9a3d5a8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9a3d5a8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfcdbea8) at kernel/qmetaobject.cpp:232
#18 0x00ba3a6a in QMetaObject::activate (sender=0x99e4338, m=0x80950c0, local_signal_index=0, argv=0xbfcdbea8) at kernel/qobject.cpp:3278
#19 0x008cc7c5 in MuonMainWindow::backendReady (this=0x99e4338, _t1=0x98eb4b0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x008cc933 in MuonMainWindow::initObject (this=0x99e4338) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x99e4338) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x99e4338, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcdbfd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00b94b7d in metacall (argv=0xbfcdbfd4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x99e4338) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x99e4338, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfcdbfd4) at kernel/qmetaobject.cpp:232
#25 0x00ba3a6a in QMetaObject::activate (sender=0x9a5a028, m=0xcc4238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00bab375 in QSingleShotTimer::timeout (this=0x9a5a028) at .moc/release-shared/qtimer.moc:82
#27 0x00bab42c in QSingleShotTimer::timerEvent (this=0x9a5a028) at kernel/qtimer.cpp:308
#28 0x00ba6994 in QObject::event (this=0x9a5a028, e=0xbfcdc3cc) at kernel/qobject.cpp:1181
#29 0x043f5d84 in notify_helper (e=0xbfcdc3cc, receiver=0x9a5a028, this=0x98e85d8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x98e85d8, receiver=0x9a5a028, e=0xbfcdc3cc) at kernel/qapplication.cpp:4458
#31 0x043fb133 in QApplication::notify (this=0xbfcdc3cc, receiver=0x9a5a028, e=0xbfcdc3cc) at kernel/qapplication.cpp:3886
#32 0x00eb0971 in KApplication::notify (this=0xbfcdc6e0, receiver=0x9a5a028, event=0xbfcdc3cc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00b8e19e in QCoreApplication::notifyInternal (this=0xbfcdc6e0, receiver=0x9a5a028, event=0xbfcdc3cc) at kernel/qcoreapplication.cpp:787
#34 0x00bbec10 in sendEvent (event=0xbfcdc3cc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x98e4334) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00bbc122 in timerSourceDispatch (source=0x98e4300) at kernel/qeventdispatcher_glib.cpp:184
#37 0x02aa425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02aa4990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02aa4c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00bbcada in QEventDispatcherGlib::processEvents (this=0x98c5238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x044ade7a in QGuiEventDispatcherGlib::processEvents (this=0x98c5238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00b8d1dd in QEventLoop::processEvents (this=0xbfcdc644, flags=...) at kernel/qeventloop.cpp:149
#43 0x00b8d421 in QEventLoop::exec (this=0xbfcdc644, flags=...) at kernel/qeventloop.cpp:201
#44 0x00b9219d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x043f3924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296452, bug 296441, bug 296357, bug 296351, bug 296323.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-22 11:18:07 UTC

*** This bug has been marked as a duplicate of bug 291262 ***