Bug 296283 - muon opening
Summary: muon opening
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-18 15:44 UTC by tymop
Modified: 2012-03-20 13:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.60 KB, text/plain)
2012-03-20 13:38 UTC, korvo71
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tymop 2012-03-18 15:44:06 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Nothing other was started.
the system was just installed 10 minutes before.
I start muon and it crashed.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb47f4930 (LWP 2273))]

Thread 2 (Thread 0xb2110b70 (LWP 2277)):
#0  0xb5341d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb72207d5 in do_gettime (frac=0xb2110020, sec=0xb2110018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb72f34b6 in QTimerInfoList::updateCurrentTime (this=0x89de3cc) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb72f380a in QTimerInfoList::timerWait (this=0x89de3cc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb72f2053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb211012c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb72f20ed in timerSourcePrepare (source=0x89de398, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb528788c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb5288637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb5288c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb72f2b37 in QEventDispatcherGlib::processEvents (this=0x8916ae0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb72c31dd in QEventLoop::processEvents (this=0xb21102b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb72c3421 in QEventLoop::exec (this=0xb21102b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb71c690b in QThread::exec (this=0x89d7b88) at thread/qthread.cpp:498
#14 0xb72a3e2d in QInotifyFileSystemWatcherEngine::run (this=0x89d7b88) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb71c97b3 in QThreadPrivate::start (arg=0x89d7b88) at thread/qthread_unix.cpp:331
#16 0xb536ed31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5dbd46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb47f4930 (LWP 2273)):
[KCrash Handler]
#7  0xb721de11 in QtPrivate::QStringList_contains (that=0xbfb11744, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb11744) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x888d718) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x888d718, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb11964) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb72cab7d in metacall (argv=0xbfb11964, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x888d718) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x888d718, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb11964) at kernel/qmetaobject.cpp:232
#13 0xb72d9a6a in QMetaObject::activate (sender=0x87ffc60, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x87ffc60) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x87ffc60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb11aa8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb72cab7d in metacall (argv=0xbfb11aa8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x87ffc60) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x87ffc60, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb11aa8) at kernel/qmetaobject.cpp:232
#18 0xb72d9a6a in QMetaObject::activate (sender=0x888d718, m=0x80950c0, local_signal_index=0, argv=0xbfb11aa8) at kernel/qobject.cpp:3278
#19 0xb773a7c5 in MuonMainWindow::backendReady (this=0x888d718, _t1=0x88b37e0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb773a933 in MuonMainWindow::initObject (this=0x888d718) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x888d718) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x888d718, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb11bd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb72cab7d in metacall (argv=0xbfb11bd4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x888d718) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x888d718, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb11bd4) at kernel/qmetaobject.cpp:232
#25 0xb72d9a6a in QMetaObject::activate (sender=0x88f3398, m=0xb73fa238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb72e1375 in QSingleShotTimer::timeout (this=0x88f3398) at .moc/release-shared/qtimer.moc:82
#27 0xb72e142c in QSingleShotTimer::timerEvent (this=0x88f3398) at kernel/qtimer.cpp:308
#28 0xb72dc994 in QObject::event (this=0x88f3398, e=0xbfb11fcc) at kernel/qobject.cpp:1181
#29 0xb60aad84 in notify_helper (e=0xbfb11fcc, receiver=0x88f3398, this=0x8798150) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8798150, receiver=0x88f3398, e=0xbfb11fcc) at kernel/qapplication.cpp:4458
#31 0xb60b0133 in QApplication::notify (this=0xbfb11fcc, receiver=0x88f3398, e=0xbfb11fcc) at kernel/qapplication.cpp:3886
#32 0xb6ec9971 in KApplication::notify (this=0xbfb122e0, receiver=0x88f3398, event=0xbfb11fcc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb72c419e in QCoreApplication::notifyInternal (this=0xbfb122e0, receiver=0x88f3398, event=0xbfb11fcc) at kernel/qcoreapplication.cpp:787
#34 0xb72f4c10 in sendEvent (event=0xbfb11fcc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8796f34) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb72f2122 in timerSourceDispatch (source=0x8796f00) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb528825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb5288990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb5288c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb72f2ada in QEventDispatcherGlib::processEvents (this=0x8776238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb6162e7a in QGuiEventDispatcherGlib::processEvents (this=0x8776238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb72c31dd in QEventLoop::processEvents (this=0xbfb12244, flags=...) at kernel/qeventloop.cpp:149
#43 0xb72c3421 in QEventLoop::exec (this=0xbfb12244, flags=...) at kernel/qeventloop.cpp:201
#44 0xb72c819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb60a8924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296230, bug 296195, bug 296189, bug 296172, bug 296170.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-18 15:58:30 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 korvo71 2012-03-20 13:38:51 UTC
Created attachment 69761 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

Any other application was running.

-- Backtrace (Reduced):
#7  0x001eee11 in QtPrivate::QStringList_contains (that=0xbf910794, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf910794) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x885beb8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x885beb8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9109b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0029bb7d in metacall (argv=0xbf9109b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x885beb8) at kernel/qmetaobject.cpp:237