Bug 296230 - Muin Crash
Summary: Muin Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-17 19:21 UTC by Gerhard Decher
Modified: 2012-03-17 23:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.13 KB, text/plain)
2012-03-17 19:53 UTC, alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Decher 2012-03-17 19:21:21 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:updating the system, muon got stuck with 41%. I switched the system off manually

- Unusual behavior I noticed:

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7743930 (LWP 2088))]

Thread 2 (Thread 0xb58edb70 (LWP 2089)):
#0  0x0133fd10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x0066d7d5 in do_gettime (frac=0xb58ed020, sec=0xb58ed018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x007404b6 in QTimerInfoList::updateCurrentTime (this=0xb4f01abc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0074080a in QTimerInfoList::timerWait (this=0xb4f01abc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0073f053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb58ed12c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0073f0ed in timerSourcePrepare (source=0xb4f01a88, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0138788c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01388637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01388c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x0073fb37 in QEventDispatcherGlib::processEvents (this=0xb4f00468, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x007101dd in QEventLoop::processEvents (this=0xb58ed2b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00710421 in QEventLoop::exec (this=0xb58ed2b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0061390b in QThread::exec (this=0x8de4088) at thread/qthread.cpp:498
#14 0x006f0e2d in QInotifyFileSystemWatcherEngine::run (this=0x8de4088) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x006167b3 in QThreadPrivate::start (arg=0x8de4088) at thread/qthread_unix.cpp:331
#16 0x07c41d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0091f46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb7743930 (LWP 2088)):
[KCrash Handler]
#7  0x0066ae11 in QtPrivate::QStringList_contains (that=0xbfea77a4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfea77a4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8dca640) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8dca640, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfea79c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00717b7d in metacall (argv=0xbfea79c4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8dca640) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8dca640, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfea79c4) at kernel/qmetaobject.cpp:232
#13 0x00726a6a in QMetaObject::activate (sender=0x8e661b0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8e661b0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8e661b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfea7b08) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00717b7d in metacall (argv=0xbfea7b08, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8e661b0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8e661b0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfea7b08) at kernel/qmetaobject.cpp:232
#18 0x00726a6a in QMetaObject::activate (sender=0x8dca640, m=0x80950c0, local_signal_index=0, argv=0xbfea7b08) at kernel/qobject.cpp:3278
#19 0x00ca07c5 in MuonMainWindow::backendReady (this=0x8dca640, _t1=0x8dcc720) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00ca0933 in MuonMainWindow::initObject (this=0x8dca640) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8dca640) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8dca640, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfea7c34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00717b7d in metacall (argv=0xbfea7c34, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8dca640) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8dca640, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfea7c34) at kernel/qmetaobject.cpp:232
#25 0x00726a6a in QMetaObject::activate (sender=0x8e17200, m=0x847238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x0072e375 in QSingleShotTimer::timeout (this=0x8e17200) at .moc/release-shared/qtimer.moc:82
#27 0x0072e42c in QSingleShotTimer::timerEvent (this=0x8e17200) at kernel/qtimer.cpp:308
#28 0x00729994 in QObject::event (this=0x8e17200, e=0xbfea802c) at kernel/qobject.cpp:1181
#29 0x02284d84 in notify_helper (e=0xbfea802c, receiver=0x8e17200, this=0x8cec390) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8cec390, receiver=0x8e17200, e=0xbfea802c) at kernel/qapplication.cpp:4458
#31 0x0228a133 in QApplication::notify (this=0xbfea802c, receiver=0x8e17200, e=0xbfea802c) at kernel/qapplication.cpp:3886
#32 0x0106f971 in KApplication::notify (this=0xbfea8340, receiver=0x8e17200, event=0xbfea802c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0071119e in QCoreApplication::notifyInternal (this=0xbfea8340, receiver=0x8e17200, event=0xbfea802c) at kernel/qcoreapplication.cpp:787
#34 0x00741c10 in sendEvent (event=0xbfea802c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8ce8834) at kernel/qeventdispatcher_unix.cpp:603
#36 0x0073f122 in timerSourceDispatch (source=0x8ce8800) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0138825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x01388990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x01388c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x0073fada in QEventDispatcherGlib::processEvents (this=0x8cca238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x0233ce7a in QGuiEventDispatcherGlib::processEvents (this=0x8cca238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007101dd in QEventLoop::processEvents (this=0xbfea82a4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00710421 in QEventLoop::exec (this=0xbfea82a4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0071519d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x02282924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296224, bug 296195, bug 296189, bug 296172, bug 296170.

Reported using DrKonqi
Comment 1 alex 2012-03-17 19:53:46 UTC
Created attachment 69694 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

i have start application MOUN and then it was crashed

-- Backtrace (Reduced):
#6  0x00007f9647094a5e in QtPrivate::QStringList_contains (that=0x7fffa5ae4300, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffa5ae4300) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x103bff0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x103bff0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa5ae48d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x108c440, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffa5ae4a30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 2 Jekyll Wu 2012-03-17 23:56:58 UTC

*** This bug has been marked as a duplicate of bug 291262 ***