Bug 296195 - Open Muon
Summary: Open Muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-17 09:15 UTC by David
Modified: 2012-03-17 09:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 11.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David 2012-03-17 09:15:43 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I just try to open Muon software to install new packages, but never work!

To open i just go to KDE start button -> Machine -> Muon

Intel i3-550, desktop board DP55WB, 8Gb ram, Nvidia GygaByte 430 Low profile, kbuntu 11.10 amd64, 1920x1080 resolution using HD 1080p cable.

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f69ef808780 (LWP 2196))]

Thread 2 (Thread 0x7f69db0a2700 (LWP 2197)):
#0  0x00007f69ec3cf473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f69e8c42f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f69e8c43429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f69ee58df3e in QEventDispatcherGlib::processEvents (this=0x26c92a0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f69ee561cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f69ee561ef7 in QEventLoop::exec (this=0x7f69db0a1dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f69ee47927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f69ee544cbf in QInotifyFileSystemWatcherEngine::run (this=0x2729830) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f69ee47bd05 in QThreadPrivate::start (arg=0x2729830) at thread/qthread_unix.cpp:331
#9  0x00007f69e9724efc in start_thread (arg=0x7f69db0a2700) at pthread_create.c:304
#10 0x00007f69ec3db59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f69ef808780 (LWP 2196)):
[KCrash Handler]
#6  0x00007f69ee4c9a5e in QtPrivate::QStringList_contains (that=0x7fff82446a50, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff82446a50) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x26c8890) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x26c8890, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff82447020) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f69ee575eba in QMetaObject::activate (sender=0x2748220, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2748220, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff82447180) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f69ee575eba in QMetaObject::activate (sender=0x26c8890, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff82447180) at kernel/qobject.cpp:3278
#13 0x00007f69ef3ebe7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x26a4f20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f69ef3ebf8e in MuonMainWindow::initObject (this=0x26c8890) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x26c8890) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x26c8890, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff82447250) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f69ee575eba in QMetaObject::activate (sender=0x2745b20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f69ee57df7f in QSingleShotTimer::timerEvent (this=0x2745b20) at kernel/qtimer.cpp:308
#19 0x00007f69ee579789 in QObject::event (this=0x2745b20, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f69ecb9c474 in notify_helper (e=0x7fff824477c0, receiver=0x2745b20, this=0x259af30) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x259af30, receiver=0x2745b20, e=0x7fff824477c0) at kernel/qapplication.cpp:4458
#22 0x00007f69ecba12e1 in QApplication::notify (this=0x7fff82447ac0, receiver=0x2745b20, e=0x7fff824477c0) at kernel/qapplication.cpp:4365
#23 0x00007f69edd81466 in KApplication::notify (this=0x7fff82447ac0, receiver=0x2745b20, event=0x7fff824477c0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f69ee562afc in QCoreApplication::notifyInternal (this=0x7fff82447ac0, receiver=0x2745b20, event=0x7fff824477c0) at kernel/qcoreapplication.cpp:787
#25 0x00007f69ee58fd62 in sendEvent (event=0x7fff824477c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x25941f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f69ee58d514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f69e8c42a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f69e8c43258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f69e8c43429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f69ee58ded6 in QEventDispatcherGlib::processEvents (this=0x256e6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f69ecc4410e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f69ee561cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f69ee561ef7 in QEventLoop::exec (this=0x7fff82447a50, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f69ee566789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff82447d38) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296189, bug 296172, bug 296170, bug 296121, bug 296099.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-17 09:20:00 UTC

*** This bug has been marked as a duplicate of bug 291262 ***