Bug 296189 - Muon падает сразу после запуска.
Summary: Muon падает сразу после запуска.
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-17 07:14 UTC by Roman Yurin
Modified: 2012-03-17 08:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Yurin 2012-03-17 07:14:09 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Ошибка появлась после установки последних обновлений. Приложение запускается, загружает список программ (примерно 10 сек), до того, как список успевает отобразиться происходит сбой.

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1a024cf780 (LWP 1966))]

Thread 2 (Thread 0x7f19ed968700 (LWP 1967)):
#0  0x00007f19ff096473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f19fb909f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f19fb90a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1a01254f3e in QEventDispatcherGlib::processEvents (this=0x1e9a980, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f1a01228cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1a01228ef7 in QEventLoop::exec (this=0x7f19ed967dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f1a0114027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f1a0120bcbf in QInotifyFileSystemWatcherEngine::run (this=0x1ea4640) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1a01142d05 in QThreadPrivate::start (arg=0x1ea4640) at thread/qthread_unix.cpp:331
#9  0x00007f19fc3ebefc in start_thread (arg=0x7f19ed968700) at pthread_create.c:304
#10 0x00007f19ff0a259d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1a024cf780 (LWP 1966)):
[KCrash Handler]
#6  0x00007f1a01190a5e in QtPrivate::QStringList_contains (that=0x7fff6275a060, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff6275a060) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1df34b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1df34b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6275a630) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f1a0123ceba in QMetaObject::activate (sender=0x1fe1a60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1fe1a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6275a790) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f1a0123ceba in QMetaObject::activate (sender=0x1df34b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6275a790) at kernel/qobject.cpp:3278
#13 0x00007f1a020b2e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1d0ff10) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f1a020b2f8e in MuonMainWindow::initObject (this=0x1df34b0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1df34b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1df34b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff6275a860) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f1a0123ceba in QMetaObject::activate (sender=0x1e8da00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f1a01244f7f in QSingleShotTimer::timerEvent (this=0x1e8da00) at kernel/qtimer.cpp:308
#19 0x00007f1a01240789 in QObject::event (this=0x1e8da00, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f19ff863474 in notify_helper (e=0x7fff6275add0, receiver=0x1e8da00, this=0x1cb19d0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1cb19d0, receiver=0x1e8da00, e=0x7fff6275add0) at kernel/qapplication.cpp:4458
#22 0x00007f19ff8682e1 in QApplication::notify (this=0x7fff6275b0d0, receiver=0x1e8da00, e=0x7fff6275add0) at kernel/qapplication.cpp:4365
#23 0x00007f1a00a48466 in KApplication::notify (this=0x7fff6275b0d0, receiver=0x1e8da00, event=0x7fff6275add0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f1a01229afc in QCoreApplication::notifyInternal (this=0x7fff6275b0d0, receiver=0x1e8da00, event=0x7fff6275add0) at kernel/qcoreapplication.cpp:787
#25 0x00007f1a01256d62 in sendEvent (event=0x7fff6275add0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1cae2f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f1a01254514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f19fb909a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f19fb90a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f19fb90a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f1a01254ed6 in QEventDispatcherGlib::processEvents (this=0x1c8a6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f19ff90b10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f1a01228cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f1a01228ef7 in QEventLoop::exec (this=0x7fff6275b060, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f1a0122d789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff6275b348) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 296172, bug 296170, bug 296121, bug 296099, bug 296044.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-17 08:18:04 UTC

*** This bug has been marked as a duplicate of bug 291262 ***