Bug 296172 - Muon не запускается - выдает сообщение об ошибке!!!
Summary: Muon не запускается - выдает сообщение об ошибке!!!
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-16 19:35 UTC by ably
Modified: 2012-03-17 00:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ably 2012-03-16 19:35:22 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Muon не запускается - выдает сообщение об ошибке!!!
Пробовал и перезагружать и запукать несколько раз - не стартует приложение...

- What I was doing when the application crashed:

- Unusual behavior I noticed:

- Custom settings of the application:

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b2930 (LWP 2530))]

Thread 2 (Thread 0xb5573b70 (LWP 2534)):
#0  0x00a26d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x003817d5 in do_gettime (frac=0xb5573020, sec=0xb5573018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x004544b6 in QTimerInfoList::updateCurrentTime (this=0x85d0264) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0045480a in QTimerInfoList::timerWait (this=0x85d0264, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00453053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb557312c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x004530ed in timerSourcePrepare (source=0x85d0230, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x051ce88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x051cf637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x051cfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00453b37 in QEventDispatcherGlib::processEvents (this=0x8511518, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x004241dd in QEventLoop::processEvents (this=0xb55732b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00424421 in QEventLoop::exec (this=0xb55732b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0032790b in QThread::exec (this=0x85cf2b8) at thread/qthread.cpp:498
#14 0x00404e2d in QInotifyFileSystemWatcherEngine::run (this=0x85cf2b8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0032a7b3 in QThreadPrivate::start (arg=0x85cf2b8) at thread/qthread_unix.cpp:331
#16 0x00f11d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0063346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77b2930 (LWP 2530)):
[KCrash Handler]
#7  0x0037ee11 in QtPrivate::QStringList_contains (that=0xbfd046c4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd046c4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x847e8f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x847e8f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd048e4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0042bb7d in metacall (argv=0xbfd048e4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x847e8f8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x847e8f8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd048e4) at kernel/qmetaobject.cpp:232
#13 0x0043aa6a in QMetaObject::activate (sender=0x84ca6d8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x84ca6d8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x84ca6d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd04a28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0042bb7d in metacall (argv=0xbfd04a28, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x84ca6d8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x84ca6d8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd04a28) at kernel/qmetaobject.cpp:232
#18 0x0043aa6a in QMetaObject::activate (sender=0x847e8f8, m=0x80950c0, local_signal_index=0, argv=0xbfd04a28) at kernel/qobject.cpp:3278
#19 0x00b017c5 in MuonMainWindow::backendReady (this=0x847e8f8, _t1=0x84da030) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00b01933 in MuonMainWindow::initObject (this=0x847e8f8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x847e8f8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x847e8f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd04b54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0042bb7d in metacall (argv=0xbfd04b54, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x847e8f8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x847e8f8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd04b54) at kernel/qmetaobject.cpp:232
#25 0x0043aa6a in QMetaObject::activate (sender=0x84e06d8, m=0x55b238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00442375 in QSingleShotTimer::timeout (this=0x84e06d8) at .moc/release-shared/qtimer.moc:82
#27 0x0044242c in QSingleShotTimer::timerEvent (this=0x84e06d8) at kernel/qtimer.cpp:308
#28 0x0043d994 in QObject::event (this=0x84e06d8, e=0xbfd04f4c) at kernel/qobject.cpp:1181
#29 0x01de3d84 in notify_helper (e=0xbfd04f4c, receiver=0x84e06d8, this=0x8379ee0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8379ee0, receiver=0x84e06d8, e=0xbfd04f4c) at kernel/qapplication.cpp:4458
#31 0x01de9133 in QApplication::notify (this=0xbfd04f4c, receiver=0x84e06d8, e=0xbfd04f4c) at kernel/qapplication.cpp:3886
#32 0x0115a971 in KApplication::notify (this=0xbfd05260, receiver=0x84e06d8, event=0xbfd04f4c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0042519e in QCoreApplication::notifyInternal (this=0xbfd05260, receiver=0x84e06d8, event=0xbfd04f4c) at kernel/qcoreapplication.cpp:787
#34 0x00455c10 in sendEvent (event=0xbfd04f4c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x837c9b4) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00453122 in timerSourceDispatch (source=0x837c980) at kernel/qeventdispatcher_glib.cpp:184
#37 0x051cf25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x051cf990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x051cfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00453ada in QEventDispatcherGlib::processEvents (this=0x8357238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01e9be7a in QGuiEventDispatcherGlib::processEvents (this=0x8357238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x004241dd in QEventLoop::processEvents (this=0xbfd051c4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00424421 in QEventLoop::exec (this=0xbfd051c4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0042919d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x01de1924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296170, bug 296121, bug 296099, bug 296044, bug 296017.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-03-17 00:52:30 UTC

*** This bug has been marked as a duplicate of bug 291262 ***