Bug 296170 - falla de muon
Summary: falla de muon
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-16 18:56 UTC by lordrios
Modified: 2012-03-17 00:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lordrios 2012-03-16 18:56:42 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
inicie el centro de software muon y el mismo no arranco solo se cerro y cada ves que lo inicio se cierra

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76d9930 (LWP 2919))]

Thread 2 (Thread 0xb5449b70 (LWP 2923)):
#0  0x007ffd10 in __GI_clock_gettime (clock_id=1, tp=0xb5449028) at ../sysdeps/unix/clock_gettime.c:116
#1  0x005b07d5 in do_gettime (frac=0xb5449020, sec=0xb5449018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x006834b6 in QTimerInfoList::updateCurrentTime (this=0x94befb4) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0068380a in QTimerInfoList::timerWait (this=0x94befb4, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00682053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb544912c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x006820ed in timerSourcePrepare (source=0x94bef80, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x08beb88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x08bec637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x08becc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00682b37 in QEventDispatcherGlib::processEvents (this=0x94b98c8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x006531dd in QEventLoop::processEvents (this=0xb54492b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00653421 in QEventLoop::exec (this=0xb54492b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x0055690b in QThread::exec (this=0x94b9248) at thread/qthread.cpp:498
#14 0x00633e2d in QInotifyFileSystemWatcherEngine::run (this=0x94b9248) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x005597b3 in QThreadPrivate::start (arg=0x94b9248) at thread/qthread_unix.cpp:331
#16 0x00860d31 in start_thread (arg=0xb5449b70) at pthread_create.c:304
#17 0x019ee46e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76d9930 (LWP 2919)):
[KCrash Handler]
#7  0x005ade11 in QtPrivate::QStringList_contains (that=0xbff92394, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff92394) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x934fe00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x934fe00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff925b4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0065ab7d in metacall (argv=0xbff925b4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x934fe00) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x934fe00, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff925b4) at kernel/qmetaobject.cpp:232
#13 0x00669a6a in QMetaObject::activate (sender=0x93cb600, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x93cb600) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x93cb600, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff926f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0065ab7d in metacall (argv=0xbff926f8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x93cb600) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x93cb600, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbff926f8) at kernel/qmetaobject.cpp:232
#18 0x00669a6a in QMetaObject::activate (sender=0x934fe00, m=0x80950c0, local_signal_index=0, argv=0xbff926f8) at kernel/qobject.cpp:3278
#19 0x0048b7c5 in MuonMainWindow::backendReady (this=0x934fe00, _t1=0x93b73f0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x0048b933 in MuonMainWindow::initObject (this=0x934fe00) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x934fe00) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x934fe00, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff92824) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0065ab7d in metacall (argv=0xbff92824, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x934fe00) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x934fe00, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbff92824) at kernel/qmetaobject.cpp:232
#25 0x00669a6a in QMetaObject::activate (sender=0x93d5758, m=0x78a238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00671375 in QSingleShotTimer::timeout (this=0x93d5758) at .moc/release-shared/qtimer.moc:82
#27 0x0067142c in QSingleShotTimer::timerEvent (this=0x93d5758) at kernel/qtimer.cpp:308
#28 0x0066c994 in QObject::event (this=0x93d5758, e=0xbff92c1c) at kernel/qobject.cpp:1181
#29 0x053edd84 in notify_helper (e=0xbff92c1c, receiver=0x93d5758, this=0x9268248) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9268248, receiver=0x93d5758, e=0xbff92c1c) at kernel/qapplication.cpp:4458
#31 0x053f3133 in QApplication::notify (this=0xbff92c1c, receiver=0x93d5758, e=0xbff92c1c) at kernel/qapplication.cpp:3886
#32 0x00abc971 in KApplication::notify (this=0xbff92f30, receiver=0x93d5758, event=0xbff92c1c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0065419e in QCoreApplication::notifyInternal (this=0xbff92f30, receiver=0x93d5758, event=0xbff92c1c) at kernel/qcoreapplication.cpp:787
#34 0x00684c10 in sendEvent (event=0xbff92c1c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x926c464) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00682122 in timerSourceDispatch (source=0x926c430) at kernel/qeventdispatcher_glib.cpp:184
#37 0x08bec25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x08bec990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x08becc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00682ada in QEventDispatcherGlib::processEvents (this=0x924b268, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x054a5e7a in QGuiEventDispatcherGlib::processEvents (this=0x924b268, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006531dd in QEventLoop::processEvents (this=0xbff92e94, flags=...) at kernel/qeventloop.cpp:149
#43 0x00653421 in QEventLoop::exec (this=0xbff92e94, flags=...) at kernel/qeventloop.cpp:201
#44 0x0065819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x053eb924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 296121, bug 296099, bug 296044, bug 296017, bug 296004.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-17 00:16:19 UTC

*** This bug has been marked as a duplicate of bug 291262 ***