Bug 296224 - dpkg do not run
Summary: dpkg do not run
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-17 17:15 UTC by Holger Nebling
Modified: 2012-03-17 23:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Nebling 2012-03-17 17:15:56 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: i wait for any system information.
i can not stop the muon updater

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f4ba9b01780 (LWP 11586))]

Thread 2 (Thread 0x7f4b94fc5700 (LWP 11587)):
#0  0x00007f4ba2f4a4c2 in g_poll () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f4ba2f3bf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f4ba2f3c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f4ba8886f3e in QEventDispatcherGlib::processEvents (this=0x1c4fed0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f4ba885acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f4ba885aef7 in QEventLoop::exec (this=0x7f4b94fc4dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f4ba877227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f4ba883dcbf in QInotifyFileSystemWatcherEngine::run (this=0x1c449b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f4ba8774d05 in QThreadPrivate::start (arg=0x1c449b0) at thread/qthread_unix.cpp:331
#9  0x00007f4ba3a1defc in start_thread (arg=0x7f4b94fc5700) at pthread_create.c:304
#10 0x00007f4ba66d459d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4ba9b01780 (LWP 11586)):
[KCrash Handler]
#6  0x00007f4ba87c2a5e in QtPrivate::QStringList_contains (that=0x7fff41172c30, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff41172c30) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1d4bf90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1d4bf90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff41173200) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f4ba886eeba in QMetaObject::activate (sender=0x1c3dba0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1c3dba0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff41173360) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f4ba886eeba in QMetaObject::activate (sender=0x1d4bf90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff41173360) at kernel/qobject.cpp:3278
#13 0x00007f4ba96e4e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1d3e850) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f4ba96e4f8e in MuonMainWindow::initObject (this=0x1d4bf90) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1d4bf90) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1d4bf90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff41173430) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f4ba886eeba in QMetaObject::activate (sender=0x1db8520, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f4ba8876f7f in QSingleShotTimer::timerEvent (this=0x1db8520) at kernel/qtimer.cpp:308
#19 0x00007f4ba8872789 in QObject::event (this=0x1db8520, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f4ba6e95474 in notify_helper (e=0x7fff411739a0, receiver=0x1db8520, this=0x1be7530) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1be7530, receiver=0x1db8520, e=0x7fff411739a0) at kernel/qapplication.cpp:4458
#22 0x00007f4ba6e9a2e1 in QApplication::notify (this=0x7fff41173ca0, receiver=0x1db8520, e=0x7fff411739a0) at kernel/qapplication.cpp:4365
#23 0x00007f4ba807a466 in KApplication::notify (this=0x7fff41173ca0, receiver=0x1db8520, event=0x7fff411739a0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f4ba885bafc in QCoreApplication::notifyInternal (this=0x7fff41173ca0, receiver=0x1db8520, event=0x7fff411739a0) at kernel/qcoreapplication.cpp:787
#25 0x00007f4ba8888d62 in sendEvent (event=0x7fff411739a0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1be3930) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f4ba8886514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f4ba2f3ba5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f4ba2f3c258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f4ba2f3c429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f4ba8886ed6 in QEventDispatcherGlib::processEvents (this=0x1bbf6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f4ba6f3d10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f4ba885acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f4ba885aef7 in QEventLoop::exec (this=0x7fff41173c30, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f4ba885f789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff41173f18) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296195, bug 296189, bug 296172, bug 296170, bug 296121.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2012-03-17 23:53:19 UTC

*** This bug has been marked as a duplicate of bug 291262 ***