Bug 296099 - muon never works
Summary: muon never works
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-15 19:40 UTC by jonny amrques
Modified: 2012-03-16 13:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.09 KB, text/plain)
2012-03-16 13:19 UTC, Alex Bruno Cáceres
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-03-15 19:40:46 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
app manager (muon) never works...........................

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb770a930 (LWP 4189))]

Thread 2 (Thread 0xb57eeb70 (LWP 4190)):
#0  0x0078a416 in __kernel_vsyscall ()
#1  0x01c107ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0322934b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0321a896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x0321ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00a57b37 in QEventDispatcherGlib::processEvents (this=0xa056710, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00a281dd in QEventLoop::processEvents (this=0xb57ee2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00a28421 in QEventLoop::exec (this=0xb57ee2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0092b90b in QThread::exec (this=0xa009b58) at thread/qthread.cpp:498
#9  0x00a08e2d in QInotifyFileSystemWatcherEngine::run (this=0xa009b58) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0092e7b3 in QThreadPrivate::start (arg=0xa009b58) at thread/qthread_unix.cpp:331
#11 0x00773d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x01c1f46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb770a930 (LWP 4189)):
[KCrash Handler]
#7  0x00982e11 in QtPrivate::QStringList_contains (that=0xbf955834, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf955834) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa007bf8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa007bf8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf955a54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00a2fb7d in metacall (argv=0xbf955a54, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa007bf8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa007bf8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf955a54) at kernel/qmetaobject.cpp:232
#13 0x00a3ea6a in QMetaObject::activate (sender=0xa05ce90, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa05ce90) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa05ce90, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf955b98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00a2fb7d in metacall (argv=0xbf955b98, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa05ce90) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa05ce90, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf955b98) at kernel/qmetaobject.cpp:232
#18 0x00a3ea6a in QMetaObject::activate (sender=0xa007bf8, m=0x80950c0, local_signal_index=0, argv=0xbf955b98) at kernel/qobject.cpp:3278
#19 0x004f27c5 in MuonMainWindow::backendReady (this=0xa007bf8, _t1=0xa02d678) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x004f2933 in MuonMainWindow::initObject (this=0xa007bf8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa007bf8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa007bf8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf955cc4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00a2fb7d in metacall (argv=0xbf955cc4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa007bf8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa007bf8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf955cc4) at kernel/qmetaobject.cpp:232
#25 0x00a3ea6a in QMetaObject::activate (sender=0xa0460b8, m=0xb5f238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00a46375 in QSingleShotTimer::timeout (this=0xa0460b8) at .moc/release-shared/qtimer.moc:82
#27 0x00a4642c in QSingleShotTimer::timerEvent (this=0xa0460b8) at kernel/qtimer.cpp:308
#28 0x00a41994 in QObject::event (this=0xa0460b8, e=0xbf9560bc) at kernel/qobject.cpp:1181
#29 0x011ddd84 in notify_helper (e=0xbf9560bc, receiver=0xa0460b8, this=0x9f2b698) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9f2b698, receiver=0xa0460b8, e=0xbf9560bc) at kernel/qapplication.cpp:4458
#31 0x011e3133 in QApplication::notify (this=0xbf9560bc, receiver=0xa0460b8, e=0xbf9560bc) at kernel/qapplication.cpp:3886
#32 0x00e33971 in KApplication::notify (this=0xbf9563d0, receiver=0xa0460b8, event=0xbf9560bc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00a2919e in QCoreApplication::notifyInternal (this=0xbf9563d0, receiver=0xa0460b8, event=0xbf9560bc) at kernel/qcoreapplication.cpp:787
#34 0x00a59c10 in sendEvent (event=0xbf9560bc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9f2da34) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00a57122 in timerSourceDispatch (source=0x9f2da00) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0321a25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x0321a990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x0321ac2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00a57ada in QEventDispatcherGlib::processEvents (this=0x9f0e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01295e7a in QGuiEventDispatcherGlib::processEvents (this=0x9f0e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00a281dd in QEventLoop::processEvents (this=0xbf956334, flags=...) at kernel/qeventloop.cpp:149
#43 0x00a28421 in QEventLoop::exec (this=0xbf956334, flags=...) at kernel/qeventloop.cpp:201
#44 0x00a2d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x011db924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296044, bug 296017, bug 296004, bug 295960, bug 295950.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-03-15 20:05:32 UTC
Thank you for the bug report. The KDE team wants to improve the crash reporting tools for end users. To help improving, please answer the following questions:

1. Did the Bug Reporting tool suggest this crash has already been reported?
[ ] no, I did not see any mention of the crash already been reported
[ ] unsure, I did not trust or understand the suggested duplicate reports
[ ] yes, the tool suggested this crash has already been reported

2. If "yes" in answer 1, how many duplicates did it display?
[ ] more than 10 duplicates
[ ] at least two duplicates
[ ] only a single duplicate

3. If "yes" or "unsure" in answer 1, what could be improved to help building trust in the suggested duplicate reports? (Please add any comment)

Thanks for taking part in this survey,
KDE Quality Team
Comment 2 Alex Bruno Cáceres 2012-03-16 13:19:48 UTC
Created attachment 69664 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed: I was trying to run (open) Muon.

- Unusual behavior I noticed: It crashes everytime.

-- Backtrace (Reduced):
#6  0x00007fea69d50a5e in QtPrivate::QStringList_contains (that=0x7fffe38e8a10, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffe38e8a10) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x234ffb0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x234ffb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe38e8fe0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x24212d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffe38e9140) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
Comment 3 Jonathan Thomas 2012-03-16 13:45:48 UTC

*** This bug has been marked as a duplicate of bug 291262 ***