Bug 296044 - centro de software fallo
Summary: centro de software fallo
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-15 08:12 UTC by juan sanchez
Modified: 2012-03-15 08:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description juan sanchez 2012-03-15 08:12:46 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: actualizando el sistema y el navegador de internet para el mejor funcionamiento

The crash can be reproduced every time.

-- Backtrace:
Application: Centro de software de Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77a5930 (LWP 1841))]

Thread 2 (Thread 0xb55fbb70 (LWP 1845)):
#0  0x00b032f4 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0x020de565 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x020dec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x007f4b37 in QEventDispatcherGlib::processEvents (this=0x87f4090, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#4  0x007c51dd in QEventLoop::processEvents (this=0xb55fb2b0, flags=...) at kernel/qeventloop.cpp:149
#5  0x007c5421 in QEventLoop::exec (this=0xb55fb2b0, flags=...) at kernel/qeventloop.cpp:201
#6  0x006c890b in QThread::exec (this=0x87c5730) at thread/qthread.cpp:498
#7  0x007a5e2d in QInotifyFileSystemWatcherEngine::run (this=0x87c5730) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x006cb7b3 in QThreadPrivate::start (arg=0x87c5730) at thread/qthread_unix.cpp:331
#9  0x00614d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0x00af546e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77a5930 (LWP 1841)):
[KCrash Handler]
#7  0x0071fe11 in QtPrivate::QStringList_contains (that=0xbf9529d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9529d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x878a6b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x878a6b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf952bf4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x007ccb7d in metacall (argv=0xbf952bf4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x878a6b0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x878a6b0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf952bf4) at kernel/qmetaobject.cpp:232
#13 0x007dba6a in QMetaObject::activate (sender=0x878e490, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x878e490) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x878e490, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf952d38) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x007ccb7d in metacall (argv=0xbf952d38, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x878e490) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x878e490, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf952d38) at kernel/qmetaobject.cpp:232
#18 0x007dba6a in QMetaObject::activate (sender=0x878a6b0, m=0x80950c0, local_signal_index=0, argv=0xbf952d38) at kernel/qobject.cpp:3278
#19 0x00c847c5 in MuonMainWindow::backendReady (this=0x878a6b0, _t1=0x87bdb68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00c84933 in MuonMainWindow::initObject (this=0x878a6b0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x878a6b0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x878a6b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf952e64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x007ccb7d in metacall (argv=0xbf952e64, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x878a6b0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x878a6b0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf952e64) at kernel/qmetaobject.cpp:232
#25 0x007dba6a in QMetaObject::activate (sender=0x87d7f38, m=0x8fc238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x007e3375 in QSingleShotTimer::timeout (this=0x87d7f38) at .moc/release-shared/qtimer.moc:82
#27 0x007e342c in QSingleShotTimer::timerEvent (this=0x87d7f38) at kernel/qtimer.cpp:308
#28 0x007de994 in QObject::event (this=0x87d7f38, e=0xbf95325c) at kernel/qobject.cpp:1181
#29 0x014bed84 in notify_helper (e=0xbf95325c, receiver=0x87d7f38, this=0x868b6c8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x868b6c8, receiver=0x87d7f38, e=0xbf95325c) at kernel/qapplication.cpp:4458
#31 0x014c4133 in QApplication::notify (this=0xbf95325c, receiver=0x87d7f38, e=0xbf95325c) at kernel/qapplication.cpp:3886
#32 0x01114971 in KApplication::notify (this=0xbf953570, receiver=0x87d7f38, event=0xbf95325c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x007c619e in QCoreApplication::notifyInternal (this=0xbf953570, receiver=0x87d7f38, event=0xbf95325c) at kernel/qcoreapplication.cpp:787
#34 0x007f6c10 in sendEvent (event=0xbf95325c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8692584) at kernel/qeventdispatcher_unix.cpp:603
#36 0x007f4122 in timerSourceDispatch (source=0x8692550) at kernel/qeventdispatcher_glib.cpp:184
#37 0x020de25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x020de990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x020dec2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x007f4ada in QEventDispatcherGlib::processEvents (this=0x866e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01576e7a in QGuiEventDispatcherGlib::processEvents (this=0x866e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x007c51dd in QEventLoop::processEvents (this=0xbf9534d4, flags=...) at kernel/qeventloop.cpp:149
#43 0x007c5421 in QEventLoop::exec (this=0xbf9534d4, flags=...) at kernel/qeventloop.cpp:201
#44 0x007ca19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x014bc924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296017, bug 296004, bug 295960, bug 295950, bug 295946.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-15 08:19:40 UTC

*** This bug has been marked as a duplicate of bug 291262 ***