Bug 296017 - Muon Software Center non si avvia
Summary: Muon Software Center non si avvia
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 20:17 UTC by nio974
Modified: 2012-03-14 23:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nio974 2012-03-14 20:17:43 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
Appena installato Kubuntu, ho cercato di fare degli aggiornamenti ma non mi funziona ne il Software center ne l'Installatore di pacchetti, mi esce un messaggio di errore che mi avvisa che non รจ possibile avviare l'applicazione.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb484c930 (LWP 7191))]

Thread 2 (Thread 0xb218fb70 (LWP 7195)):
#0  0xb77d9424 in __kernel_vsyscall ()
#1  0xb5e057ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb52ee34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb52df896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb52dfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb7349b37 in QEventDispatcherGlib::processEvents (this=0x9b16138, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb731a1dd in QEventLoop::processEvents (this=0xb218f2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb731a421 in QEventLoop::exec (this=0xb218f2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb721d90b in QThread::exec (this=0x9a049c0) at thread/qthread.cpp:498
#9  0xb72fae2d in QInotifyFileSystemWatcherEngine::run (this=0x9a049c0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb72207b3 in QThreadPrivate::start (arg=0x9a049c0) at thread/qthread_unix.cpp:331
#11 0xb53c5d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5e1446e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb484c930 (LWP 7191)):
[KCrash Handler]
#7  0xb7274e11 in QtPrivate::QStringList_contains (that=0xbff5c3e4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbff5c3e4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x99ba530) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x99ba530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff5c604) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7321b7d in metacall (argv=0xbff5c604, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x99ba530) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x99ba530, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbff5c604) at kernel/qmetaobject.cpp:232
#13 0xb7330a6a in QMetaObject::activate (sender=0x9a4a5f8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9a4a5f8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9a4a5f8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff5c748) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7321b7d in metacall (argv=0xbff5c748, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9a4a5f8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9a4a5f8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbff5c748) at kernel/qmetaobject.cpp:232
#18 0xb7330a6a in QMetaObject::activate (sender=0x99ba530, m=0x80950c0, local_signal_index=0, argv=0xbff5c748) at kernel/qobject.cpp:3278
#19 0xb77917c5 in MuonMainWindow::backendReady (this=0x99ba530, _t1=0x993c050) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb7791933 in MuonMainWindow::initObject (this=0x99ba530) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x99ba530) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x99ba530, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbff5c874) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7321b7d in metacall (argv=0xbff5c874, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x99ba530) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x99ba530, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbff5c874) at kernel/qmetaobject.cpp:232
#25 0xb7330a6a in QMetaObject::activate (sender=0x9a2b3d0, m=0xb7451238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7338375 in QSingleShotTimer::timeout (this=0x9a2b3d0) at .moc/release-shared/qtimer.moc:82
#27 0xb733842c in QSingleShotTimer::timerEvent (this=0x9a2b3d0) at kernel/qtimer.cpp:308
#28 0xb7333994 in QObject::event (this=0x9a2b3d0, e=0xbff5cc6c) at kernel/qobject.cpp:1181
#29 0xb6101d84 in notify_helper (e=0xbff5cc6c, receiver=0x9a2b3d0, this=0x98c1eb0) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x98c1eb0, receiver=0x9a2b3d0, e=0xbff5cc6c) at kernel/qapplication.cpp:4458
#31 0xb6107133 in QApplication::notify (this=0xbff5cc6c, receiver=0x9a2b3d0, e=0xbff5cc6c) at kernel/qapplication.cpp:3886
#32 0xb6f20971 in KApplication::notify (this=0xbff5cf80, receiver=0x9a2b3d0, event=0xbff5cc6c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb731b19e in QCoreApplication::notifyInternal (this=0xbff5cf80, receiver=0x9a2b3d0, event=0xbff5cc6c) at kernel/qcoreapplication.cpp:787
#34 0xb734bc10 in sendEvent (event=0xbff5cc6c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x98c4d54) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb7349122 in timerSourceDispatch (source=0x98c4d20) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb52df25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb52df990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb52dfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb7349ada in QEventDispatcherGlib::processEvents (this=0x98a4238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb61b9e7a in QGuiEventDispatcherGlib::processEvents (this=0x98a4238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb731a1dd in QEventLoop::processEvents (this=0xbff5cee4, flags=...) at kernel/qeventloop.cpp:149
#43 0xb731a421 in QEventLoop::exec (this=0xbff5cee4, flags=...) at kernel/qeventloop.cpp:201
#44 0xb731f19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb60ff924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 296004, bug 295960, bug 295950, bug 295946, bug 295939.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-14 23:58:38 UTC

*** This bug has been marked as a duplicate of bug 291262 ***