Bug 296004 - muon crash on launch everytime
Summary: muon crash on launch everytime
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 16:23 UTC by perugolate
Modified: 2012-04-07 21:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (7.28 KB, text/plain)
2012-03-23 15:14 UTC, Michael
Details
New crash information added by DrKonqi (5.22 KB, text/plain)
2012-04-07 21:14 UTC, rwbowers54
Details

Note You need to log in before you can comment on or make changes to this bug.
Description perugolate 2012-03-14 16:23:11 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
when launching muon it the window opens in the top right of the screen but does not load up with any text. It then freezes for a few seconds then crashes. Every time

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f82c4e25780 (LWP 1884))]

Thread 2 (Thread 0x7f82aec0f700 (LWP 1893)):
#0  0x00007f82c19ee473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f82be261f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f82be262429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f82c3bacf3e in QEventDispatcherGlib::processEvents (this=0x19f1780, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f82c3b80cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f82c3b80ef7 in QEventLoop::exec (this=0x7f82aec0edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f82c3a9827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f82c3b63cbf in QInotifyFileSystemWatcherEngine::run (this=0x1bb8490) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f82c3a9ad05 in QThreadPrivate::start (arg=0x1bb8490) at thread/qthread_unix.cpp:331
#9  0x00007f82bed43efc in start_thread (arg=0x7f82aec0f700) at pthread_create.c:304
#10 0x00007f82c19fa59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f82c4e25780 (LWP 1884)):
[KCrash Handler]
#6  0x00007f82c3ae8a5e in QtPrivate::QStringList_contains (that=0x7fff0e7efc20, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff0e7efc20) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x19ef3a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x19ef3a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0e7f01f0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f82c3b94eba in QMetaObject::activate (sender=0x1a52a40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1a52a40, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0e7f0350) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f82c3b94eba in QMetaObject::activate (sender=0x19ef3a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0e7f0350) at kernel/qobject.cpp:3278
#13 0x00007f82c4a0ae7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1a12c70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f82c4a0af8e in MuonMainWindow::initObject (this=0x19ef3a0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x19ef3a0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x19ef3a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0e7f0420) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f82c3b94eba in QMetaObject::activate (sender=0x1a99210, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f82c3b9cf7f in QSingleShotTimer::timerEvent (this=0x1a99210) at kernel/qtimer.cpp:308
#19 0x00007f82c3b98789 in QObject::event (this=0x1a99210, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f82c21bb474 in notify_helper (e=0x7fff0e7f0990, receiver=0x1a99210, this=0x1893540) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1893540, receiver=0x1a99210, e=0x7fff0e7f0990) at kernel/qapplication.cpp:4458
#22 0x00007f82c21c02e1 in QApplication::notify (this=0x7fff0e7f0c90, receiver=0x1a99210, e=0x7fff0e7f0990) at kernel/qapplication.cpp:4365
#23 0x00007f82c33a0466 in KApplication::notify (this=0x7fff0e7f0c90, receiver=0x1a99210, event=0x7fff0e7f0990) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f82c3b81afc in QCoreApplication::notifyInternal (this=0x7fff0e7f0c90, receiver=0x1a99210, event=0x7fff0e7f0990) at kernel/qcoreapplication.cpp:787
#25 0x00007f82c3baed62 in sendEvent (event=0x7fff0e7f0990, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1894580) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f82c3bac514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f82be261a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f82be262258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f82be262429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f82c3baced6 in QEventDispatcherGlib::processEvents (this=0x186e6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f82c226310e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f82c3b80cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f82c3b80ef7 in QEventLoop::exec (this=0x7fff0e7f0c20, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f82c3b85789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff0e7f0f08) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 291262.

Possible duplicates by query: bug 295960, bug 295950, bug 295946, bug 295939, bug 295919.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-14 16:42:03 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 Michael 2012-03-23 15:14:25 UTC
Created attachment 69833 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Started Muon Software Center and the program crashed immediately upon execution.

-- Backtrace (Reduced):
#7  0x006a4e11 in QtPrivate::QStringList_contains (that=0xbf98d884, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf98d884) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9f39d10) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9f39d10, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf98daa4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00751b7d in metacall (argv=0xbf98daa4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9f39d10) at kernel/qmetaobject.cpp:237
Comment 3 rwbowers54 2012-04-07 21:14:50 UTC
Created attachment 70218 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Upon opening Muon Software Center, a window opens, then freezes immediately, and a few seconds later program crashes.  This occurs everytime and continues after command "sudo apt-get update" and "sudo apt-get upgrade."

-- Backtrace (Reduced):
#6  0x00007fad3ff47a5e in QtPrivate::QStringList_contains (that=0x7fff8c4803a0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff8c4803a0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x183ac60) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x183ac60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8c480970) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x18489a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff8c480ad0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109