Bug 296145 - Random, nonreproducible crashes in kmail
Summary: Random, nonreproducible crashes in kmail
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-16 12:54 UTC by abrahams
Modified: 2012-03-19 11:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.28 KB, text/plain)
2012-03-16 13:01 UTC, abrahams
Details
New crash information added by DrKonqi (8.45 KB, text/plain)
2012-03-17 01:24 UTC, E.T. Anderson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description abrahams 2012-03-16 12:54:33 UTC
Application: kmail (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-17-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: Advancing through list of emails

Notes:

1. I've had a lot of crashes in kmail recently.  Today I had two within five minutes.

2. Since there's no clear action that triggers this bug, there's no way to know if it's a true duplicate of any other kmail bug.  As far as I know I was not doing anything that I haven't already done successfully many times.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f2755d947c0 (LWP 23645))]

Thread 4 (Thread 0x7f2734cab700 (LWP 23657)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f27481b1c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f27481b1d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f2750c9fefc in start_thread (arg=0x7f2734cab700) at pthread_create.c:304
#4  0x00007f275310a59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f273439a700 (LWP 23658)):
#0  0x00007f27530fe473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f274ba99f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f274ba9a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2753a8ec06 in QEventDispatcherGlib::processEvents (this=0x309aff0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f2753a5e3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2753a5e637 in QEventLoop::exec (this=0x7f2734399dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f275395e067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f275396108b in QThreadPrivate::start (arg=0x309a5f0) at thread/qthread_unix.cpp:298
#8  0x00007f2750c9fefc in start_thread (arg=0x7f273439a700) at pthread_create.c:304
#9  0x00007f275310a59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2731f64700 (LWP 23659)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f2731f63ab0 in ?? ()
#2  0x00007fff205bb7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7f2755d947c0 (LWP 23645)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x44e7a70, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f2752191299 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x44e7a70, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f2753a78ba6 in QObject::event (this=0x44e7a70, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f2753f82104 in notify_helper (e=0x7f272c0d2d50, receiver=0x44e7a70, this=0x21bf880) at kernel/qapplication.cpp:4555
#10 QApplicationPrivate::notify_helper (this=0x21bf880, receiver=0x44e7a70, e=0x7f272c0d2d50) at kernel/qapplication.cpp:4527
#11 0x00007f2753f86f83 in QApplication::notify (this=0x7fff205407d0, receiver=0x44e7a70, e=0x7f272c0d2d50) at kernel/qapplication.cpp:4416
#12 0x00007f27557b09a6 in KApplication::notify (this=0x7fff205407d0, receiver=0x44e7a70, event=0x7f272c0d2d50) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f2753a5f5fc in QCoreApplication::notifyInternal (this=0x7fff205407d0, receiver=0x44e7a70, event=0x7f272c0d2d50) at kernel/qcoreapplication.cpp:876
#14 0x00007f2753a633ca in sendEvent (event=0x7f272c0d2d50, receiver=0x44e7a70) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x216a220) at kernel/qcoreapplication.cpp:1500
#16 0x00007f2753a8e773 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f274ba99a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f274ba9a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f274ba9a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f2753a8eb9f in QEventDispatcherGlib::processEvents (this=0x216bb00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f275402721e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f2753a5e3e2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f2753a5e637 in QEventLoop::exec (this=0x7fff205406b0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f2753a636c7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in main (argc=<optimized out>, argv=<optimized out>) at ../../kmail/main.cpp:145

Possible duplicates by query: bug 295746, bug 295225, bug 294828, bug 293172, bug 292991.

Reported using DrKonqi
Comment 1 abrahams 2012-03-16 13:01:56 UTC
Created attachment 69663 [details]
New crash information added by DrKonqi

kmail (4.8.0) on KDE Platform 4.8.1 (4.8.1) using Qt 4.8.0

- What I was doing when the application crashed:

I was trying to delete a particular message.  Every time I tried to delete this message, kmail crashed.  The message appeared to be a duplicate of another message, but I don't know whether the duplication was a kmail artifact or whether the message was actually sent twice.

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2ca5500, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f566ecc5299 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2ca5500, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f56705acba6 in QObject::event (this=0x2ca5500, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f5670ab6104 in notify_helper (e=0x7f564c0f9b00, receiver=0x2ca5500, this=0x150f240) at kernel/qapplication.cpp:4555
#10 QApplicationPrivate::notify_helper (this=0x150f240, receiver=0x2ca5500, e=0x7f564c0f9b00) at kernel/qapplication.cpp:4527
Comment 2 E.T. Anderson 2012-03-17 01:24:03 UTC
Created attachment 69683 [details]
New crash information added by DrKonqi

kmail (4.8.0) on KDE Platform 4.8.1 (4.8.1) using Qt 4.8.0

- What I was doing when the application crashed:

I had just clicked on an unread message to open it and Kmail crashed. This does not happen every time, but almost once per day.

- Custom settings of the application:

I am using an external (but still localhost) PostgreSQL database for Akonadi information.

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x5f8f930, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f36c78d8299 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x5f8f930, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f36c91bfba6 in QObject::event (this=0x5f8f930, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f36c96c9104 in notify_helper (e=0x7f36a432e980, receiver=0x5f8f930, this=0x1c32c20) at kernel/qapplication.cpp:4555
#10 QApplicationPrivate::notify_helper (this=0x1c32c20, receiver=0x5f8f930, e=0x7f36a432e980) at kernel/qapplication.cpp:4527
Comment 3 Laurent Montel 2012-03-19 11:35:37 UTC

*** This bug has been marked as a duplicate of bug 286307 ***