Bug 295746 - Kmail crashes often
Summary: Kmail crashes often
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-11 10:32 UTC by ipomo
Modified: 2012-03-19 11:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ipomo 2012-03-11 10:32:19 UTC
Application: kmail (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1) "release 481"
Qt Version: 4.8.0
Operating System: Linux 3.1.10-9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I selected a message. It only occurs on some messages. I don't know the criteria for crashing. After new messages arrived, it can be possible to select the message.
Sometimes kmail crashes when I try to throw the message to trash.
Since introduction of akonadi KDE is a pain in the...

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f10b2d99780 (LWP 6438))]

Thread 3 (Thread 0x7f109478a700 (LWP 6443)):
#0  0x00007f10adee6e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f10a459fc12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f10a459fc49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f10adee2f05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f10b00d963d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f1093e89700 (LWP 6444)):
#0  0x00007f10b00d0523 in poll () from /lib64/libc.so.6
#1  0x00007f10a82b9a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f10a82b9f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f10b1736956 in QEventDispatcherGlib::processEvents (this=0x7f108c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f10b1706682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f10b17068d7 in QEventLoop::exec (this=0x7f1093e88e00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f10b1607537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f10b160a55b in QThreadPrivate::start (arg=0xb83680) at thread/qthread_unix.cpp:298
#8  0x00007f10adee2f05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f10b00d963d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f10b2d99780 (LWP 6438)):
[KCrash Handler]
#6  QList (l=..., this=0x7fff57993890) at ../../src/corelib/tools/qlist.h:122
#7  QNetworkCacheMetaData::rawHeaders (this=0x7fff57993ba0) at access/qabstractnetworkcache.cpp:240
#8  0x00007f10af09e5cc in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0xa3a8b0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1019
#9  0x00007f10af09fd24 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xa3a8b0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#10 0x00007f10af12b379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xa3a8b0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#11 0x00007f10b1720926 in QObject::event (this=0xa3a8b0, e=<optimized out>) at kernel/qobject.cpp:1204
#12 0x00007f10b0a8ce84 in notify_helper (e=0x7f1038014b20, receiver=0xa3a8b0, this=0x6609d0) at kernel/qapplication.cpp:4550
#13 QApplicationPrivate::notify_helper (this=0x6609d0, receiver=0xa3a8b0, e=0x7f1038014b20) at kernel/qapplication.cpp:4522
#14 0x00007f10b0a91d03 in QApplication::notify (this=0x7fff579946d0, receiver=0xa3a8b0, e=0x7f1038014b20) at kernel/qapplication.cpp:4411
#15 0x00007f10b27b6656 in KApplication::notify (this=0x7fff579946d0, receiver=0xa3a8b0, event=0x7f1038014b20) at /usr/src/debug/kdelibs-4.8.1/kdeui/kernel/kapplication.cpp:311
#16 0x00007f10b170789c in QCoreApplication::notifyInternal (this=0x7fff579946d0, receiver=0xa3a8b0, event=0x7f1038014b20) at kernel/qcoreapplication.cpp:876
#17 0x00007f10b170b13a in sendEvent (event=0x7f1038014b20, receiver=0xa3a8b0) at kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b720) at kernel/qcoreapplication.cpp:1500
#19 0x00007f10b17364c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#20 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#21 0x00007f10a82b958d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f10a82b9d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f10a82b9f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#24 0x00007f10b17368ef in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f10b0b302de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f10b1706682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f10b17068d7 in QEventLoop::exec (this=0x7fff579945b0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f10b170b435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#29 0x0000000000402df3 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.8.1/kmail/main.cpp:145

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 291499, bug 289946, bug 289179, bug 286307.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-03-19 11:35:18 UTC

*** This bug has been marked as a duplicate of bug 286307 ***