Bug 292991 - kmail crashes when viewing (html) messages from groupon
Summary: kmail crashes when viewing (html) messages from groupon
Status: RESOLVED DUPLICATE of bug 291230
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-31 19:11 UTC by Prakash Punnoor
Modified: 2012-01-31 21:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Prakash Punnoor 2012-01-31 19:11:28 UTC
Application: kmail (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.3.0-rc1+ x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

This happened on an IMAP account: Reading an d deleting some messages, then trying to open a html formatted message from groupon and crash.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f829bab9760 (LWP 4083))]

Thread 7 (Thread 0x7f827f2d8700 (LWP 4090)):
#0  0x00007f8295e2943c in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007f828dd122b4 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/qt4/libQtWebKit.so.4
#2  0x00007f8295e24ccc in start_thread () from /lib64/libpthread.so.0
#3  0x00007f8294ba807d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f827eac7700 (LWP 4091)):
#0  0x00007f8294b9f423 in poll () from /lib64/libc.so.6
#1  0x00007f828c057d70 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f828c058221 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f82961e5f16 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f82961b6772 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f82961b6a25 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f82960b6d15 in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f82960b9327 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007f8295e24ccc in start_thread () from /lib64/libpthread.so.0
#9  0x00007f8294ba807d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f827d620700 (LWP 4092)):
#0  0x00007f8295e297bb in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1  0x00007f82960ba192 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f82960adb4f in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f82960b9327 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f8295e24ccc in start_thread () from /lib64/libpthread.so.0
#5  0x00007f8294ba807d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f8237fff700 (LWP 4097)):
#0  0x00007f8295e297bb in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1  0x00007f82960ba192 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f82960adb4f in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f82960b9327 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f8295e24ccc in start_thread () from /lib64/libpthread.so.0
#5  0x00007f8294ba807d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f822ffff700 (LWP 4218)):
#0  0x00007f8295e297bb in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1  0x00007f82960ba192 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f82960adb4f in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f82960b9327 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f8295e24ccc in start_thread () from /lib64/libpthread.so.0
#5  0x00007f8294ba807d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f8235693700 (LWP 4219)):
#0  0x00007f8295e297bb in pthread_cond_timedwait () from /lib64/libpthread.so.0
#1  0x00007f82960ba192 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f82960adb4f in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007f82960b9327 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f8295e24ccc in start_thread () from /lib64/libpthread.so.0
#5  0x00007f8294ba807d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f829bab9760 (LWP 4083)):
[KCrash Handler]
#6  0x00007f829794910b in QNetworkAccessHttpBackend::replyDownloadMetaData(QList<QPair<QByteArray, QByteArray> >, int, QString, bool, QSharedPointer<char>, long long) () from /usr/lib64/qt4/libQtNetwork.so.4
#7  0x00007f82979ca3d5 in QNetworkAccessHttpBackend::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib64/qt4/libQtNetwork.so.4
#8  0x00007f82961cbf9e in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007f8296bbcf44 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#10 0x00007f8296bc1aaf in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#11 0x00007f829b4d0fc6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#12 0x00007f82961b7703 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00007f82961bac2f in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib64/qt4/libQtCore.so.4
#14 0x00007f82961e5d33 in postEventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtCore.so.4
#15 0x00007f828c057862 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#16 0x00007f828c058040 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#17 0x00007f828c058221 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f82961e5ebf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#19 0x00007f8296c608be in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007f82961b6772 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#21 0x00007f82961b6a25 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007f82961bb0b3 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#23 0x0000000000403512 in main ()

Possible duplicates by query: bug 292546, bug 291913, bug 291499, bug 291230, bug 289950.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-01-31 21:04:59 UTC

*** This bug has been marked as a duplicate of bug 291230 ***