Bug 294828 - Kmail crashes all the time when trying to delete emails
Summary: Kmail crashes all the time when trying to delete emails
Status: RESOLVED DUPLICATE of bug 286320
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-25 21:34 UTC by Tony Eikelmann
Modified: 2012-03-21 00:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.87 KB, text/plain)
2012-03-21 00:07 UTC, helal@mnet-online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Eikelmann 2012-02-25 21:34:54 UTC
Application: kmail (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.6-3.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
Deleting e-mails, ca 10 at the time

The same problem can also be seen when trying to open an e-mail

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f23dacf9840 (LWP 4203))]

Thread 3 (Thread 0x7f23cc91c700 (LWP 4214)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x0000003860fb86ec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x386197cc20) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x0000003860fb8819 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x00007f23da932d90 in start_thread (arg=0x7f23cc91c700) at pthread_create.c:309
#4  0x00007f23da3dff5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f23cc01b700 (LWP 4215)):
#0  0x00007fffaa9ff98f in clock_gettime ()
#1  0x00007f23d9ecf1f1 in __GI_clock_gettime (clock_id=1, tp=0x7f23cc01ab00) at ../sysdeps/unix/clock_gettime.c:100
#2  0x00000031768d22e4 in do_gettime (frac=0x7f23cc01ab18, sec=0x7f23cc01ab10) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00000031769a84cd in QTimerInfoList::updateCurrentTime (this=0x7f23c40020d0) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00000031769a81e1 in timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:150
#6  timerSourceCheckHelper (src=<optimized out>) at kernel/qeventdispatcher_glib.cpp:144
#7  0x000000316ec447a4 in g_main_context_check () from /lib64/libglib-2.0.so.0
#8  0x000000316ec44ff2 in ?? () from /lib64/libglib-2.0.so.0
#9  0x000000316ec4549c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#10 0x00000031769a7dc6 in QEventDispatcherGlib::processEvents (this=0x7f23c40008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#11 0x0000003176978182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00000031769783d7 in QEventLoop::exec (this=0x7f23cc01ad40, flags=...) at kernel/qeventloop.cpp:204
#13 0x0000003176878b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x000000317687bb6b in QThreadPrivate::start (arg=0x2448500) at thread/qthread_unix.cpp:298
#15 0x00007f23da932d90 in start_thread (arg=0x7f23cc01b700) at pthread_create.c:309
#16 0x00007f23da3dff5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f23dacf9840 (LWP 4203)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x2eab1a0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000031782f6409 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x2eab1a0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003176991f16 in QObject::event (this=0x2eab1a0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x0000003858bc9994 in notify_helper (e=0x7f237c007410, receiver=0x2eab1a0, this=0x1f59aa0) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x1f59aa0, receiver=0x2eab1a0, e=0x7f237c007410) at kernel/qapplication.cpp:4522
#11 0x0000003858bce813 in QApplication::notify (this=0x7fffaa87e5c0, receiver=0x2eab1a0, e=0x7f237c007410) at kernel/qapplication.cpp:4411
#12 0x0000003859a50766 in KApplication::notify (this=0x7fffaa87e5c0, receiver=0x2eab1a0, event=0x7f237c007410) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x000000317697904c in QCoreApplication::notifyInternal (this=0x7fffaa87e5c0, receiver=0x2eab1a0, event=0x7f237c007410) at kernel/qcoreapplication.cpp:876
#14 0x000000317697cada in sendEvent (event=0x7f237c007410, receiver=0x2eab1a0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1f11210) at kernel/qcoreapplication.cpp:1500
#16 0x00000031769a7933 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0x1f614f0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x000000316ec44acd in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#19 0x000000316ec452c8 in ?? () from /lib64/libglib-2.0.so.0
#20 0x000000316ec4549c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#21 0x00000031769a7d5f in QEventDispatcherGlib::processEvents (this=0x1f12af0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x0000003858c6c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#23 0x0000003176978182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00000031769783d7 in QEventLoop::exec (this=0x7fffaa87e490, flags=...) at kernel/qeventloop.cpp:204
#25 0x000000317697cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402d23 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.7.4/kmail/main.cpp:145

Possible duplicates by query: bug 293172, bug 292991, bug 292546, bug 291913, bug 291499.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-02-26 09:01:50 UTC

*** This bug has been marked as a duplicate of bug 286320 ***
Comment 2 helal@mnet-online.de 2012-03-21 00:07:40 UTC
Created attachment 69776 [details]
New crash information added by DrKonqi

kmail (4.8.0) on KDE Platform 4.8.1 (4.8.1) "release 483" using Qt 4.8.0

- What I was doing when the application crashed:
I am deleting mails from imap account -kde 4.8.1.
I use kmail for long time, but now it's a terrible
piece of software (included kwallet). I could not understand that i have to
give password bofore i can read my mails. At the customer  site  I switched
to thunderbird already. I love kmail, but at the moment is kmail not suitable for professional use. So I test kmail at home and hopefully in kde 4.9  we get
a stable version.

-- Backtrace (Reduced):
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x29f1500, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007fe8cedeb379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x29f1500, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007fe8d13e0926 in QObject::event (this=0x29f1500, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007fe8d074ce84 in notify_helper (e=0x2f50360, receiver=0x29f1500, this=0x65af20) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x65af20, receiver=0x29f1500, e=0x2f50360) at kernel/qapplication.cpp:4522