Bug 293172 - Kmail crashed when viewing an email
Summary: Kmail crashed when viewing an email
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-02 20:12 UTC by Lastique
Modified: 2012-02-03 08:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lastique 2012-02-02 20:12:06 UTC
Application: kmail (4.8.0)
KDE Platform Version: 4.8.00 (4.8.0 "release 462"
Qt Version: 4.8.0
Operating System: Linux 3.1.9-6-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Kmail was open for quite a while, I read a few emails. Then when I selected an other email to read it crashed.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f52f2c95780 (LWP 4791))]

Thread 4 (Thread 0x7f52d4ec7700 (LWP 4794)):
#0  0x00007f52edde0e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f52e44adc12 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f52e44adc49 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f52edddcf05 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f52effd363d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f52d45c6700 (LWP 4795)):
#0  0x00007f52edde011f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f52e84c4f25 in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f52e84c599a in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f52e84c5f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f52f1630956 in QEventDispatcherGlib::processEvents (this=0x7f52cc0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f52f1600682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f52f16008d7 in QEventLoop::exec (this=0x7f52d45c5e00, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f52f1501537 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f52f150455b in QThreadPrivate::start (arg=0xadbf00) at thread/qthread_unix.cpp:298
#9  0x00007f52edddcf05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f52effd363d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f528bd89700 (LWP 19636)):
#0  0x00007f52edde11eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f52f15049cf in wait (time=30000, this=0x7f5280005fc0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f5280005f68, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f52f14f7ddf in QThreadPoolThread::run (this=0x7f5280006240) at concurrent/qthreadpool.cpp:141
#4  0x00007f52f150455b in QThreadPrivate::start (arg=0x7f5280006240) at thread/qthread_unix.cpp:298
#5  0x00007f52edddcf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f52effd363d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f52f2c95780 (LWP 4791)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x825c810, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f52ef025379 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x825c810, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f52f161a926 in QObject::event (this=0x825c810, e=<optimized out>) at kernel/qobject.cpp:1204
#9  0x00007f52f0986e84 in notify_helper (e=0x7f5280005b70, receiver=0x825c810, this=0x65e580) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0x65e580, receiver=0x825c810, e=0x7f5280005b70) at kernel/qapplication.cpp:4522
#11 0x00007f52f098bd03 in QApplication::notify (this=0x7fff0ef178d0, receiver=0x825c810, e=0x7f5280005b70) at kernel/qapplication.cpp:4411
#12 0x00007f52f26ab786 in KApplication::notify (this=0x7fff0ef178d0, receiver=0x825c810, event=0x7f5280005b70) at /usr/src/debug/kdelibs-4.8.0/kdeui/kernel/kapplication.cpp:311
#13 0x00007f52f160189c in QCoreApplication::notifyInternal (this=0x7fff0ef178d0, receiver=0x825c810, event=0x7f5280005b70) at kernel/qcoreapplication.cpp:876
#14 0x00007f52f160513a in sendEvent (event=0x7f5280005b70, receiver=0x825c810) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x60b720) at kernel/qcoreapplication.cpp:1500
#16 0x00007f52f16304c3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f52e84c558d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f52e84c5d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f52e84c5f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f52f16308ef in QEventDispatcherGlib::processEvents (this=0x60b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f52f0a2a2de in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f52f1600682 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f52f16008d7 in QEventLoop::exec (this=0x7fff0ef177b0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f52f1605435 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402df3 in ?? ()
#27 0x00007f52eff1b23d in __libc_start_main () from /lib64/libc.so.6
#28 0x00000000004032d5 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 292991, bug 292546, bug 291913, bug 291499, bug 291230.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-02-03 08:11:58 UTC

*** This bug has been marked as a duplicate of bug 286307 ***