Bug 295225 - Crashes while reading e-mails
Summary: Crashes while reading e-mails
Status: RESOLVED DUPLICATE of bug 286320
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-02 16:59 UTC by Tony Eikelmann
Modified: 2012-03-02 17:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Eikelmann 2012-03-02 16:59:29 UTC
Application: kmail (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.2.7-1.fc16.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
This will happend each I am trying to read an e-mail. sometimes immediatly or after reading 3-4 emails. I am using Fedora 16 -- 64 bit version

The crash can be reproduced some of the time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fb6e2ca4840 (LWP 32018))]

Thread 6 (Thread 0x7fb6d679f700 (LWP 32022)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x000000352f9b86ec in WTF::TCMalloc_PageHeap::scavengerThread (this=0x353037cc20) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#2  0x000000352f9b8819 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#3  0x0000003b4dc07d90 in start_thread (arg=0x7fb6d679f700) at pthread_create.c:309
#4  0x0000003b4d4f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 5 (Thread 0x7fb6d5e96700 (LWP 32023)):
#0  0x0000003b4d4e85c3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000037a0444fd8 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00000037a044549c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x0000003521da7dc6 in QEventDispatcherGlib::processEvents (this=0x7fb6d00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x0000003521d78182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x0000003521d783d7 in QEventLoop::exec (this=0x7fb6d5e95d40, flags=...) at kernel/qeventloop.cpp:204
#6  0x0000003521c78b27 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x0000003521c7bb6b in QThreadPrivate::start (arg=0xf664f0) at thread/qthread_unix.cpp:298
#8  0x0000003b4dc07d90 in start_thread (arg=0x7fb6d5e96700) at pthread_create.c:309
#9  0x0000003b4d4f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7fb68e056700 (LWP 32046)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x0000003521c7bfdf in wait (time=30000, this=0x7fb688005ee0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb688005e88, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003521c6f5af in QThreadPoolThread::run (this=0x7fb688006130) at concurrent/qthreadpool.cpp:141
#4  0x0000003521c7bb6b in QThreadPrivate::start (arg=0x7fb688006130) at thread/qthread_unix.cpp:298
#5  0x0000003b4dc07d90 in start_thread (arg=0x7fb68e056700) at pthread_create.c:309
#6  0x0000003b4d4f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fb68d855700 (LWP 32047)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x0000003521c7bfdf in wait (time=30000, this=0x7fb688005ee0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb688005e88, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003521c6f5af in QThreadPoolThread::run (this=0x7fb6880067a0) at concurrent/qthreadpool.cpp:141
#4  0x0000003521c7bb6b in QThreadPrivate::start (arg=0x7fb6880067a0) at thread/qthread_unix.cpp:298
#5  0x0000003b4dc07d90 in start_thread (arg=0x7fb68d855700) at pthread_create.c:309
#6  0x0000003b4d4f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fb68cc4a700 (LWP 32048)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x0000003521c7bfdf in wait (time=30000, this=0x7fb688005ee0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fb688005e88, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003521c6f5af in QThreadPoolThread::run (this=0x7fb68800e140) at concurrent/qthreadpool.cpp:141
#4  0x0000003521c7bb6b in QThreadPrivate::start (arg=0x7fb68800e140) at thread/qthread_unix.cpp:298
#5  0x0000003b4dc07d90 in start_thread (arg=0x7fb68cc4a700) at pthread_create.c:309
#6  0x0000003b4d4f0f5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fb6e2ca4840 (LWP 32018)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x120a9d0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00000035226f6409 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x120a9d0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x0000003521d91f16 in QObject::event (this=0x120a9d0, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x0000003523dc9994 in notify_helper (e=0x7fb6880055e0, receiver=0x120a9d0, this=0xacc1f0) at kernel/qapplication.cpp:4550
#10 QApplicationPrivate::notify_helper (this=0xacc1f0, receiver=0x120a9d0, e=0x7fb6880055e0) at kernel/qapplication.cpp:4522
#11 0x0000003523dce813 in QApplication::notify (this=0x7fff5fd22070, receiver=0x120a9d0, e=0x7fb6880055e0) at kernel/qapplication.cpp:4411
#12 0x0000003525050766 in KApplication::notify (this=0x7fff5fd22070, receiver=0x120a9d0, event=0x7fb6880055e0) at /usr/src/debug/kdelibs-4.7.4/kdeui/kernel/kapplication.cpp:311
#13 0x0000003521d7904c in QCoreApplication::notifyInternal (this=0x7fff5fd22070, receiver=0x120a9d0, event=0x7fb6880055e0) at kernel/qcoreapplication.cpp:876
#14 0x0000003521d7cada in sendEvent (event=0x7fb6880055e0, receiver=0x120a9d0) at kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xa7b210) at kernel/qcoreapplication.cpp:1500
#16 0x0000003521da7933 in sendPostedEvents () at kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=0xacfab0) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00000037a0444acd in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#19 0x00000037a04452c8 in ?? () from /lib64/libglib-2.0.so.0
#20 0x00000037a044549c in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#21 0x0000003521da7d5f in QEventDispatcherGlib::processEvents (this=0xa7caf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#22 0x0000003523e6c66e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:207
#23 0x0000003521d78182 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x0000003521d783d7 in QEventLoop::exec (this=0x7fff5fd21f40, flags=...) at kernel/qeventloop.cpp:204
#25 0x0000003521d7cdd5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402d23 in main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/kdepim-4.7.4/kmail/main.cpp:145

Possible duplicates by query: bug 294828, bug 293172, bug 292991, bug 292546, bug 291913.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-03-02 17:28:52 UTC

*** This bug has been marked as a duplicate of bug 286320 ***