Bug 295960 - muon crash
Summary: muon crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-13 21:46 UTC by jonny amrques
Modified: 2012-03-13 21:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-03-13 21:46:10 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
every time I try open app manager, this crash... this app is muon

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76f3930 (LWP 5393))]

Thread 2 (Thread 0xb57d7b70 (LWP 5394)):
#0  0x0087ed44 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00d9c2f4 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x0209ff1f in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x020a08f0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x020a0c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00ab8b37 in QEventDispatcherGlib::processEvents (this=0x854a2b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00a891dd in QEventLoop::processEvents (this=0xb57d72b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00a89421 in QEventLoop::exec (this=0xb57d72b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0098c90b in QThread::exec (this=0x850d210) at thread/qthread.cpp:498
#9  0x00a69e2d in QInotifyFileSystemWatcherEngine::run (this=0x850d210) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0098f7b3 in QThreadPrivate::start (arg=0x850d210) at thread/qthread_unix.cpp:331
#11 0x0087bd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00d8e46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb76f3930 (LWP 5393)):
[KCrash Handler]
#7  0x009e3e11 in QtPrivate::QStringList_contains (that=0xbf8f2904, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf8f2904) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x850e5d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x850e5d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8f2b24) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00a90b7d in metacall (argv=0xbf8f2b24, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x850e5d8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x850e5d8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf8f2b24) at kernel/qmetaobject.cpp:232
#13 0x00a9fa6a in QMetaObject::activate (sender=0x8566e58, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8566e58) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8566e58, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8f2c68) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00a90b7d in metacall (argv=0xbf8f2c68, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8566e58) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8566e58, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf8f2c68) at kernel/qmetaobject.cpp:232
#18 0x00a9fa6a in QMetaObject::activate (sender=0x850e5d8, m=0x80950c0, local_signal_index=0, argv=0xbf8f2c68) at kernel/qobject.cpp:3278
#19 0x004f17c5 in MuonMainWindow::backendReady (this=0x850e5d8, _t1=0x850e818) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x004f1933 in MuonMainWindow::initObject (this=0x850e5d8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x850e5d8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x850e5d8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf8f2d94) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00a90b7d in metacall (argv=0xbf8f2d94, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x850e5d8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x850e5d8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf8f2d94) at kernel/qmetaobject.cpp:232
#25 0x00a9fa6a in QMetaObject::activate (sender=0x856c670, m=0xbc0238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00aa7375 in QSingleShotTimer::timeout (this=0x856c670) at .moc/release-shared/qtimer.moc:82
#27 0x00aa742c in QSingleShotTimer::timerEvent (this=0x856c670) at kernel/qtimer.cpp:308
#28 0x00aa2994 in QObject::event (this=0x856c670, e=0xbf8f318c) at kernel/qobject.cpp:1181
#29 0x0147cd84 in notify_helper (e=0xbf8f318c, receiver=0x856c670, this=0x843cde8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x843cde8, receiver=0x856c670, e=0xbf8f318c) at kernel/qapplication.cpp:4458
#31 0x01482133 in QApplication::notify (this=0xbf8f318c, receiver=0x856c670, e=0xbf8f318c) at kernel/qapplication.cpp:3886
#32 0x010d2971 in KApplication::notify (this=0xbf8f34a0, receiver=0x856c670, event=0xbf8f318c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00a8a19e in QCoreApplication::notifyInternal (this=0xbf8f34a0, receiver=0x856c670, event=0xbf8f318c) at kernel/qcoreapplication.cpp:787
#34 0x00abac10 in sendEvent (event=0xbf8f318c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x843e834) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00ab8122 in timerSourceDispatch (source=0x843e800) at kernel/qeventdispatcher_glib.cpp:184
#37 0x020a025f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x020a0990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x020a0c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00ab8ada in QEventDispatcherGlib::processEvents (this=0x8420238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x01534e7a in QGuiEventDispatcherGlib::processEvents (this=0x8420238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00a891dd in QEventLoop::processEvents (this=0xbf8f3404, flags=...) at kernel/qeventloop.cpp:149
#43 0x00a89421 in QEventLoop::exec (this=0xbf8f3404, flags=...) at kernel/qeventloop.cpp:201
#44 0x00a8e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0147a924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295950, bug 295946, bug 295939, bug 295919, bug 295895.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-13 21:58:11 UTC

*** This bug has been marked as a duplicate of bug 291262 ***