Bug 295950 - moun app manager always crash when I try open
Summary: moun app manager always crash when I try open
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-13 18:38 UTC by jonny amrques
Modified: 2012-03-13 22:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonny amrques 2012-03-13 18:38:26 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
moun app manager always crash when I try open. I tryed everyng , but nothing works

The crash can be reproduced every time.

-- Backtrace:
Application: Central de Aplicativos Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771f930 (LWP 3214))]

Thread 2 (Thread 0xb4109b70 (LWP 3220)):
#0  0x0045ad10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x00d897d5 in do_gettime (frac=0xb4109020, sec=0xb4109018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00e5c4b6 in QTimerInfoList::updateCurrentTime (this=0xa2c4074) at kernel/qeventdispatcher_unix.cpp:339
#4  0x00e5c80a in QTimerInfoList::timerWait (this=0xa2c4074, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x00e5b053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb410912c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x00e5b0ed in timerSourcePrepare (source=0xa2c4040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x0413588c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x04136637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x04136c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x00e5bb37 in QEventDispatcherGlib::processEvents (this=0xa1df4b8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x00e2c1dd in QEventLoop::processEvents (this=0xb41092b0, flags=...) at kernel/qeventloop.cpp:149
#12 0x00e2c421 in QEventLoop::exec (this=0xb41092b0, flags=...) at kernel/qeventloop.cpp:201
#13 0x00d2f90b in QThread::exec (this=0xa2bd218) at thread/qthread.cpp:498
#14 0x00e0ce2d in QInotifyFileSystemWatcherEngine::run (this=0xa2bd218) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x00d327b3 in QThreadPrivate::start (arg=0xa2bd218) at thread/qthread_unix.cpp:331
#16 0x00c89d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x0039246e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb771f930 (LWP 3214)):
[KCrash Handler]
#7  0x00d86e11 in QtPrivate::QStringList_contains (that=0xbfa3f2d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa3f2d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0xa17f648) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0xa17f648, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa3f4f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00e33b7d in metacall (argv=0xbfa3f4f4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0xa17f648) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0xa17f648, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfa3f4f4) at kernel/qmetaobject.cpp:232
#13 0x00e42a6a in QMetaObject::activate (sender=0xa0a9c28, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0xa0a9c28) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0xa0a9c28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa3f638) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00e33b7d in metacall (argv=0xbfa3f638, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0xa0a9c28) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0xa0a9c28, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfa3f638) at kernel/qmetaobject.cpp:232
#18 0x00e42a6a in QMetaObject::activate (sender=0xa17f648, m=0x80950c0, local_signal_index=0, argv=0xbfa3f638) at kernel/qobject.cpp:3278
#19 0x00a637c5 in MuonMainWindow::backendReady (this=0xa17f648, _t1=0xa17db98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00a63933 in MuonMainWindow::initObject (this=0xa17f648) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0xa17f648) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0xa17f648, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa3f764) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00e33b7d in metacall (argv=0xbfa3f764, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0xa17f648) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0xa17f648, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfa3f764) at kernel/qmetaobject.cpp:232
#25 0x00e42a6a in QMetaObject::activate (sender=0xa1d5df8, m=0xf63238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00e4a375 in QSingleShotTimer::timeout (this=0xa1d5df8) at .moc/release-shared/qtimer.moc:82
#27 0x00e4a42c in QSingleShotTimer::timerEvent (this=0xa1d5df8) at kernel/qtimer.cpp:308
#28 0x00e45994 in QObject::event (this=0xa1d5df8, e=0xbfa3fb5c) at kernel/qobject.cpp:1181
#29 0x04c5fd84 in notify_helper (e=0xbfa3fb5c, receiver=0xa1d5df8, this=0xa0b4068) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0xa0b4068, receiver=0xa1d5df8, e=0xbfa3fb5c) at kernel/qapplication.cpp:4458
#31 0x04c65133 in QApplication::notify (this=0xbfa3fb5c, receiver=0xa1d5df8, e=0xbfa3fb5c) at kernel/qapplication.cpp:3886
#32 0x01197971 in KApplication::notify (this=0xbfa3fe70, receiver=0xa1d5df8, event=0xbfa3fb5c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00e2d19e in QCoreApplication::notifyInternal (this=0xbfa3fe70, receiver=0xa1d5df8, event=0xbfa3fb5c) at kernel/qcoreapplication.cpp:787
#34 0x00e5dc10 in sendEvent (event=0xbfa3fb5c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0xa0b6abc) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00e5b122 in timerSourceDispatch (source=0xa0b6a88) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0413625f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x04136990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x04136c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00e5bada in QEventDispatcherGlib::processEvents (this=0xa096238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x04d17e7a in QGuiEventDispatcherGlib::processEvents (this=0xa096238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00e2c1dd in QEventLoop::processEvents (this=0xbfa3fdd4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00e2c421 in QEventLoop::exec (this=0xbfa3fdd4, flags=...) at kernel/qeventloop.cpp:201
#44 0x00e3119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x04c5d924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295946, bug 295939, bug 295919, bug 295895, bug 295886.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-13 22:38:00 UTC

*** This bug has been marked as a duplicate of bug 291262 ***