Bug 296047 - Crashes on exit some applications.
Summary: Crashes on exit some applications.
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-15 08:54 UTC by scaphe
Modified: 2012-03-15 09:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description scaphe 2012-03-15 08:54:04 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.8.1 (4.8.1) (Compiled from sources)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-17-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: 

Just before the crash, I used the application "Muon". The crash occurred when leaving the application. Since the update my system, I observed several times the same problem when I leave applications.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c4930 (LWP 2575))]

Thread 2 (Thread 0xb5281b70 (LWP 2579)):
#0  __pthread_mutex_unlock (mutex=0x91f5bec) at pthread_mutex_unlock.c:290
#1  0x07f0b2f4 in pthread_mutex_unlock (mutex=0x91f5bec) at forward.c:184
#2  0x01e7687f in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01e77637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01e77c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x009161c7 in QEventDispatcherGlib::processEvents (this=0x9091e58, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x008e1d1d in QEventLoop::processEvents (this=0xb52812a0, flags=...) at kernel/qeventloop.cpp:149
#7  0x008e1fb9 in QEventLoop::exec (this=0xb52812a0, flags=...) at kernel/qeventloop.cpp:204
#8  0x007cb9dc in QThread::exec (this=0x9092cc0) at thread/qthread.cpp:501
#9  0x008bf2dd in QInotifyFileSystemWatcherEngine::run (this=0x9092cc0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x007cee70 in QThreadPrivate::start (arg=0x9092cc0) at thread/qthread_unix.cpp:298
#11 0x00348d31 in start_thread (arg=0xb5281b70) at pthread_create.c:304
#12 0x07efd46e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77c4930 (LWP 2575)):
[KCrash Handler]
#7  0x0805e766 in value (akey=..., this=0x99fcd64) at /usr/include/qt4/QtCore/qhash.h:607
#8  Application::getField (this=0x99fcd60, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#9  0x0805f0d7 in Application::untranslatedName (this=0x99fcd60) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#10 0x0805f29d in Application::name (this=0x99fcd60) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#11 0x08083b74 in ReviewsBackend::reviewsFetched (this=0x91d6248, job=0xa61f540) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#12 0x0805e465 in ReviewsBackend::qt_metacall (this=0x91d6248, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcf5388) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#13 0x008ea4ad in metacall (argv=0xbfcf5388, idx=6, cl=QMetaObject::InvokeMetaMethod, object=0x91d6248) at kernel/qmetaobject.cpp:245
#14 QMetaObject::metacall (object=0x91d6248, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfcf5388) at kernel/qmetaobject.cpp:240
#15 0x008fa1cd in QMetaObject::activate (sender=0xa61f540, m=0xd5458c, local_signal_index=3, argv=0xbfcf5388) at kernel/qobject.cpp:3566
#16 0x00ba6345 in KJob::result (this=0xa61f540, _t1=0xa61f540) at ./kjob.moc:194
#17 0x00ba6398 in KJob::emitResult (this=0xa61f540) at ../../kdecore/jobs/kjob.cpp:318
#18 0x00589d8c in KIO::FileCopyJob::slotResult (this=0xa61f540, job=0x90da638) at ../../kio/kio/job.cpp:2449
#19 0x00589b1d in KIO::FileCopyJob::qt_metacall (this=0xa61f540, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcf5528) at ./jobclasses.moc:724
#20 0x008ea4ad in metacall (argv=0xbfcf5528, idx=32, cl=QMetaObject::InvokeMetaMethod, object=0xa61f540) at kernel/qmetaobject.cpp:245
#21 QMetaObject::metacall (object=0xa61f540, cl=QMetaObject::InvokeMetaMethod, idx=32, argv=0xbfcf5528) at kernel/qmetaobject.cpp:240
#22 0x008fa1cd in QMetaObject::activate (sender=0x90da638, m=0xd5458c, local_signal_index=3, argv=0xbfcf5528) at kernel/qobject.cpp:3566
#23 0x00ba6345 in KJob::result (this=0x90da638, _t1=0x90da638) at ./kjob.moc:194
#24 0x00ba6398 in KJob::emitResult (this=0x90da638) at ../../kdecore/jobs/kjob.cpp:318
#25 0x005812b8 in KIO::SimpleJob::slotFinished (this=0x90da638) at ../../kio/kio/job.cpp:494
#26 0x00589fed in KIO::TransferJob::slotFinished (this=0x90da638) at ../../kio/kio/job.cpp:1081
#27 0x00588624 in KIO::TransferJob::qt_metacall (this=0x90da638, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcf57e0) at ./jobclasses.moc:369
#28 0x008ea4ad in metacall (argv=0xbfcf57e0, idx=47, cl=QMetaObject::InvokeMetaMethod, object=0x90da638) at kernel/qmetaobject.cpp:245
#29 QMetaObject::metacall (object=0x90da638, cl=QMetaObject::InvokeMetaMethod, idx=47, argv=0xbfcf57e0) at kernel/qmetaobject.cpp:240
#30 0x008fa1cd in QMetaObject::activate (sender=0x9182fa8, m=0x75f6a0, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3566
#31 0x0063f755 in KIO::SlaveInterface::finished (this=0x9182fa8) at ./slaveinterface.moc:171
#32 0x006425d9 in KIO::SlaveInterface::dispatch (this=0x9182fa8, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#33 0x0063ed3a in KIO::SlaveInterface::dispatch (this=0x9182fa8) at ../../kio/kio/slaveinterface.cpp:88
#34 0x00630368 in KIO::Slave::gotInput (this=0x9182fa8) at ../../kio/kio/slave.cpp:344
#35 0x00630bdc in KIO::Slave::qt_metacall (this=0x9182fa8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfcf5ae0) at ./slave.moc:82
#36 0x008ea4ad in metacall (argv=0xbfcf5ae0, idx=30, cl=QMetaObject::InvokeMetaMethod, object=0x9182fa8) at kernel/qmetaobject.cpp:245
#37 QMetaObject::metacall (object=0x9182fa8, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbfcf5ae0) at kernel/qmetaobject.cpp:240
#38 0x008fa1cd in QMetaObject::activate (sender=0x91441b8, m=0x75c4a8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3566
#39 0x0054c265 in KIO::Connection::readyRead (this=0x91441b8) at ./connection.moc:92
#40 0x0054ca9a in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#41 KIO::ConnectionPrivate::dequeue (this=0x9206b50) at ../../kio/kio/connection.cpp:71
#42 0x0054cb6f in KIO::Connection::qt_metacall (this=0x91441b8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x98fbe58) at ./connection.moc:79
#43 0x008ea4ad in metacall (argv=0x98fbe58, idx=5, cl=QMetaObject::InvokeMetaMethod, object=0x91441b8) at kernel/qmetaobject.cpp:245
#44 QMetaObject::metacall (object=0x91441b8, cl=QMetaObject::InvokeMetaMethod, idx=5, argv=0x98fbe58) at kernel/qmetaobject.cpp:240
#45 0x008f5445 in placeMetaCall (object=0x91441b8, this=0xa60b738) at kernel/qobject.cpp:527
#46 QMetaCallEvent::placeMetaCall (this=0xa60b738, object=0x91441b8) at kernel/qobject.cpp:522
#47 0x008fe48b in QObject::event (this=0x91441b8, e=0xa60b738) at kernel/qobject.cpp:1195
#48 0x05e7d844 in notify_helper (e=0xa60b738, receiver=0x91441b8, this=0x905d418) at kernel/qapplication.cpp:4555
#49 QApplicationPrivate::notify_helper (this=0x905d418, receiver=0x91441b8, e=0xa60b738) at kernel/qapplication.cpp:4527
#50 0x05e82c7d in QApplication::notify (this=0xa60b738, receiver=0x91441b8, e=0xa60b738) at kernel/qapplication.cpp:4284
#51 0x0102d051 in KApplication::notify (this=0xbfcf63d0, receiver=0x91441b8, event=0xa60b738) at ../../kdeui/kernel/kapplication.cpp:311
#52 0x008e318e in QCoreApplication::notifyInternal (this=0xbfcf63d0, receiver=0x91441b8, event=0xa60b738) at kernel/qcoreapplication.cpp:876
#53 0x008e72e8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#54 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9035090) at kernel/qcoreapplication.cpp:1500
#55 0x008e761c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#56 0x00915d74 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#57 postEventSourceDispatch (s=0x905f2e0) at kernel/qeventdispatcher_glib.cpp:279
#58 0x01e7725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#59 0x01e77990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#60 0x01e77c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#61 0x00916167 in QEventDispatcherGlib::processEvents (this=0x9035e20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#62 0x05f32fda in QGuiEventDispatcherGlib::processEvents (this=0x9035e20, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#63 0x008e1d1d in QEventLoop::processEvents (this=0xbfcf6334, flags=...) at kernel/qeventloop.cpp:149
#64 0x008e1fb9 in QEventLoop::exec (this=0xbfcf6334, flags=...) at kernel/qeventloop.cpp:204
#65 0x008e76ca in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#66 0x05e7b6a4 in QApplication::exec () at kernel/qapplication.cpp:3816
#67 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294370, bug 294327, bug 293679, bug 291761, bug 291238.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-15 09:01:32 UTC

*** This bug has been marked as a duplicate of bug 283728 ***