Bug 294370 - Software center crash
Summary: Software center crash
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 15:19 UTC by aldo.andreani
Modified: 2012-02-18 16:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aldo.andreani 2012-02-18 15:19:55 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: installing Ebumeter. After restart software center the installation works fine.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9b99f0a780 (LWP 2293))]

Thread 2 (Thread 0x7f9b84d91700 (LWP 2296)):
#0  0x00007f9b96adf773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9b93354f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9b93355429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9b98c9df3e in QEventDispatcherGlib::processEvents (this=0x23d1230, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f9b98c71cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9b98c71ef7 in QEventLoop::exec (this=0x7f9b84d90dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f9b98b8927f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f9b98c54cbf in QInotifyFileSystemWatcherEngine::run (this=0x239a3a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9b98b8bd05 in QThreadPrivate::start (arg=0x239a3a0) at thread/qthread_unix.cpp:331
#9  0x00007f9b93e36efc in start_thread (arg=0x7f9b84d91700) at pthread_create.c:304
#10 0x00007f9b96aeb89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9b99f0a780 (LWP 2293)):
[KCrash Handler]
#6  same_key (key0=..., h0=346165, this=0x2b0) at /usr/include/qt4/QtCore/qhash.h:225
#7  QHash<QByteArray, QByteArray>::findNode (this=<optimized out>, akey=..., ahp=0x0) at /usr/include/qt4/QtCore/qhash.h:885
#8  0x000000000041c893 in value (akey=<optimized out>, this=0x2eb82d8) at /usr/include/qt4/QtCore/qhash.h:607
#9  Application::getField (this=0x2eb82d0, field=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#10 0x000000000041d0dd in Application::untranslatedName (this=0x2eb82d0) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#11 0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#12 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x2269a60, job=0x443e440) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#13 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x2269a60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1f190c20) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#14 0x00007f9b98c85eba in QMetaObject::activate (sender=0x443e440, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1f190c20) at kernel/qobject.cpp:3278
#15 0x00007f9b97ec1622 in KJob::result (this=<optimized out>, _t1=0x443e440) at ./kjob.moc:194
#16 0x00007f9b97ec1660 in KJob::emitResult (this=0x443e440) at ../../kdecore/jobs/kjob.cpp:312
#17 0x00007f9b997196fa in KIO::FileCopyJob::slotResult (this=0x443e440, job=0x42ee150) at ../../kio/kio/job.cpp:2449
#18 0x00007f9b997194a0 in KIO::FileCopyJob::qt_metacall (this=0x443e440, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1f190d90) at ./jobclasses.moc:724
#19 0x00007f9b98c85eba in QMetaObject::activate (sender=0x42ee150, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1f190d90) at kernel/qobject.cpp:3278
#20 0x00007f9b97ec1622 in KJob::result (this=<optimized out>, _t1=0x42ee150) at ./kjob.moc:194
#21 0x00007f9b97ec1660 in KJob::emitResult (this=0x42ee150) at ../../kdecore/jobs/kjob.cpp:312
#22 0x00007f9b99711d94 in KIO::SimpleJob::slotFinished (this=0x42ee150) at ../../kio/kio/job.cpp:494
#23 0x00007f9b9971994d in KIO::TransferJob::slotFinished (this=0x42ee150) at ../../kio/kio/job.cpp:1081
#24 0x00007f9b997182b1 in KIO::TransferJob::qt_metacall (this=0x42ee150, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1f191140) at ./jobclasses.moc:369
#25 0x00007f9b98c85eba in QMetaObject::activate (sender=0x3c70470, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00007f9b997c0081 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#27 0x00007f9b997bcf35 in KIO::SlaveInterface::dispatch (this=0x3c70470) at ../../kio/kio/slaveinterface.cpp:88
#28 0x00007f9b997b00fe in KIO::Slave::gotInput (this=0x3c70470) at ../../kio/kio/slave.cpp:344
#29 0x00007f9b997b085c in KIO::Slave::qt_metacall (this=0x3c70470, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1f191570) at ./slave.moc:82
#30 0x00007f9b98c85eba in QMetaObject::activate (sender=0x3d39920, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#31 0x00007f9b996e2827 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#32 KIO::ConnectionPrivate::dequeue (this=0x3e9c320) at ../../kio/kio/connection.cpp:71
#33 0x00007f9b996e28cd in KIO::Connection::qt_metacall (this=0x3d39920, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x3c4eb00) at ./connection.moc:79
#34 0x00007f9b98c89a5e in QObject::event (this=0x3d39920, e=<optimized out>) at kernel/qobject.cpp:1217
#35 0x00007f9b972ac474 in notify_helper (e=0x3e4b090, receiver=0x3d39920, this=0x21d4620) at kernel/qapplication.cpp:4486
#36 QApplicationPrivate::notify_helper (this=0x21d4620, receiver=0x3d39920, e=0x3e4b090) at kernel/qapplication.cpp:4458
#37 0x00007f9b972b12e1 in QApplication::notify (this=0x7fff1f193a40, receiver=0x3d39920, e=0x3e4b090) at kernel/qapplication.cpp:4365
#38 0x00007f9b98491466 in KApplication::notify (this=0x7fff1f193a40, receiver=0x3d39920, event=0x3e4b090) at ../../kdeui/kernel/kapplication.cpp:311
#39 0x00007f9b98c72afc in QCoreApplication::notifyInternal (this=0x7fff1f193a40, receiver=0x3d39920, event=0x3e4b090) at kernel/qcoreapplication.cpp:787
#40 0x00007f9b98c7651f in sendEvent (event=0x3e4b090, receiver=0x3d39920) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x21a9be0) at kernel/qcoreapplication.cpp:1428
#42 0x00007f9b98c9da73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#44 0x00007f9b93354a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f9b93355258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f9b93355429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007f9b98c9ded6 in QEventDispatcherGlib::processEvents (this=0x21ab6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#48 0x00007f9b9735410e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007f9b98c7692f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:979
#50 0x00007f9b993ffcf3 in QApt::CacheBuildProgress::Update (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:36
#51 0x00007f9b948ba27b in pkgDepCache::Init(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#52 0x00007f9b948e41fd in pkgCacheFile::BuildDepCache(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#53 0x00007f9b948e427a in pkgCacheFile::Open(OpProgress*, bool) () from /usr/lib/libapt-pkg.so.4.11
#54 0x00007f9b993ffab7 in QApt::Cache::open (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:85
#55 0x00007f9b993fae22 in QApt::Backend::reloadCache (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/backend.cpp:184
#56 0x0000000000420dbb in ApplicationBackend::reload (this=0x2371280) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:118
#57 0x0000000000420ff5 in ApplicationBackend::workerEvent (this=0x2371280, event=<optimized out>) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:179
#58 0x000000000041c383 in ApplicationBackend::qt_metacall (this=0x2371280, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff1f192bc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:113
#59 0x00007f9b98c85eba in QMetaObject::activate (sender=0x23dd680, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1f192bc0) at kernel/qobject.cpp:3278
#60 0x00007f9b99415f41 in QApt::Backend::workerEvent (this=<optimized out>, _t1=QApt::CommitChangesFinished) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:244
#61 0x00007f9b9941619c in QApt::Backend::qt_metacall (this=0x23dd680, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0x7fff1f192cd0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:204
#62 0x00007f9b98c85eba in QMetaObject::activate (sender=0x23c39c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1f192cd0) at kernel/qobject.cpp:3278
#63 0x00007f9b99416ae1 in OrgKubuntuQaptworkerInterface::workerEvent (this=<optimized out>, _t1=6) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:228
#64 0x00007f9b99416ee5 in OrgKubuntuQaptworkerInterface::qt_metacall (this=0x23c39c0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fff1f1931b0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:131
#65 0x00007f9b94e270e9 in QDBusConnectionPrivate::deliverCall (this=0x23b7530, object=0x23c39c0, msg=..., metaTypes=..., slotIdx=13) at qdbusintegrator.cpp:942
#66 0x00007f9b94e3038f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#67 0x00007f9b98c89a5e in QObject::event (this=0x23c39c0, e=<optimized out>) at kernel/qobject.cpp:1217
#68 0x00007f9b972ac474 in notify_helper (e=0x3cce380, receiver=0x23c39c0, this=0x21d4620) at kernel/qapplication.cpp:4486
#69 QApplicationPrivate::notify_helper (this=0x21d4620, receiver=0x23c39c0, e=0x3cce380) at kernel/qapplication.cpp:4458
#70 0x00007f9b972b12e1 in QApplication::notify (this=0x7fff1f193a40, receiver=0x23c39c0, e=0x3cce380) at kernel/qapplication.cpp:4365
#71 0x00007f9b98491466 in KApplication::notify (this=0x7fff1f193a40, receiver=0x23c39c0, event=0x3cce380) at ../../kdeui/kernel/kapplication.cpp:311
#72 0x00007f9b98c72afc in QCoreApplication::notifyInternal (this=0x7fff1f193a40, receiver=0x23c39c0, event=0x3cce380) at kernel/qcoreapplication.cpp:787
#73 0x00007f9b98c7651f in sendEvent (event=0x3cce380, receiver=0x23c39c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#74 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x21a9be0) at kernel/qcoreapplication.cpp:1428
#75 0x00007f9b98c9da73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#77 0x00007f9b93354a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#78 0x00007f9b93355258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#79 0x00007f9b93355429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#80 0x00007f9b98c9ded6 in QEventDispatcherGlib::processEvents (this=0x21ab6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#81 0x00007f9b9735410e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#82 0x00007f9b98c71cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#83 0x00007f9b98c71ef7 in QEventLoop::exec (this=0x7fff1f1939d0, flags=...) at kernel/qeventloop.cpp:201
#84 0x00007f9b98c76789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#85 0x000000000041bd67 in main (argc=5, argv=0x7fff1f193cb8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294327, bug 290145.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-18 16:26:08 UTC

*** This bug has been marked as a duplicate of bug 283728 ***