Bug 291761 - muon crashed
Summary: muon crashed
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-17 11:39 UTC by Marcel Litfin
Modified: 2012-01-17 12:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Litfin 2012-01-17 11:39:43 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

tried to install some stuff with the muon. crashed while i was looking for some graphics->3d software. no software downloaded, program crashed.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc6e4da7780 (LWP 4306))]

Thread 2 (Thread 0x7fc6cfc8d700 (LWP 4310)):
#0  0x00007fc6e1985773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc6de1faf68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc6de1fb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc6e3b43f3e in QEventDispatcherGlib::processEvents (this=0x1ac7aa0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc6e3b17cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc6e3b17ef7 in QEventLoop::exec (this=0x7fc6cfc8cdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc6e3a2f27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fc6e3afacbf in QInotifyFileSystemWatcherEngine::run (this=0x1ac98d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc6e3a31d05 in QThreadPrivate::start (arg=0x1ac98d0) at thread/qthread_unix.cpp:331
#9  0x00007fc6decdcefc in start_thread (arg=0x7fc6cfc8d700) at pthread_create.c:304
#10 0x00007fc6e199189d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc6e4da7780 (LWP 4306)):
[KCrash Handler]
#6  value (akey=..., this=0x2d14758) at /usr/include/qt4/QtCore/qhash.h:607
#7  Application::getField (this=0x2d14750, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#8  0x000000000041d0dd in Application::untranslatedName (this=0x2d14750) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#9  0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#10 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x1c23d60, job=0x2d736e0) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#11 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x1c23d60, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc1749e00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#12 0x00007fc6e3b2beba in QMetaObject::activate (sender=0x2d736e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc1749e00) at kernel/qobject.cpp:3278
#13 0x00007fc6e2d67622 in KJob::result (this=<optimized out>, _t1=0x2d736e0) at ./kjob.moc:194
#14 0x00007fc6e2d67660 in KJob::emitResult (this=0x2d736e0) at ../../kdecore/jobs/kjob.cpp:312
#15 0x00007fc6e45bf6fa in KIO::FileCopyJob::slotResult (this=0x2d736e0, job=0x2dd16c0) at ../../kio/kio/job.cpp:2449
#16 0x00007fc6e45bf4a0 in KIO::FileCopyJob::qt_metacall (this=0x2d736e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc1749f70) at ./jobclasses.moc:724
#17 0x00007fc6e3b2beba in QMetaObject::activate (sender=0x2dd16c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffc1749f70) at kernel/qobject.cpp:3278
#18 0x00007fc6e2d67622 in KJob::result (this=<optimized out>, _t1=0x2dd16c0) at ./kjob.moc:194
#19 0x00007fc6e2d67660 in KJob::emitResult (this=0x2dd16c0) at ../../kdecore/jobs/kjob.cpp:312
#20 0x00007fc6e45b7d94 in KIO::SimpleJob::slotFinished (this=0x2dd16c0) at ../../kio/kio/job.cpp:494
#21 0x00007fc6e45bf94d in KIO::TransferJob::slotFinished (this=0x2dd16c0) at ../../kio/kio/job.cpp:1081
#22 0x00007fc6e45be2b1 in KIO::TransferJob::qt_metacall (this=0x2dd16c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc174a320) at ./jobclasses.moc:369
#23 0x00007fc6e3b2beba in QMetaObject::activate (sender=0x250efc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#24 0x00007fc6e4666081 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#25 0x00007fc6e4662f35 in KIO::SlaveInterface::dispatch (this=0x250efc0) at ../../kio/kio/slaveinterface.cpp:88
#26 0x00007fc6e46560fe in KIO::Slave::gotInput (this=0x250efc0) at ../../kio/kio/slave.cpp:344
#27 0x00007fc6e465685c in KIO::Slave::qt_metacall (this=0x250efc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffc174a750) at ./slave.moc:82
#28 0x00007fc6e3b2beba in QMetaObject::activate (sender=0x20d7570, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#29 0x00007fc6e4588827 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#30 KIO::ConnectionPrivate::dequeue (this=0x4222f70) at ../../kio/kio/connection.cpp:71
#31 0x00007fc6e45888cd in KIO::Connection::qt_metacall (this=0x20d7570, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2c6ff30) at ./connection.moc:79
#32 0x00007fc6e3b2fa5e in QObject::event (this=0x20d7570, e=<optimized out>) at kernel/qobject.cpp:1217
#33 0x00007fc6e2152474 in notify_helper (e=0x40b08d0, receiver=0x20d7570, this=0x1a6d5a0) at kernel/qapplication.cpp:4486
#34 QApplicationPrivate::notify_helper (this=0x1a6d5a0, receiver=0x20d7570, e=0x40b08d0) at kernel/qapplication.cpp:4458
#35 0x00007fc6e21572e1 in QApplication::notify (this=0x7fffc174b000, receiver=0x20d7570, e=0x40b08d0) at kernel/qapplication.cpp:4365
#36 0x00007fc6e3337466 in KApplication::notify (this=0x7fffc174b000, receiver=0x20d7570, event=0x40b08d0) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007fc6e3b18afc in QCoreApplication::notifyInternal (this=0x7fffc174b000, receiver=0x20d7570, event=0x40b08d0) at kernel/qcoreapplication.cpp:787
#38 0x00007fc6e3b1c51f in sendEvent (event=0x40b08d0, receiver=0x20d7570) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1a43be0) at kernel/qcoreapplication.cpp:1428
#40 0x00007fc6e3b43a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007fc6de1faa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007fc6de1fb258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007fc6de1fb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007fc6e3b43ed6 in QEventDispatcherGlib::processEvents (this=0x1a456f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#46 0x00007fc6e21fa10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007fc6e3b17cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007fc6e3b17ef7 in QEventLoop::exec (this=0x7fffc174af90, flags=...) at kernel/qeventloop.cpp:201
#49 0x00007fc6e3b1c789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#50 0x000000000041bd67 in main (argc=5, argv=0x7fffc174b278) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 291238, bug 290145, bug 288692, bug 286903, bug 285580.

Reported using DrKonqi
Comment 1 Thijs 2012-01-17 12:34:16 UTC

*** This bug has been marked as a duplicate of bug 291262 ***