Bug 293679 - Crash Muon podczas instalacji aplikacji
Summary: Crash Muon podczas instalacji aplikacji
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: muon
Classification: Unclassified
Component: installer (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-08 21:23 UTC by xa.kasprzyk
Modified: 2012-02-11 16:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xa.kasprzyk 2012-02-08 21:23:40 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.8.00 (4.8.0
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Włączyłem program wyszukałem aplikację (błędnie wpisałem nazwę), wyszukałem ponownie wpisująć inną i kliknąłem zainstaluj.
Aplikacja pobierała się, chciałem zobaczyć screena innej i nagle Muon scrashował się.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Centrum oprogramowania Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc7ee992780 (LWP 13556))]

Thread 2 (Thread 0x7fc7d9d4c700 (LWP 13561)):
#0  0x00007fc7eb55c773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fc7e7dcef68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc7e7dcf429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc7ed71bf3e in QEventDispatcherGlib::processEvents (this=0xaec510, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc7ed6efcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc7ed6efef7 in QEventLoop::exec (this=0x7fc7d9d4bdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc7ed60727f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fc7ed6d2cbf in QInotifyFileSystemWatcherEngine::run (this=0xaeb9e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fc7ed609d05 in QThreadPrivate::start (arg=0xaeb9e0) at thread/qthread_unix.cpp:331
#9  0x00007fc7e88b0efc in start_thread (arg=0x7fc7d9d4c700) at pthread_create.c:304
#10 0x00007fc7eb56889d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc7ee992780 (LWP 13556)):
[KCrash Handler]
#6  same_key (key0=..., h0=346165, this=0x0) at /usr/include/qt4/QtCore/qhash.h:225
#7  QHash<QByteArray, QByteArray>::findNode (this=<optimized out>, akey=..., ahp=0x0) at /usr/include/qt4/QtCore/qhash.h:885
#8  0x000000000041c893 in value (akey=<optimized out>, this=0x1a82b88) at /usr/include/qt4/QtCore/qhash.h:607
#9  Application::getField (this=0x1a82b80, field=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#10 0x000000000041d0dd in Application::untranslatedName (this=0x1a82b80) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#11 0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#12 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x974110, job=0x23fe700) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#13 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x974110, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff803c8510) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#14 0x00007fc7ed703eba in QMetaObject::activate (sender=0x23fe700, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff803c8510) at kernel/qobject.cpp:3278
#15 0x00007fc7ec93e9d2 in KJob::result (this=<optimized out>, _t1=0x23fe700) at ./kjob.moc:194
#16 0x00007fc7ec93ea10 in KJob::emitResult (this=0x23fe700) at ../../kdecore/jobs/kjob.cpp:318
#17 0x00007fc7ee1979aa in KIO::FileCopyJob::slotResult (this=0x23fe700, job=0x23dd310) at ../../kio/kio/job.cpp:2449
#18 0x00007fc7ee197750 in KIO::FileCopyJob::qt_metacall (this=0x23fe700, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff803c8680) at ./jobclasses.moc:724
#19 0x00007fc7ed703eba in QMetaObject::activate (sender=0x23dd310, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff803c8680) at kernel/qobject.cpp:3278
#20 0x00007fc7ec93e9d2 in KJob::result (this=<optimized out>, _t1=0x23dd310) at ./kjob.moc:194
#21 0x00007fc7ec93ea10 in KJob::emitResult (this=0x23dd310) at ../../kdecore/jobs/kjob.cpp:318
#22 0x00007fc7ee190044 in KIO::SimpleJob::slotFinished (this=0x23dd310) at ../../kio/kio/job.cpp:494
#23 0x00007fc7ee197bfd in KIO::TransferJob::slotFinished (this=0x23dd310) at ../../kio/kio/job.cpp:1081
#24 0x00007fc7ee196561 in KIO::TransferJob::qt_metacall (this=0x23dd310, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff803c8a30) at ./jobclasses.moc:369
#25 0x00007fc7ed703eba in QMetaObject::activate (sender=0x90b270, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00007fc7ee23e3d1 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#27 0x00007fc7ee23b285 in KIO::SlaveInterface::dispatch (this=0x90b270) at ../../kio/kio/slaveinterface.cpp:88
#28 0x00007fc7ee22e44e in KIO::Slave::gotInput (this=0x90b270) at ../../kio/kio/slave.cpp:344
#29 0x00007fc7ee22ebac in KIO::Slave::qt_metacall (this=0x90b270, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff803c8e60) at ./slave.moc:82
#30 0x00007fc7ed703eba in QMetaObject::activate (sender=0x96be80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#31 0x00007fc7ee160af7 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#32 KIO::ConnectionPrivate::dequeue (this=0xad9bf0) at ../../kio/kio/connection.cpp:71
#33 0x00007fc7ee160b9d in KIO::Connection::qt_metacall (this=0x96be80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x233e390) at ./connection.moc:79
#34 0x00007fc7ed707a5e in QObject::event (this=0x96be80, e=<optimized out>) at kernel/qobject.cpp:1217
#35 0x00007fc7ebd29474 in notify_helper (e=0x219fa30, receiver=0x96be80, this=0x7a50e0) at kernel/qapplication.cpp:4486
#36 QApplicationPrivate::notify_helper (this=0x7a50e0, receiver=0x96be80, e=0x219fa30) at kernel/qapplication.cpp:4458
#37 0x00007fc7ebd2e2e1 in QApplication::notify (this=0x7fff803cb330, receiver=0x96be80, e=0x219fa30) at kernel/qapplication.cpp:4365
#38 0x00007fc7ecf0fae6 in KApplication::notify (this=0x7fff803cb330, receiver=0x96be80, event=0x219fa30) at ../../kdeui/kernel/kapplication.cpp:311
#39 0x00007fc7ed6f0afc in QCoreApplication::notifyInternal (this=0x7fff803cb330, receiver=0x96be80, event=0x219fa30) at kernel/qcoreapplication.cpp:787
#40 0x00007fc7ed6f451f in sendEvent (event=0x219fa30, receiver=0x96be80) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x77bbe0) at kernel/qcoreapplication.cpp:1428
#42 0x00007fc7ed71ba73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#44 0x00007fc7e7dcea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007fc7e7dcf258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007fc7e7dcf429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007fc7ed71bed6 in QEventDispatcherGlib::processEvents (this=0x77d6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#48 0x00007fc7ebdd110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007fc7ed6f492f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:979
#50 0x00007fc7ede7dcf3 in QApt::CacheBuildProgress::Update (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:36
#51 0x00007fc7e933427b in pkgDepCache::Init(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#52 0x00007fc7e935e1fd in pkgCacheFile::BuildDepCache(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#53 0x00007fc7e935e27a in pkgCacheFile::Open(OpProgress*, bool) () from /usr/lib/libapt-pkg.so.4.11
#54 0x00007fc7ede7dab7 in QApt::Cache::open (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:85
#55 0x00007fc7ede78e22 in QApt::Backend::reloadCache (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/backend.cpp:184
#56 0x0000000000420dbb in ApplicationBackend::reload (this=0x9123d0) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:118
#57 0x0000000000420ff5 in ApplicationBackend::workerEvent (this=0x9123d0, event=<optimized out>) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:179
#58 0x000000000041c383 in ApplicationBackend::qt_metacall (this=0x9123d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff803ca4b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:113
#59 0x00007fc7ed703eba in QMetaObject::activate (sender=0x798550, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff803ca4b0) at kernel/qobject.cpp:3278
#60 0x00007fc7ede93f41 in QApt::Backend::workerEvent (this=<optimized out>, _t1=QApt::CommitChangesFinished) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:244
#61 0x00007fc7ede9419c in QApt::Backend::qt_metacall (this=0x798550, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0x7fff803ca5c0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:204
#62 0x00007fc7ed703eba in QMetaObject::activate (sender=0x963e20, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff803ca5c0) at kernel/qobject.cpp:3278
#63 0x00007fc7ede94ae1 in OrgKubuntuQaptworkerInterface::workerEvent (this=<optimized out>, _t1=6) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:228
#64 0x00007fc7ede94ee5 in OrgKubuntuQaptworkerInterface::qt_metacall (this=0x963e20, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fff803caaa0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:131
#65 0x00007fc7e98a10e9 in QDBusConnectionPrivate::deliverCall (this=0x97c9d0, object=0x963e20, msg=..., metaTypes=..., slotIdx=13) at qdbusintegrator.cpp:942
#66 0x00007fc7e98aa38f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#67 0x00007fc7ed707a5e in QObject::event (this=0x963e20, e=<optimized out>) at kernel/qobject.cpp:1217
#68 0x00007fc7ebd29474 in notify_helper (e=0x23adde0, receiver=0x963e20, this=0x7a50e0) at kernel/qapplication.cpp:4486
#69 QApplicationPrivate::notify_helper (this=0x7a50e0, receiver=0x963e20, e=0x23adde0) at kernel/qapplication.cpp:4458
#70 0x00007fc7ebd2e2e1 in QApplication::notify (this=0x7fff803cb330, receiver=0x963e20, e=0x23adde0) at kernel/qapplication.cpp:4365
#71 0x00007fc7ecf0fae6 in KApplication::notify (this=0x7fff803cb330, receiver=0x963e20, event=0x23adde0) at ../../kdeui/kernel/kapplication.cpp:311
#72 0x00007fc7ed6f0afc in QCoreApplication::notifyInternal (this=0x7fff803cb330, receiver=0x963e20, event=0x23adde0) at kernel/qcoreapplication.cpp:787
#73 0x00007fc7ed6f451f in sendEvent (event=0x23adde0, receiver=0x963e20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#74 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x77bbe0) at kernel/qcoreapplication.cpp:1428
#75 0x00007fc7ed71ba73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#76 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#77 0x00007fc7e7dcea5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#78 0x00007fc7e7dcf258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#79 0x00007fc7e7dcf429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#80 0x00007fc7ed71bed6 in QEventDispatcherGlib::processEvents (this=0x77d6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#81 0x00007fc7ebdd110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#82 0x00007fc7ed6efcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#83 0x00007fc7ed6efef7 in QEventLoop::exec (this=0x7fff803cb2c0, flags=...) at kernel/qeventloop.cpp:201
#84 0x00007fc7ed6f4789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#85 0x000000000041bd67 in main (argc=5, argv=0x7fff803cb5a8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 290145, bug 284817, bug 284139.

Reported using DrKonqi
Comment 1 Jonathan Thomas 2012-02-11 16:58:22 UTC

*** This bug has been marked as a duplicate of bug 283728 ***