Bug 294327 - Muon software center crashed after uninstalling
Summary: Muon software center crashed after uninstalling
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 00:25 UTC by stonecold.1995
Modified: 2012-02-18 01:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stonecold.1995 2012-02-18 00:25:13 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I was uninstalling Wine.  There were three Wine packages that I had to uninstall.  I pressed "Remove" on all of them, and when the final one finished uninstalling, the application crashed.  This has never happened before when I was uninstalling anything.

The crash does not seem to be reproducible.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f062237c780 (LWP 4283))]

Thread 2 (Thread 0x7f060d738700 (LWP 4287)):
#0  0x00007f061ef53773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f061b7c8f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f061b7c9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0621111f3e in QEventDispatcherGlib::processEvents (this=0x1a3b2f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f06210e5cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f06210e5ef7 in QEventLoop::exec (this=0x7f060d737dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f0620ffd27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f06210c8cbf in QInotifyFileSystemWatcherEngine::run (this=0x18f70d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f0620fffd05 in QThreadPrivate::start (arg=0x18f70d0) at thread/qthread_unix.cpp:331
#9  0x00007f061c2aaefc in start_thread (arg=0x7f060d738700) at pthread_create.c:304
#10 0x00007f061ef5f89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f062237c780 (LWP 4283)):
[KCrash Handler]
#6  same_key (key0=..., h0=346165, this=0x0) at /usr/include/qt4/QtCore/qhash.h:225
#7  QHash<QByteArray, QByteArray>::findNode (this=<optimized out>, akey=..., ahp=0x0) at /usr/include/qt4/QtCore/qhash.h:885
#8  0x000000000041c893 in value (akey=<optimized out>, this=0x2af1a28) at /usr/include/qt4/QtCore/qhash.h:607
#9  Application::getField (this=0x2af1a20, field=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#10 0x000000000041d0dd in Application::untranslatedName (this=0x2af1a20) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#11 0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#12 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x1a269c0, job=0x31e0110) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#13 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x1a269c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff841e5a70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#14 0x00007f06210f9eba in QMetaObject::activate (sender=0x31e0110, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff841e5a70) at kernel/qobject.cpp:3278
#15 0x00007f0620335622 in KJob::result (this=<optimized out>, _t1=0x31e0110) at ./kjob.moc:194
#16 0x00007f0620335660 in KJob::emitResult (this=0x31e0110) at ../../kdecore/jobs/kjob.cpp:312
#17 0x00007f0621b8d6fa in KIO::FileCopyJob::slotResult (this=0x31e0110, job=0x31f83e0) at ../../kio/kio/job.cpp:2449
#18 0x00007f0621b8d4a0 in KIO::FileCopyJob::qt_metacall (this=0x31e0110, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff841e5be0) at ./jobclasses.moc:724
#19 0x00007f06210f9eba in QMetaObject::activate (sender=0x31f83e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff841e5be0) at kernel/qobject.cpp:3278
#20 0x00007f0620335622 in KJob::result (this=<optimized out>, _t1=0x31f83e0) at ./kjob.moc:194
#21 0x00007f0620335660 in KJob::emitResult (this=0x31f83e0) at ../../kdecore/jobs/kjob.cpp:312
#22 0x00007f0621b85d94 in KIO::SimpleJob::slotFinished (this=0x31f83e0) at ../../kio/kio/job.cpp:494
#23 0x00007f0621b8d94d in KIO::TransferJob::slotFinished (this=0x31f83e0) at ../../kio/kio/job.cpp:1081
#24 0x00007f0621b8c2b1 in KIO::TransferJob::qt_metacall (this=0x31f83e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff841e5f90) at ./jobclasses.moc:369
#25 0x00007f06210f9eba in QMetaObject::activate (sender=0x337edf0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00007f0621c34081 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#27 0x00007f0621c30f35 in KIO::SlaveInterface::dispatch (this=0x337edf0) at ../../kio/kio/slaveinterface.cpp:88
#28 0x00007f0621c240fe in KIO::Slave::gotInput (this=0x337edf0) at ../../kio/kio/slave.cpp:344
#29 0x00007f0621c2485c in KIO::Slave::qt_metacall (this=0x337edf0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff841e63c0) at ./slave.moc:82
#30 0x00007f06210f9eba in QMetaObject::activate (sender=0x33bf430, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#31 0x00007f0621b56827 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#32 KIO::ConnectionPrivate::dequeue (this=0x33790e0) at ../../kio/kio/connection.cpp:71
#33 0x00007f0621b568cd in KIO::Connection::qt_metacall (this=0x33bf430, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2f03420) at ./connection.moc:79
#34 0x00007f06210fda5e in QObject::event (this=0x33bf430, e=<optimized out>) at kernel/qobject.cpp:1217
#35 0x00007f061f720474 in notify_helper (e=0x33c1de0, receiver=0x33bf430, this=0x18ba970) at kernel/qapplication.cpp:4486
#36 QApplicationPrivate::notify_helper (this=0x18ba970, receiver=0x33bf430, e=0x33c1de0) at kernel/qapplication.cpp:4458
#37 0x00007f061f7252e1 in QApplication::notify (this=0x7fff841e8950, receiver=0x33bf430, e=0x33c1de0) at kernel/qapplication.cpp:4365
#38 0x00007f0620905466 in KApplication::notify (this=0x7fff841e8950, receiver=0x33bf430, event=0x33c1de0) at ../../kdeui/kernel/kapplication.cpp:311
#39 0x00007f06210e6afc in QCoreApplication::notifyInternal (this=0x7fff841e8950, receiver=0x33bf430, event=0x33c1de0) at kernel/qcoreapplication.cpp:787
#40 0x00007f06210ea51f in sendEvent (event=0x33c1de0, receiver=0x33bf430) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#41 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1890be0) at kernel/qcoreapplication.cpp:1428
#42 0x00007f0621111a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#43 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#44 0x00007f061b7c8a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f061b7c9258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f061b7c9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007f0621111ed6 in QEventDispatcherGlib::processEvents (this=0x18926f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#48 0x00007f061f7c810e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00007f06210ea92f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:979
#50 0x00007f0621873cf3 in QApt::CacheBuildProgress::Update (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:36
#51 0x00007f061cd29020 in pkgDepCache::Update(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#52 0x00007f061cd2e23e in pkgDepCache::Init(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#53 0x00007f061cd581fd in pkgCacheFile::BuildDepCache(OpProgress*) () from /usr/lib/libapt-pkg.so.4.11
#54 0x00007f061cd5827a in pkgCacheFile::Open(OpProgress*, bool) () from /usr/lib/libapt-pkg.so.4.11
#55 0x00007f0621873ab7 in QApt::Cache::open (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/cache.cpp:85
#56 0x00007f062186ee22 in QApt::Backend::reloadCache (this=<optimized out>) at /build/buildd/qapt-1.2.1/src/backend.cpp:184
#57 0x0000000000420dbb in ApplicationBackend::reload (this=0x1b00510) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:118
#58 0x0000000000420ff5 in ApplicationBackend::workerEvent (this=0x1b00510, event=<optimized out>) at /build/buildd/muon-1.2.1/installer/ApplicationBackend.cpp:179
#59 0x000000000041c383 in ApplicationBackend::qt_metacall (this=0x1b00510, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff841e7ad0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:113
#60 0x00007f06210f9eba in QMetaObject::activate (sender=0x1a706e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff841e7ad0) at kernel/qobject.cpp:3278
#61 0x00007f0621889f41 in QApt::Backend::workerEvent (this=<optimized out>, _t1=QApt::CommitChangesFinished) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:244
#62 0x00007f062188a19c in QApt::Backend::qt_metacall (this=0x1a706e0, _c=QMetaObject::InvokeMetaMethod, _id=40, _a=0x7fff841e7be0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/moc_backend.cxx:204
#63 0x00007f06210f9eba in QMetaObject::activate (sender=0x1a06590, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff841e7be0) at kernel/qobject.cpp:3278
#64 0x00007f062188aae1 in OrgKubuntuQaptworkerInterface::workerEvent (this=<optimized out>, _t1=6) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:228
#65 0x00007f062188aee5 in OrgKubuntuQaptworkerInterface::qt_metacall (this=0x1a06590, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fff841e80c0) at /build/buildd/qapt-1.2.1/obj-x86_64-linux-gnu/src/workerdbus.moc:131
#66 0x00007f061d29b0e9 in QDBusConnectionPrivate::deliverCall (this=0x1ab7eb0, object=0x1a06590, msg=..., metaTypes=..., slotIdx=13) at qdbusintegrator.cpp:942
#67 0x00007f061d2a438f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#68 0x00007f06210fda5e in QObject::event (this=0x1a06590, e=<optimized out>) at kernel/qobject.cpp:1217
#69 0x00007f061f720474 in notify_helper (e=0x3372900, receiver=0x1a06590, this=0x18ba970) at kernel/qapplication.cpp:4486
#70 QApplicationPrivate::notify_helper (this=0x18ba970, receiver=0x1a06590, e=0x3372900) at kernel/qapplication.cpp:4458
#71 0x00007f061f7252e1 in QApplication::notify (this=0x7fff841e8950, receiver=0x1a06590, e=0x3372900) at kernel/qapplication.cpp:4365
#72 0x00007f0620905466 in KApplication::notify (this=0x7fff841e8950, receiver=0x1a06590, event=0x3372900) at ../../kdeui/kernel/kapplication.cpp:311
#73 0x00007f06210e6afc in QCoreApplication::notifyInternal (this=0x7fff841e8950, receiver=0x1a06590, event=0x3372900) at kernel/qcoreapplication.cpp:787
#74 0x00007f06210ea51f in sendEvent (event=0x3372900, receiver=0x1a06590) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#75 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1890be0) at kernel/qcoreapplication.cpp:1428
#76 0x00007f0621111a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#77 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#78 0x00007f061b7c8a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#79 0x00007f061b7c9258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#80 0x00007f061b7c9429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#81 0x00007f0621111ed6 in QEventDispatcherGlib::processEvents (this=0x18926f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#82 0x00007f061f7c810e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#83 0x00007f06210e5cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#84 0x00007f06210e5ef7 in QEventLoop::exec (this=0x7fff841e88e0, flags=...) at kernel/qeventloop.cpp:201
#85 0x00007f06210ea789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#86 0x000000000041bd67 in main (argc=5, argv=0x7fff841e8bc8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 283728.

Possible duplicates by query: bug 290145.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-18 00:36:13 UTC

*** This bug has been marked as a duplicate of bug 293728 ***
Comment 2 Jack 2012-02-18 01:02:09 UTC
I think there is a typo.  This was closed as a dup of 293728, which seems completely unrelated (KMyMoney wishlist item).  Should it have been 283728 (8 instead of 9 as second digit)?
Comment 3 Jekyll Wu 2012-02-18 01:04:33 UTC
Sorry for the typo of number

*** This bug has been marked as a duplicate of bug 283728 ***