Bug 291238 - Moun Software Center Crash
Summary: Moun Software Center Crash
Status: RESOLVED DUPLICATE of bug 283728
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-11 02:49 UTC by CJ Ryan
Modified: 2012-01-11 13:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description CJ Ryan 2012-01-11 02:49:39 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.3 (4.7.3) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I uninstalled digicam. When uninstall finished, Moun Software Center simply crashed.

nothing else to add...

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7028797780 (LWP 5329))]

Thread 2 (Thread 0x7f7013d53700 (LWP 5333)):
#0  0x00007f702536f773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7021be4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f7021be5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f702752cf3e in QEventDispatcherGlib::processEvents (this=0x1b534c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f7027500cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7027500ef7 in QEventLoop::exec (this=0x7f7013d52dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f702741827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f70274e3cbf in QInotifyFileSystemWatcherEngine::run (this=0x1b47d70) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f702741ad05 in QThreadPrivate::start (arg=0x1b47d70) at thread/qthread_unix.cpp:331
#9  0x00007f70226c6efc in start_thread (arg=0x7f7013d53700) at pthread_create.c:304
#10 0x00007f702537b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7028797780 (LWP 5329)):
[KCrash Handler]
#6  value (akey=..., this=0x1d645a8) at /usr/include/qt4/QtCore/qhash.h:607
#7  Application::getField (this=0x1d645a0, field=...) at /build/buildd/muon-1.2.1/installer/Application.cpp:342
#8  0x000000000041d0dd in Application::untranslatedName (this=0x1d645a0) at /build/buildd/muon-1.2.1/installer/Application.cpp:68
#9  0x000000000041d270 in Application::name (this=<optimized out>) at /build/buildd/muon-1.2.1/installer/Application.cpp:63
#10 0x000000000043f175 in ReviewsBackend::reviewsFetched (this=0x19a2070, job=0x3274190) at /build/buildd/muon-1.2.1/installer/ReviewsBackend/ReviewsBackend.cpp:208
#11 0x000000000041c563 in ReviewsBackend::qt_metacall (this=0x19a2070, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9981db30) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ReviewsBackend.cpp:81
#12 0x00007f7027514eba in QMetaObject::activate (sender=0x3274190, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9981db30) at kernel/qobject.cpp:3278
#13 0x00007f70267505b2 in KJob::result (this=<optimized out>, _t1=0x3274190) at ./kjob.moc:194
#14 0x00007f70267505f0 in KJob::emitResult (this=0x3274190) at ../../kdecore/jobs/kjob.cpp:312
#15 0x00007f7027fa743a in KIO::FileCopyJob::slotResult (this=0x3274190, job=0x280c9b0) at ../../kio/kio/job.cpp:2449
#16 0x00007f7027fa71e0 in KIO::FileCopyJob::qt_metacall (this=0x3274190, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9981dca0) at ./jobclasses.moc:724
#17 0x00007f7027514eba in QMetaObject::activate (sender=0x280c9b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff9981dca0) at kernel/qobject.cpp:3278
#18 0x00007f70267505b2 in KJob::result (this=<optimized out>, _t1=0x280c9b0) at ./kjob.moc:194
#19 0x00007f70267505f0 in KJob::emitResult (this=0x280c9b0) at ../../kdecore/jobs/kjob.cpp:312
#20 0x00007f7027f9fad4 in KIO::SimpleJob::slotFinished (this=0x280c9b0) at ../../kio/kio/job.cpp:494
#21 0x00007f7027fa768d in KIO::TransferJob::slotFinished (this=0x280c9b0) at ../../kio/kio/job.cpp:1081
#22 0x00007f7027fa5ff1 in KIO::TransferJob::qt_metacall (this=0x280c9b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9981e050) at ./jobclasses.moc:369
#23 0x00007f7027514eba in QMetaObject::activate (sender=0x327eda0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#24 0x00007f702804d1d1 in KIO::SlaveInterface::dispatch (this=<optimized out>, _cmd=104, rawdata=...) at ../../kio/kio/slaveinterface.cpp:172
#25 0x00007f702804a085 in KIO::SlaveInterface::dispatch (this=0x327eda0) at ../../kio/kio/slaveinterface.cpp:88
#26 0x00007f702803d24e in KIO::Slave::gotInput (this=0x327eda0) at ../../kio/kio/slave.cpp:344
#27 0x00007f702803d9ac in KIO::Slave::qt_metacall (this=0x327eda0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9981e480) at ./slave.moc:82
#28 0x00007f7027514eba in QMetaObject::activate (sender=0x2743400, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#29 0x00007f7027f70577 in dequeue (this=<optimized out>) at ../../kio/kio/connection.cpp:82
#30 KIO::ConnectionPrivate::dequeue (this=0x1f85ff0) at ../../kio/kio/connection.cpp:71
#31 0x00007f7027f7061d in KIO::Connection::qt_metacall (this=0x2743400, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x2554bd0) at ./connection.moc:79
#32 0x00007f7027518a5e in QObject::event (this=0x2743400, e=<optimized out>) at kernel/qobject.cpp:1217
#33 0x00007f7025b3c424 in notify_helper (e=0x1f867d0, receiver=0x2743400, this=0x1816b10) at kernel/qapplication.cpp:4486
#34 QApplicationPrivate::notify_helper (this=0x1816b10, receiver=0x2743400, e=0x1f867d0) at kernel/qapplication.cpp:4458
#35 0x00007f7025b41291 in QApplication::notify (this=0x7fff9981ed30, receiver=0x2743400, e=0x1f867d0) at kernel/qapplication.cpp:4365
#36 0x00007f7026d20126 in KApplication::notify (this=0x7fff9981ed30, receiver=0x2743400, event=0x1f867d0) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f7027501afc in QCoreApplication::notifyInternal (this=0x7fff9981ed30, receiver=0x2743400, event=0x1f867d0) at kernel/qcoreapplication.cpp:787
#38 0x00007f702750551f in sendEvent (event=0x1f867d0, receiver=0x2743400) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x17f1be0) at kernel/qcoreapplication.cpp:1428
#40 0x00007f702752ca73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007f7021be4a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f7021be5258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f7021be5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f702752ced6 in QEventDispatcherGlib::processEvents (this=0x17f36f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#46 0x00007f7025be407e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007f7027500cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007f7027500ef7 in QEventLoop::exec (this=0x7fff9981ecc0, flags=...) at kernel/qeventloop.cpp:201
#49 0x00007f7027505789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#50 0x000000000041bd67 in main (argc=5, argv=0x7fff9981efa8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 290145, bug 288692, bug 286903, bug 285580, bug 285299.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-01-11 13:58:09 UTC

*** This bug has been marked as a duplicate of bug 283728 ***