Bug 295946 - startup
Summary: startup
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-13 17:39 UTC by Kosek Libor
Modified: 2012-03-13 21:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kosek Libor 2012-03-13 17:39:07 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I dont know
?????????????????????????????????????????????

The crash can be reproduced every time.

-- Backtrace:
Application: Centrum softwaru Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d0930 (LWP 1786))]

Thread 2 (Thread 0xb42b5b70 (LWP 1792)):
#0  0x00d99fb6 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0x00d6c2c8 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x02e84785 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x02e84c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x002a4b37 in QEventDispatcherGlib::processEvents (this=0x8dd95b8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x002751dd in QEventLoop::processEvents (this=0xb42b52b0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00275421 in QEventLoop::exec (this=0xb42b52b0, flags=...) at kernel/qeventloop.cpp:201
#7  0x0017890b in QThread::exec (this=0x8f33628) at thread/qthread.cpp:498
#8  0x00255e2d in QInotifyFileSystemWatcherEngine::run (this=0x8f33628) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x0017b7b3 in QThreadPrivate::start (arg=0x8f33628) at thread/qthread_unix.cpp:331
#10 0x00940d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x00d5e46e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d0930 (LWP 1786)):
[KCrash Handler]
#7  0x001cfe11 in QtPrivate::QStringList_contains (that=0xbfb6e544, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfb6e544) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8ddc6c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8ddc6c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb6e764) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0027cb7d in metacall (argv=0xbfb6e764, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8ddc6c8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8ddc6c8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfb6e764) at kernel/qmetaobject.cpp:232
#13 0x0028ba6a in QMetaObject::activate (sender=0x8cbbaf8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8cbbaf8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8cbbaf8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb6e8a8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0027cb7d in metacall (argv=0xbfb6e8a8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8cbbaf8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8cbbaf8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfb6e8a8) at kernel/qmetaobject.cpp:232
#18 0x0028ba6a in QMetaObject::activate (sender=0x8ddc6c8, m=0x80950c0, local_signal_index=0, argv=0xbfb6e8a8) at kernel/qobject.cpp:3278
#19 0x004af7c5 in MuonMainWindow::backendReady (this=0x8ddc6c8, _t1=0x8e1a688) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x004af933 in MuonMainWindow::initObject (this=0x8ddc6c8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8ddc6c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8ddc6c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfb6e9d4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0027cb7d in metacall (argv=0xbfb6e9d4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8ddc6c8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8ddc6c8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfb6e9d4) at kernel/qmetaobject.cpp:232
#25 0x0028ba6a in QMetaObject::activate (sender=0x8e43890, m=0x3ac238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00293375 in QSingleShotTimer::timeout (this=0x8e43890) at .moc/release-shared/qtimer.moc:82
#27 0x0029342c in QSingleShotTimer::timerEvent (this=0x8e43890) at kernel/qtimer.cpp:308
#28 0x0028e994 in QObject::event (this=0x8e43890, e=0xbfb6edcc) at kernel/qobject.cpp:1181
#29 0x06900d84 in notify_helper (e=0xbfb6edcc, receiver=0x8e43890, this=0x8cce938) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8cce938, receiver=0x8e43890, e=0xbfb6edcc) at kernel/qapplication.cpp:4458
#31 0x06906133 in QApplication::notify (this=0xbfb6edcc, receiver=0x8e43890, e=0xbfb6edcc) at kernel/qapplication.cpp:3886
#32 0x0103e971 in KApplication::notify (this=0xbfb6f0e0, receiver=0x8e43890, event=0xbfb6edcc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0027619e in QCoreApplication::notifyInternal (this=0xbfb6f0e0, receiver=0x8e43890, event=0xbfb6edcc) at kernel/qcoreapplication.cpp:787
#34 0x002a6c10 in sendEvent (event=0xbfb6edcc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8ccd5bc) at kernel/qeventdispatcher_unix.cpp:603
#36 0x002a4122 in timerSourceDispatch (source=0x8ccd588) at kernel/qeventdispatcher_glib.cpp:184
#37 0x02e8425f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x02e84990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x02e84c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x002a4ada in QEventDispatcherGlib::processEvents (this=0x8cb0238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x069b8e7a in QGuiEventDispatcherGlib::processEvents (this=0x8cb0238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x002751dd in QEventLoop::processEvents (this=0xbfb6f044, flags=...) at kernel/qeventloop.cpp:149
#43 0x00275421 in QEventLoop::exec (this=0xbfb6f044, flags=...) at kernel/qeventloop.cpp:201
#44 0x0027a19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x068fe924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295939, bug 295919, bug 295895, bug 295886, bug 295885.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-13 21:57:44 UTC

*** This bug has been marked as a duplicate of bug 291262 ***