Bug 295895 - muon crashes after attempting chromium update
Summary: muon crashes after attempting chromium update
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-13 06:20 UTC by nagid_brown
Modified: 2012-03-13 06:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nagid_brown 2012-03-13 06:20:02 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I attempted to update my google chromium browser, it wasn't able to download the necessary packages for the update. Then I couldn't close the window, I had to close it via the system monitor.  Now muon won't open, but keeps telling me that I have an update available.  Also appearently my adobe flashplayer is out of date for chromium, so it's unusable

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f793a36aa5e in QtPrivate::QStringList_contains (that=0x7fff0704d2b0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff0704d2b0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x19bc3d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x19bc3d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0704d880) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f793a416eba in QMetaObject::activate (sender=0x19d5890, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x19d5890, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0704d9e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f793a416eba in QMetaObject::activate (sender=0x19bc3d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0704d9e0) at kernel/qobject.cpp:3278
#13 0x00007f793b28ce7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1947380) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f793b28cf8e in MuonMainWindow::initObject (this=0x19bc3d0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x19bc3d0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x19bc3d0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff0704dab0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f793a416eba in QMetaObject::activate (sender=0x1a24740, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f793a41ef7f in QSingleShotTimer::timerEvent (this=0x1a24740) at kernel/qtimer.cpp:308
#19 0x00007f793a41a789 in QObject::event (this=0x1a24740, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f7938a3d474 in notify_helper (e=0x7fff0704e020, receiver=0x1a24740, this=0x1881940) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1881940, receiver=0x1a24740, e=0x7fff0704e020) at kernel/qapplication.cpp:4458
#22 0x00007f7938a422e1 in QApplication::notify (this=0x7fff0704e320, receiver=0x1a24740, e=0x7fff0704e020) at kernel/qapplication.cpp:4365
#23 0x00007f7939c22466 in KApplication::notify (this=0x7fff0704e320, receiver=0x1a24740, event=0x7fff0704e020) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f793a403afc in QCoreApplication::notifyInternal (this=0x7fff0704e320, receiver=0x1a24740, event=0x7fff0704e020) at kernel/qcoreapplication.cpp:787
#25 0x00007f793a430d62 in sendEvent (event=0x7fff0704e020, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x18880d0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f793a42e514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f7934ae5a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f7934ae6258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f7934ae6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f793a42eed6 in QEventDispatcherGlib::processEvents (this=0x185c6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f7938ae510e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f793a402cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f793a402ef7 in QEventLoop::exec (this=0x7fff0704e2b0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f793a407789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff0704e598) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 294405.

Possible duplicates by query: bug 295886, bug 295885, bug 295882, bug 295855, bug 295833.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-13 06:27:17 UTC

*** This bug has been marked as a duplicate of bug 291262 ***