Bug 295833 - Muon software center segmentation fault
Summary: Muon software center segmentation fault
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-12 12:53 UTC by ste.petrucci
Modified: 2012-03-12 13:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ste.petrucci 2012-03-12 12:53:18 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
I just turned on the computer and run apt-get update apt-get upgrade then I called muon software center and the program had a "segmentation fault"

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f51dbeff780 (LWP 1905))]

Thread 2 (Thread 0x7f51c76a2700 (LWP 1906)):
#0  0x00007f51d8ad6473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f51d5349f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f51d534a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f51dac94f3e in QEventDispatcherGlib::processEvents (this=0xfca270, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f51dac68cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f51dac68ef7 in QEventLoop::exec (this=0x7f51c76a1dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f51dab8027f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f51dac4bcbf in QInotifyFileSystemWatcherEngine::run (this=0x11bb870) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f51dab82d05 in QThreadPrivate::start (arg=0x11bb870) at thread/qthread_unix.cpp:331
#9  0x00007f51d5e2befc in start_thread (arg=0x7f51c76a2700) at pthread_create.c:304
#10 0x00007f51d8ae259d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f51dbeff780 (LWP 1905)):
[KCrash Handler]
#6  0x00007f51dabd0a5e in QtPrivate::QStringList_contains (that=0x7fff60fe35a0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff60fe35a0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xfceed0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xfceed0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff60fe3b70) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f51dac7ceba in QMetaObject::activate (sender=0x11a2250, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x11a2250, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff60fe3cd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f51dac7ceba in QMetaObject::activate (sender=0xfceed0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff60fe3cd0) at kernel/qobject.cpp:3278
#13 0x00007f51dbaf2e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x10481e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f51dbaf2f8e in MuonMainWindow::initObject (this=0xfceed0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xfceed0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xfceed0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff60fe3da0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f51dac7ceba in QMetaObject::activate (sender=0x1059710, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f51dac84f7f in QSingleShotTimer::timerEvent (this=0x1059710) at kernel/qtimer.cpp:308
#19 0x00007f51dac80789 in QObject::event (this=0x1059710, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f51d92a3474 in notify_helper (e=0x7fff60fe4310, receiver=0x1059710, this=0xea04e0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xea04e0, receiver=0x1059710, e=0x7fff60fe4310) at kernel/qapplication.cpp:4458
#22 0x00007f51d92a82e1 in QApplication::notify (this=0x7fff60fe4610, receiver=0x1059710, e=0x7fff60fe4310) at kernel/qapplication.cpp:4365
#23 0x00007f51da488466 in KApplication::notify (this=0x7fff60fe4610, receiver=0x1059710, event=0x7fff60fe4310) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f51dac69afc in QCoreApplication::notifyInternal (this=0x7fff60fe4610, receiver=0x1059710, event=0x7fff60fe4310) at kernel/qcoreapplication.cpp:787
#25 0x00007f51dac96d62 in sendEvent (event=0x7fff60fe4310, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xe9cf00) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f51dac94514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f51d5349a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f51d534a258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f51d534a429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f51dac94ed6 in QEventDispatcherGlib::processEvents (this=0xe766f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f51d934b10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f51dac68cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f51dac68ef7 in QEventLoop::exec (this=0x7fff60fe45a0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f51dac6d789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff60fe4888) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295807, bug 295787, bug 295758, bug 295741, bug 295706.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-12 13:14:48 UTC

*** This bug has been marked as a duplicate of bug 291262 ***