Bug 295882 - НУ упала она, УПАЛА!!!MUON
Summary: НУ упала она, УПАЛА!!!MUON
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-12 23:26 UTC by andrew
Modified: 2012-03-13 00:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrew 2012-03-12 23:26:22 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Не понятно что делать вообще!

The crash can be reproduced every time.

-- Backtrace:
Application: Центр программ Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f0895c7a780 (LWP 2037))]

Thread 2 (Thread 0x7f0880f8a700 (LWP 2041)):
#0  __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f087c0009a8) at pthread_mutex_unlock.c:290
#2  0x00007f088f0b4f3f in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f088f0b5dfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f088f0b6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0894a00f3e in QEventDispatcherGlib::processEvents (this=0x7f087c0008b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f08949d4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f08949d4ef7 in QEventLoop::exec (this=0x7f0880f89dd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f08948ec27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007f08949b7cbf in QInotifyFileSystemWatcherEngine::run (this=0x19e8a30) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f08948eed05 in QThreadPrivate::start (arg=0x19e8a30) at thread/qthread_unix.cpp:331
#11 0x00007f088fb97efc in start_thread (arg=0x7f0880f8a700) at pthread_create.c:304
#12 0x00007f089284e59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f0895c7a780 (LWP 2037)):
[KCrash Handler]
#6  0x00007f089493ca5e in QtPrivate::QStringList_contains (that=0x7fffbb94f4d0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fffbb94f4d0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x199b0f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x199b0f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbb94faa0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f08949e8eba in QMetaObject::activate (sender=0x1997bb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x1997bb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbb94fc00) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f08949e8eba in QMetaObject::activate (sender=0x199b0f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffbb94fc00) at kernel/qobject.cpp:3278
#13 0x00007f089585ee7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1996230) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f089585ef8e in MuonMainWindow::initObject (this=0x199b0f0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x199b0f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x199b0f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fffbb94fcd0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f08949e8eba in QMetaObject::activate (sender=0x1a09340, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f08949f0f7f in QSingleShotTimer::timerEvent (this=0x1a09340) at kernel/qtimer.cpp:308
#19 0x00007f08949ec789 in QObject::event (this=0x1a09340, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f089300f474 in notify_helper (e=0x7fffbb950240, receiver=0x1a09340, this=0x181f5e0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x181f5e0, receiver=0x1a09340, e=0x7fffbb950240) at kernel/qapplication.cpp:4458
#22 0x00007f08930142e1 in QApplication::notify (this=0x7fffbb950540, receiver=0x1a09340, e=0x7fffbb950240) at kernel/qapplication.cpp:4365
#23 0x00007f08941f4466 in KApplication::notify (this=0x7fffbb950540, receiver=0x1a09340, event=0x7fffbb950240) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f08949d5afc in QCoreApplication::notifyInternal (this=0x7fffbb950540, receiver=0x1a09340, event=0x7fffbb950240) at kernel/qcoreapplication.cpp:787
#25 0x00007f0894a02d62 in sendEvent (event=0x7fffbb950240, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x181ad20) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f0894a00538 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#29 0x00007f088f0b5a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f088f0b6258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f088f0b6429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f0894a00ed6 in QEventDispatcherGlib::processEvents (this=0x17f76f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#33 0x00007f08930b710e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f08949d4cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f08949d4ef7 in QEventLoop::exec (this=0x7fffbb9504d0, flags=...) at kernel/qeventloop.cpp:201
#36 0x00007f08949d9789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#37 0x000000000041bd67 in main (argc=5, argv=0x7fffbb9507b8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295855, bug 295833, bug 295807, bug 295787, bug 295758.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-13 00:19:00 UTC

*** This bug has been marked as a duplicate of bug 291262 ***