Bug 295885 - crash on startup / plantage au démarrage
Summary: crash on startup / plantage au démarrage
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-13 00:56 UTC by etiennedecolomiers
Modified: 2012-03-13 02:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description etiennedecolomiers 2012-03-13 00:56:34 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
nothing / rien
just installed computer / ordinateur fraichement installé

The crash can be reproduced every time.

-- Backtrace:
Application: Centre de logiciels Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f33714c7780 (LWP 2136))]

Thread 2 (Thread 0x7f335caf9700 (LWP 2137)):
#0  0x00007f336e08e473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f336a901f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f336a902429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f337024cf3e in QEventDispatcherGlib::processEvents (this=0x15b0b00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f3370220cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3370220ef7 in QEventLoop::exec (this=0x7f335caf8dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f337013827f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f3370203cbf in QInotifyFileSystemWatcherEngine::run (this=0x1618130) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f337013ad05 in QThreadPrivate::start (arg=0x1618130) at thread/qthread_unix.cpp:331
#9  0x00007f336b3e3efc in start_thread (arg=0x7f335caf9700) at pthread_create.c:304
#10 0x00007f336e09a59d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f33714c7780 (LWP 2136)):
[KCrash Handler]
#6  0x00007f3370188a5e in QtPrivate::QStringList_contains (that=0x7ffff2ad9de0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7ffff2ad9de0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x15f2b50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x15f2b50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff2ada3b0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f3370234eba in QMetaObject::activate (sender=0x17b2bd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x17b2bd0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff2ada510) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f3370234eba in QMetaObject::activate (sender=0x15f2b50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff2ada510) at kernel/qobject.cpp:3278
#13 0x00007f33710aae7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1647fc0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f33710aaf8e in MuonMainWindow::initObject (this=0x15f2b50) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x15f2b50) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x15f2b50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff2ada5e0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f3370234eba in QMetaObject::activate (sender=0x1676d60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f337023cf7f in QSingleShotTimer::timerEvent (this=0x1676d60) at kernel/qtimer.cpp:308
#19 0x00007f3370238789 in QObject::event (this=0x1676d60, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f336e85b474 in notify_helper (e=0x7ffff2adab50, receiver=0x1676d60, this=0x1495500) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1495500, receiver=0x1676d60, e=0x7ffff2adab50) at kernel/qapplication.cpp:4458
#22 0x00007f336e8602e1 in QApplication::notify (this=0x7ffff2adae50, receiver=0x1676d60, e=0x7ffff2adab50) at kernel/qapplication.cpp:4365
#23 0x00007f336fa40466 in KApplication::notify (this=0x7ffff2adae50, receiver=0x1676d60, event=0x7ffff2adab50) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f3370221afc in QCoreApplication::notifyInternal (this=0x7ffff2adae50, receiver=0x1676d60, event=0x7ffff2adab50) at kernel/qcoreapplication.cpp:787
#25 0x00007f337024ed62 in sendEvent (event=0x7ffff2adab50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x14910d0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f337024c514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f336a901a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f336a902258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f336a902429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f337024ced6 in QEventDispatcherGlib::processEvents (this=0x146c6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f336e90310e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f3370220cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f3370220ef7 in QEventLoop::exec (this=0x7ffff2adade0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f3370225789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7ffff2adb0c8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295882, bug 295855, bug 295833, bug 295807, bug 295787.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-13 02:04:33 UTC

*** This bug has been marked as a duplicate of bug 291262 ***