Bug 294405 - Muon Installer Crashes
Summary: Muon Installer Crashes
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 06:25 UTC by hamblinm10
Modified: 2012-02-19 06:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hamblinm10 2012-02-19 06:25:06 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4) (Compiled from sources)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

Trying to open the updater to make sure that all installed programs were up to date. It then proceeded to crash multiple times.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4769930 (LWP 22675))]

Thread 2 (Thread 0xb0ab2b70 (LWP 22688)):
#0  0xb52b6d10 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb71927d5 in do_gettime (frac=0xb0ab2020, sec=0xb0ab2018) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb72654b6 in QTimerInfoList::updateCurrentTime (this=0x8a9cedc) at kernel/qeventdispatcher_unix.cpp:339
#4  0xb726580a in QTimerInfoList::timerWait (this=0x8a9cedc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0xb7264053 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb0ab212c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb72640ed in timerSourcePrepare (source=0x8a9cea8, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb51fc88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb51fd637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb51fdc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb7264b37 in QEventDispatcherGlib::processEvents (this=0x8aaabe0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0xb72351dd in QEventLoop::processEvents (this=0xb0ab22b0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb7235421 in QEventLoop::exec (this=0xb0ab22b0, flags=...) at kernel/qeventloop.cpp:201
#13 0xb713890b in QThread::exec (this=0x8aa8b98) at thread/qthread.cpp:498
#14 0xb7215e2d in QInotifyFileSystemWatcherEngine::run (this=0x8aa8b98) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb713b7b3 in QThreadPrivate::start (arg=0x8aa8b98) at thread/qthread_unix.cpp:331
#16 0xb52e3d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5d300ce in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb4769930 (LWP 22675)):
[KCrash Handler]
#7  0xb718fe11 in QtPrivate::QStringList_contains (that=0xbf9e4b14, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbf9e4b14) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8942fb0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8942fb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e4d34) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb723cb7d in metacall (argv=0xbf9e4d34, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8942fb0) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8942fb0, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbf9e4d34) at kernel/qmetaobject.cpp:232
#13 0xb724ba6a in QMetaObject::activate (sender=0x8851dd8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8851dd8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8851dd8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e4e78) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb723cb7d in metacall (argv=0xbf9e4e78, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8851dd8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8851dd8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbf9e4e78) at kernel/qmetaobject.cpp:232
#18 0xb724ba6a in QMetaObject::activate (sender=0x8942fb0, m=0x80950c0, local_signal_index=0, argv=0xbf9e4e78) at kernel/qobject.cpp:3278
#19 0xb76ac7c5 in MuonMainWindow::backendReady (this=0x8942fb0, _t1=0x89ac348) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb76ac933 in MuonMainWindow::initObject (this=0x8942fb0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8942fb0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8942fb0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbf9e4fa4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb723cb7d in metacall (argv=0xbf9e4fa4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8942fb0) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8942fb0, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbf9e4fa4) at kernel/qmetaobject.cpp:232
#25 0xb724ba6a in QMetaObject::activate (sender=0x89a9fa8, m=0xb736c238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb7253375 in QSingleShotTimer::timeout (this=0x89a9fa8) at .moc/release-shared/qtimer.moc:82
#27 0xb725342c in QSingleShotTimer::timerEvent (this=0x89a9fa8) at kernel/qtimer.cpp:308
#28 0xb724e994 in QObject::event (this=0x89a9fa8, e=0xbf9e539c) at kernel/qobject.cpp:1181
#29 0xb601cd84 in notify_helper (e=0xbf9e539c, receiver=0x89a9fa8, this=0x885b430) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x885b430, receiver=0x89a9fa8, e=0xbf9e539c) at kernel/qapplication.cpp:4458
#31 0xb6022133 in QApplication::notify (this=0xbf9e539c, receiver=0x89a9fa8, e=0xbf9e539c) at kernel/qapplication.cpp:3886
#32 0xb6e3b971 in KApplication::notify (this=0xbf9e56b0, receiver=0x89a9fa8, event=0xbf9e539c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb723619e in QCoreApplication::notifyInternal (this=0xbf9e56b0, receiver=0x89a9fa8, event=0xbf9e539c) at kernel/qcoreapplication.cpp:787
#34 0xb7266c10 in sendEvent (event=0xbf9e539c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8863334) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb7264122 in timerSourceDispatch (source=0x8863300) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb51fd25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb51fd990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb51fdc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb7264ada in QEventDispatcherGlib::processEvents (this=0x883e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb60d4e7a in QGuiEventDispatcherGlib::processEvents (this=0x883e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb72351dd in QEventLoop::processEvents (this=0xbf9e5614, flags=...) at kernel/qeventloop.cpp:149
#43 0xb7235421 in QEventLoop::exec (this=0xbf9e5614, flags=...) at kernel/qeventloop.cpp:201
#44 0xb723a19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb601a924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 294404, bug 294395, bug 294394, bug 294363, bug 294343.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-19 06:29:28 UTC

*** This bug has been marked as a duplicate of bug 291262 ***