Bug 295855 - muon-installer PID: 2071 Signál: Segmentation fault (11)
Summary: muon-installer PID: 2071 Signál: Segmentation fault (11)
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-12 17:26 UTC by konstro
Modified: 2012-03-12 18:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description konstro 2012-03-12 17:26:42 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
Starting software center

The crash can be reproduced every time.

-- Backtrace:
Application: Centrum softwaru Muon (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f253f859780 (LWP 1732))]

Thread 2 (Thread 0x7f252aea7700 (LWP 1733)):
#0  0x00007f253c42c473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2538c9ff68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2538ca0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f253e5eaf3e in QEventDispatcherGlib::processEvents (this=0x1e74c30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f253e5becf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f253e5beef7 in QEventLoop::exec (this=0x7f252aea6dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f253e4d627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f253e5a1cbf in QInotifyFileSystemWatcherEngine::run (this=0x1fa2060) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f253e4d8d05 in QThreadPrivate::start (arg=0x1fa2060) at thread/qthread_unix.cpp:331
#9  0x00007f2539781efc in start_thread (arg=0x7f252aea7700) at pthread_create.c:304
#10 0x00007f253c43859d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f253f859780 (LWP 1732)):
[KCrash Handler]
#6  0x00007f253e526a5e in QtPrivate::QStringList_contains (that=0x7fff890821a0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff890821a0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x1f220e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x1f220e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff89082770) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007f253e5d2eba in QMetaObject::activate (sender=0x20e0ac0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x20e0ac0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff890828d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007f253e5d2eba in QMetaObject::activate (sender=0x1f220e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff890828d0) at kernel/qobject.cpp:3278
#13 0x00007f253f448e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x1f84800) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007f253f448f8e in MuonMainWindow::initObject (this=0x1f220e0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x1f220e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x1f220e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff890829a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007f253e5d2eba in QMetaObject::activate (sender=0x1f8c490, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007f253e5daf7f in QSingleShotTimer::timerEvent (this=0x1f8c490) at kernel/qtimer.cpp:308
#19 0x00007f253e5d6789 in QObject::event (this=0x1f8c490, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007f253cbf9474 in notify_helper (e=0x7fff89082f10, receiver=0x1f8c490, this=0x1dc4840) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x1dc4840, receiver=0x1f8c490, e=0x7fff89082f10) at kernel/qapplication.cpp:4458
#22 0x00007f253cbfe2e1 in QApplication::notify (this=0x7fff89083210, receiver=0x1f8c490, e=0x7fff89082f10) at kernel/qapplication.cpp:4365
#23 0x00007f253ddde466 in KApplication::notify (this=0x7fff89083210, receiver=0x1f8c490, event=0x7fff89082f10) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f253e5bfafc in QCoreApplication::notifyInternal (this=0x7fff89083210, receiver=0x1f8c490, event=0x7fff89082f10) at kernel/qcoreapplication.cpp:787
#25 0x00007f253e5ecd62 in sendEvent (event=0x7fff89082f10, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x1dc04f0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007f253e5ea514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007f2538c9fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f2538ca0258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f2538ca0429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f253e5eaed6 in QEventDispatcherGlib::processEvents (this=0x1d9b6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f253cca110e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007f253e5becf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007f253e5beef7 in QEventLoop::exec (this=0x7fff890831a0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007f253e5c3789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff89083488) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295833, bug 295807, bug 295787, bug 295758, bug 295741.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-12 18:19:04 UTC

*** This bug has been marked as a duplicate of bug 291262 ***