Bug 295787 - Muon did not finish first update and crashes now everytime when I start it.
Summary: Muon did not finish first update and crashes now everytime when I start it.
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-11 19:32 UTC by tuxluchs
Modified: 2012-03-11 22:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.71 KB, text/plain)
2012-03-11 22:24 UTC, Jesse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tuxluchs 2012-03-11 19:32:48 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Started Muon - better - I tried to start it.

Synaptik ist working well.
Apper works well too.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd40c331780 (LWP 2831))]

Thread 2 (Thread 0x7fd3f77a8700 (LWP 2832)):
#0  0x00007fd408f07473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd40577af68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd40577b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd40b0c5f3e in QEventDispatcherGlib::processEvents (this=0xe7ae50, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fd40b099cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd40b099ef7 in QEventLoop::exec (this=0x7fd3f77a7dd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fd40afb127f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007fd40b07ccbf in QInotifyFileSystemWatcherEngine::run (this=0xe848f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fd40afb3d05 in QThreadPrivate::start (arg=0xe848f0) at thread/qthread_unix.cpp:331
#9  0x00007fd40625cefc in start_thread (arg=0x7fd3f77a8700) at pthread_create.c:304
#10 0x00007fd408f1359d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd40c331780 (LWP 2831)):
[KCrash Handler]
#6  0x00007fd40b001a5e in QtPrivate::QStringList_contains (that=0x7fff04666dd0, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff04666dd0) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0xe50000) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0xe50000, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff046673a0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007fd40b0adeba in QMetaObject::activate (sender=0xee0b70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0xee0b70, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff04667500) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007fd40b0adeba in QMetaObject::activate (sender=0xe50000, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff04667500) at kernel/qobject.cpp:3278
#13 0x00007fd40bf23e7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0xeffa90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007fd40bf23f8e in MuonMainWindow::initObject (this=0xe50000) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0xe50000) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0xe50000, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff046675d0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007fd40b0adeba in QMetaObject::activate (sender=0xef48a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007fd40b0b5f7f in QSingleShotTimer::timerEvent (this=0xef48a0) at kernel/qtimer.cpp:308
#19 0x00007fd40b0b1789 in QObject::event (this=0xef48a0, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007fd4096d4474 in notify_helper (e=0x7fff04667b40, receiver=0xef48a0, this=0xccc870) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0xccc870, receiver=0xef48a0, e=0x7fff04667b40) at kernel/qapplication.cpp:4458
#22 0x00007fd4096d92e1 in QApplication::notify (this=0x7fff04667e40, receiver=0xef48a0, e=0x7fff04667b40) at kernel/qapplication.cpp:4365
#23 0x00007fd40a8b9466 in KApplication::notify (this=0x7fff04667e40, receiver=0xef48a0, event=0x7fff04667b40) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fd40b09aafc in QCoreApplication::notifyInternal (this=0x7fff04667e40, receiver=0xef48a0, event=0x7fff04667b40) at kernel/qcoreapplication.cpp:787
#25 0x00007fd40b0c7d62 in sendEvent (event=0x7fff04667b40, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0xcc4b80) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007fd40b0c5514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007fd40577aa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007fd40577b258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fd40577b429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fd40b0c5ed6 in QEventDispatcherGlib::processEvents (this=0xc9f6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007fd40977c10e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007fd40b099cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007fd40b099ef7 in QEventLoop::exec (this=0x7fff04667dd0, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007fd40b09e789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=5, argv=0x7fff046680b8) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295758, bug 295741, bug 295706, bug 295692, bug 295682.

Reported using DrKonqi
Comment 1 Jesse 2012-03-11 22:24:56 UTC
Created attachment 69518 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Muon Softrware Center crashes every time I try to use it.  Kubuntu is not very useful without it.

-- Backtrace (Reduced):
#7  0x00494e11 in QtPrivate::QStringList_contains (that=0xbfa2acc4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfa2acc4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9fc1418) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9fc1418, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfa2aee4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00541b7d in metacall (argv=0xbfa2aee4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9fc1418) at kernel/qmetaobject.cpp:237
Comment 2 Jekyll Wu 2012-03-11 22:50:49 UTC

*** This bug has been marked as a duplicate of bug 291262 ***