Bug 295807 - Crashes when it starts
Summary: Crashes when it starts
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-11 22:36 UTC by HerrZufall
Modified: 2012-04-16 22:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (6.13 KB, text/plain)
2012-04-16 22:27 UTC, jeauseoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description HerrZufall 2012-03-11 22:36:40 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I started it.
There was no update before.
I use it as it comes from the kubuntu - 11.10 image.

It crashes everytime when I start the programm.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon-Programmverwaltung (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77d6930 (LWP 3487))]

Thread 2 (Thread 0xb55cfb70 (LWP 3491)):
#0  0x00adf416 in __kernel_vsyscall ()
#1  0x00ba47ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x05bb634b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x05ba7896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x05ba7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x00912b37 in QEventDispatcherGlib::processEvents (this=0x9da28f8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x008e31dd in QEventLoop::processEvents (this=0xb55cf2b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x008e3421 in QEventLoop::exec (this=0xb55cf2b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x007e690b in QThread::exec (this=0x9c92c68) at thread/qthread.cpp:498
#9  0x008c3e2d in QInotifyFileSystemWatcherEngine::run (this=0x9c92c68) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x007e97b3 in QThreadPrivate::start (arg=0x9c92c68) at thread/qthread_unix.cpp:331
#11 0x00a90d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00bb346e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77d6930 (LWP 3487)):
[KCrash Handler]
#7  0x0083de11 in QtPrivate::QStringList_contains (that=0xbfe81944, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe81944) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x9c56808) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x9c56808, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe81b64) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x008eab7d in metacall (argv=0xbfe81b64, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x9c56808) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x9c56808, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe81b64) at kernel/qmetaobject.cpp:232
#13 0x008f9a6a in QMetaObject::activate (sender=0x9ca5d30, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x9ca5d30) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x9ca5d30, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe81ca8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x008eab7d in metacall (argv=0xbfe81ca8, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x9ca5d30) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x9ca5d30, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe81ca8) at kernel/qmetaobject.cpp:232
#18 0x008f9a6a in QMetaObject::activate (sender=0x9c56808, m=0x80950c0, local_signal_index=0, argv=0xbfe81ca8) at kernel/qobject.cpp:3278
#19 0x002737c5 in MuonMainWindow::backendReady (this=0x9c56808, _t1=0x9cb4480) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00273933 in MuonMainWindow::initObject (this=0x9c56808) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x9c56808) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x9c56808, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe81dd4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x008eab7d in metacall (argv=0xbfe81dd4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x9c56808) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x9c56808, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe81dd4) at kernel/qmetaobject.cpp:232
#25 0x008f9a6a in QMetaObject::activate (sender=0x9cb4588, m=0xa1a238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00901375 in QSingleShotTimer::timeout (this=0x9cb4588) at .moc/release-shared/qtimer.moc:82
#27 0x0090142c in QSingleShotTimer::timerEvent (this=0x9cb4588) at kernel/qtimer.cpp:308
#28 0x008fc994 in QObject::event (this=0x9cb4588, e=0xbfe821cc) at kernel/qobject.cpp:1181
#29 0x08720d84 in notify_helper (e=0xbfe821cc, receiver=0x9cb4588, this=0x9b4be68) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x9b4be68, receiver=0x9cb4588, e=0xbfe821cc) at kernel/qapplication.cpp:4458
#31 0x08726133 in QApplication::notify (this=0xbfe821cc, receiver=0x9cb4588, e=0xbfe821cc) at kernel/qapplication.cpp:3886
#32 0x00ed2971 in KApplication::notify (this=0xbfe824e0, receiver=0x9cb4588, event=0xbfe821cc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x008e419e in QCoreApplication::notifyInternal (this=0xbfe824e0, receiver=0x9cb4588, event=0xbfe821cc) at kernel/qcoreapplication.cpp:787
#34 0x00914c10 in sendEvent (event=0xbfe821cc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x9b4e474) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00912122 in timerSourceDispatch (source=0x9b4e440) at kernel/qeventdispatcher_glib.cpp:184
#37 0x05ba725f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x05ba7990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x05ba7c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00912ada in QEventDispatcherGlib::processEvents (this=0x9b2e238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x087d8e7a in QGuiEventDispatcherGlib::processEvents (this=0x9b2e238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x008e31dd in QEventLoop::processEvents (this=0xbfe82444, flags=...) at kernel/qeventloop.cpp:149
#43 0x008e3421 in QEventLoop::exec (this=0xbfe82444, flags=...) at kernel/qeventloop.cpp:201
#44 0x008e819d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x0871e924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295787, bug 295758, bug 295741, bug 295706, bug 295692.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-11 22:50:25 UTC

*** This bug has been marked as a duplicate of bug 291262 ***
Comment 2 jeauseoff 2012-04-16 22:27:35 UTC
Created attachment 70442 [details]
New crash information added by DrKonqi

muon-installer (1.2.1 "Caustic Carrionite") on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

Just installed Kubuntu 11.10 and wanted to go grab some software.  Muon crashed immediately on the 1st attempt to start the program.  Repeated 'Reload' button presses had no effect.

-- Backtrace (Reduced):
#6  0x00007f8f79c28a5e in QtPrivate::QStringList_contains (that=0x7fff4d823810, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff4d823810) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x23e62e0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x23e62e0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4d823de0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
[...]
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x2468130, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff4d823f40) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109