Bug 295758 - muon software centre crashing
Summary: muon software centre crashing
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-11 12:22 UTC by gerry
Modified: 2012-03-11 13:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gerry 2012-03-11 12:22:15 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: booted the laptop to power it up. went to open muon software centre to find new applications and the program crashed each time i openes it

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[KCrash Handler]
#7  0x003c3e11 in QtPrivate::QStringList_contains (that=0xbfd6c334, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd6c334) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x883df28) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x883df28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd6c554) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x00470b7d in metacall (argv=0xbfd6c554, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x883df28) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x883df28, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd6c554) at kernel/qmetaobject.cpp:232
#13 0x0047fa6a in QMetaObject::activate (sender=0x8886798, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x8886798) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x8886798, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd6c698) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x00470b7d in metacall (argv=0xbfd6c698, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x8886798) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x8886798, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd6c698) at kernel/qmetaobject.cpp:232
#18 0x0047fa6a in QMetaObject::activate (sender=0x883df28, m=0x80950c0, local_signal_index=0, argv=0xbfd6c698) at kernel/qobject.cpp:3278
#19 0x001367c5 in MuonMainWindow::backendReady (this=0x883df28, _t1=0x88737c0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x00136933 in MuonMainWindow::initObject (this=0x883df28) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x883df28) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x883df28, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd6c7c4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x00470b7d in metacall (argv=0xbfd6c7c4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x883df28) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x883df28, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd6c7c4) at kernel/qmetaobject.cpp:232
#25 0x0047fa6a in QMetaObject::activate (sender=0x887da90, m=0x5a0238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x00487375 in QSingleShotTimer::timeout (this=0x887da90) at .moc/release-shared/qtimer.moc:82
#27 0x0048742c in QSingleShotTimer::timerEvent (this=0x887da90) at kernel/qtimer.cpp:308
#28 0x00482994 in QObject::event (this=0x887da90, e=0xbfd6cbbc) at kernel/qobject.cpp:1181
#29 0x06009d84 in notify_helper (e=0xbfd6cbbc, receiver=0x887da90, this=0x87b35b8) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x87b35b8, receiver=0x887da90, e=0xbfd6cbbc) at kernel/qapplication.cpp:4458
#31 0x0600f133 in QApplication::notify (this=0xbfd6cbbc, receiver=0x887da90, e=0xbfd6cbbc) at kernel/qapplication.cpp:3886
#32 0x0112f971 in KApplication::notify (this=0xbfd6ced0, receiver=0x887da90, event=0xbfd6cbbc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0046a19e in QCoreApplication::notifyInternal (this=0xbfd6ced0, receiver=0x887da90, event=0xbfd6cbbc) at kernel/qcoreapplication.cpp:787
#34 0x0049ac10 in sendEvent (event=0xbfd6cbbc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x87b6634) at kernel/qeventdispatcher_unix.cpp:603
#36 0x00498122 in timerSourceDispatch (source=0x87b6600) at kernel/qeventdispatcher_glib.cpp:184
#37 0x016ef25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x016ef990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x016efc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x00498ada in QEventDispatcherGlib::processEvents (this=0x8796250, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x060c1e7a in QGuiEventDispatcherGlib::processEvents (this=0x8796250, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x004691dd in QEventLoop::processEvents (this=0xbfd6ce34, flags=...) at kernel/qeventloop.cpp:149
#43 0x00469421 in QEventLoop::exec (this=0xbfd6ce34, flags=...) at kernel/qeventloop.cpp:201
#44 0x0046e19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x06007924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295741, bug 295706, bug 295692, bug 295682, bug 295215.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-11 13:12:49 UTC

*** This bug has been marked as a duplicate of bug 291262 ***