Bug 295741 - Muon doesn't closes down
Summary: Muon doesn't closes down
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-11 09:34 UTC by Carl
Modified: 2012-03-11 09:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carl 2012-03-11 09:34:53 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic-pae i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
Burning an ISO and copying files to a USB stick.

- Unusual behavior I noticed:
Muon started, then shut down.  This has happened since a clean install of Kubuntu 11.10	

- Custom settings of the application:
None at all - fresh out of the box.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Centre (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb494f930 (LWP 1956))]

Thread 2 (Thread 0xb2487b70 (LWP 1960)):
#0  0xb78da424 in __kernel_vsyscall ()
#1  0xb5f077ae in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb53f134b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb53e2896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb53e2c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb744bb37 in QEventDispatcherGlib::processEvents (this=0x9409328, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb741c1dd in QEventLoop::processEvents (this=0xb24872b0, flags=...) at kernel/qeventloop.cpp:149
#7  0xb741c421 in QEventLoop::exec (this=0xb24872b0, flags=...) at kernel/qeventloop.cpp:201
#8  0xb731f90b in QThread::exec (this=0x934f848) at thread/qthread.cpp:498
#9  0xb73fce2d in QInotifyFileSystemWatcherEngine::run (this=0x934f848) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb73227b3 in QThreadPrivate::start (arg=0x934f848) at thread/qthread_unix.cpp:331
#11 0xb54c8d31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb5f1646e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb494f930 (LWP 1956)):
[KCrash Handler]
#7  0xb7376e11 in QtPrivate::QStringList_contains (that=0xbfe3c934, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfe3c934) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x92b41c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x92b41c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3cb54) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0xb7423b7d in metacall (argv=0xbfe3cb54, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x92b41c8) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x92b41c8, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfe3cb54) at kernel/qmetaobject.cpp:232
#13 0xb7432a6a in QMetaObject::activate (sender=0x93006c8, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x93006c8) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x93006c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3cc98) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0xb7423b7d in metacall (argv=0xbfe3cc98, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x93006c8) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x93006c8, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfe3cc98) at kernel/qmetaobject.cpp:232
#18 0xb7432a6a in QMetaObject::activate (sender=0x92b41c8, m=0x80950c0, local_signal_index=0, argv=0xbfe3cc98) at kernel/qobject.cpp:3278
#19 0xb78937c5 in MuonMainWindow::backendReady (this=0x92b41c8, _t1=0x9313750) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0xb7893933 in MuonMainWindow::initObject (this=0x92b41c8) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x92b41c8) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x92b41c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfe3cdc4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0xb7423b7d in metacall (argv=0xbfe3cdc4, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x92b41c8) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x92b41c8, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfe3cdc4) at kernel/qmetaobject.cpp:232
#25 0xb7432a6a in QMetaObject::activate (sender=0x931b5c8, m=0xb7553238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0xb743a375 in QSingleShotTimer::timeout (this=0x931b5c8) at .moc/release-shared/qtimer.moc:82
#27 0xb743a42c in QSingleShotTimer::timerEvent (this=0x931b5c8) at kernel/qtimer.cpp:308
#28 0xb7435994 in QObject::event (this=0x931b5c8, e=0xbfe3d1bc) at kernel/qobject.cpp:1181
#29 0xb6203d84 in notify_helper (e=0xbfe3d1bc, receiver=0x931b5c8, this=0x91c0588) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x91c0588, receiver=0x931b5c8, e=0xbfe3d1bc) at kernel/qapplication.cpp:4458
#31 0xb6209133 in QApplication::notify (this=0xbfe3d1bc, receiver=0x931b5c8, e=0xbfe3d1bc) at kernel/qapplication.cpp:3886
#32 0xb7022971 in KApplication::notify (this=0xbfe3d4d0, receiver=0x931b5c8, event=0xbfe3d1bc) at ../../kdeui/kernel/kapplication.cpp:311
#33 0xb741d19e in QCoreApplication::notifyInternal (this=0xbfe3d4d0, receiver=0x931b5c8, event=0xbfe3d1bc) at kernel/qcoreapplication.cpp:787
#34 0xb744dc10 in sendEvent (event=0xbfe3d1bc, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x91c0f9c) at kernel/qeventdispatcher_unix.cpp:603
#36 0xb744b122 in timerSourceDispatch (source=0x91c0f68) at kernel/qeventdispatcher_glib.cpp:184
#37 0xb53e225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb53e2990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb53e2c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb744bada in QEventDispatcherGlib::processEvents (this=0x91a3220, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0xb62bbe7a in QGuiEventDispatcherGlib::processEvents (this=0x91a3220, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb741c1dd in QEventLoop::processEvents (this=0xbfe3d434, flags=...) at kernel/qeventloop.cpp:149
#43 0xb741c421 in QEventLoop::exec (this=0xbfe3d434, flags=...) at kernel/qeventloop.cpp:201
#44 0xb742119d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0xb6201924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295706, bug 295692, bug 295682, bug 295215, bug 295188.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-11 09:42:12 UTC

*** This bug has been marked as a duplicate of bug 291262 ***