Bug 295706 - Muon sw center crashed during launch
Summary: Muon sw center crashed during launch
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-10 19:03 UTC by Giuseppe Mameli
Modified: 2012-03-10 23:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Giuseppe Mameli 2012-03-10 19:03:12 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed: I did a click on K\Application\System\Muon Software Center. Muon sw center crashed soon without show any form

The crash can be reproduced every time.

-- Backtrace:
Application: Muon Software Center (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ffc51048780 (LWP 2547))]

Thread 2 (Thread 0x7ffc3c4fb700 (LWP 2551)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007ffc3c4faaf0 in ?? ()
#2  0x00007fff3c1ff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0x7ffc51048780 (LWP 2547)):
[KCrash Handler]
#6  0x00007ffc4fd1aa5e in QtPrivate::QStringList_contains (that=0x7fff3c15a290, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0x000000000042416b in contains (cs=Qt::CaseSensitive, str=..., this=0x7fff3c15a290) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  ApplicationWindow::populateViews (this=0x23282f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#9  0x000000000042771c in ApplicationWindow::qt_metacall (this=0x23282f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3c15a860) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:113
#10 0x00007ffc4fdc6eba in QMetaObject::activate (sender=0x23a4970, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#11 0x000000000041c31c in ApplicationBackend::qt_metacall (this=0x23a4970, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3c15a9c0) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#12 0x00007ffc4fdc6eba in QMetaObject::activate (sender=0x23282f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff3c15a9c0) at kernel/qobject.cpp:3278
#13 0x00007ffc50c3ce7f in MuonMainWindow::backendReady (this=<optimized out>, _t1=0x233c120) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/libmuon/MuonMainWindow.moc:168
#14 0x00007ffc50c3cf8e in MuonMainWindow::initObject (this=0x23282f0) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#15 0x0000000000422fa0 in ApplicationWindow::initObject (this=0x23282f0) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#16 0x0000000000427619 in ApplicationWindow::qt_metacall (this=0x23282f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff3c15aa90) at /build/buildd/muon-1.2.1/obj-x86_64-linux-gnu/installer/ApplicationWindow.moc:104
#17 0x00007ffc4fdc6eba in QMetaObject::activate (sender=0x23a5100, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3278
#18 0x00007ffc4fdcef7f in QSingleShotTimer::timerEvent (this=0x23a5100) at kernel/qtimer.cpp:308
#19 0x00007ffc4fdca789 in QObject::event (this=0x23a5100, e=<optimized out>) at kernel/qobject.cpp:1181
#20 0x00007ffc4e3ed474 in notify_helper (e=0x7fff3c15b000, receiver=0x23a5100, this=0x21a7cf0) at kernel/qapplication.cpp:4486
#21 QApplicationPrivate::notify_helper (this=0x21a7cf0, receiver=0x23a5100, e=0x7fff3c15b000) at kernel/qapplication.cpp:4458
#22 0x00007ffc4e3f22e1 in QApplication::notify (this=0x7fff3c15b300, receiver=0x23a5100, e=0x7fff3c15b000) at kernel/qapplication.cpp:4365
#23 0x00007ffc4f5d2466 in KApplication::notify (this=0x7fff3c15b300, receiver=0x23a5100, event=0x7fff3c15b000) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007ffc4fdb3afc in QCoreApplication::notifyInternal (this=0x7fff3c15b300, receiver=0x23a5100, event=0x7fff3c15b000) at kernel/qcoreapplication.cpp:787
#25 0x00007ffc4fde0d62 in sendEvent (event=0x7fff3c15b000, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QTimerInfoList::activateTimers (this=0x21a21e0) at kernel/qeventdispatcher_unix.cpp:603
#27 0x00007ffc4fdde514 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#28 0x00007ffc4a493a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007ffc4a494258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007ffc4a494429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007ffc4fddeed6 in QEventDispatcherGlib::processEvents (this=0x217a6f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007ffc4e49510e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#33 0x00007ffc4fdb2cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#34 0x00007ffc4fdb2ef7 in QEventLoop::exec (this=0x7fff3c15b290, flags=...) at kernel/qeventloop.cpp:201
#35 0x00007ffc4fdb7789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#36 0x000000000041bd67 in main (argc=1, argv=0x7fff3c15b578) at /build/buildd/muon-1.2.1/installer/main.cpp:61

This bug may be a duplicate of or related to bug 295692.

Possible duplicates by query: bug 295692, bug 295682, bug 295215, bug 295188, bug 295179.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-10 23:47:20 UTC

*** This bug has been marked as a duplicate of bug 291262 ***