Bug 295692 - Crash
Summary: Crash
Status: RESOLVED DUPLICATE of bug 291262
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-10 17:10 UTC by Patrick
Modified: 2012-03-11 00:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick 2012-03-10 17:10:46 UTC
Application: muon-installer (1.2.1 "Caustic Carrionite")
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic i686
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
listening to music in Amarok but the crash always happens even if i don't have some programms open.

The crash can be reproduced every time.

-- Backtrace:
Application: Muon softwarecentrum (muon-installer), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b1710 (LWP 1902))]

Thread 2 (Thread 0xb5926b70 (LWP 1906)):
#0  0x00c524c2 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0x00c357c0 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x047a134b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x04792896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x04792c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x006b7b37 in QEventDispatcherGlib::processEvents (this=0x90038d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x006881dd in QEventLoop::processEvents (this=0xb59262b0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00688421 in QEventLoop::exec (this=0xb59262b0, flags=...) at kernel/qeventloop.cpp:201
#8  0x0058b90b in QThread::exec (this=0x9031f00) at thread/qthread.cpp:498
#9  0x00668e2d in QInotifyFileSystemWatcherEngine::run (this=0x9031f00) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0058e7b3 in QThreadPrivate::start (arg=0x9031f00) at thread/qthread_unix.cpp:331
#11 0x0093cd31 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00c4446e in clone () from /lib/i386-linux-gnu/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb77b1710 (LWP 1902)):
[KCrash Handler]
#7  0x005e2e11 in QtPrivate::QStringList_contains (that=0xbfd840d4, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#8  0x08066812 in contains (cs=Qt::CaseSensitive, str=..., this=0xbfd840d4) at /usr/include/qt4/QtCore/qstringlist.h:171
#9  ApplicationWindow::populateViews (this=0x8ff7e80) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:229
#10 0x0806a194 in ApplicationWindow::qt_metacall (this=0x8ff7e80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd842f4) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:113
#11 0x0068fb7d in metacall (argv=0xbfd842f4, idx=86, cl=QMetaObject::InvokeMetaMethod, object=0x8ff7e80) at kernel/qmetaobject.cpp:237
#12 QMetaObject::metacall (object=0x8ff7e80, cl=QMetaObject::InvokeMetaMethod, idx=86, argv=0xbfd842f4) at kernel/qmetaobject.cpp:232
#13 0x0069ea6a in QMetaObject::activate (sender=0x90537a0, m=0x8085040, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#14 0x0805de57 in ApplicationBackend::appBackendReady (this=0x90537a0) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:127
#15 0x0805e1d5 in ApplicationBackend::qt_metacall (this=0x90537a0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd84438) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/moc_ApplicationBackend.cpp:109
#16 0x0068fb7d in metacall (argv=0xbfd84438, idx=12, cl=QMetaObject::InvokeMetaMethod, object=0x90537a0) at kernel/qmetaobject.cpp:237
#17 QMetaObject::metacall (object=0x90537a0, cl=QMetaObject::InvokeMetaMethod, idx=12, argv=0xbfd84438) at kernel/qmetaobject.cpp:232
#18 0x0069ea6a in QMetaObject::activate (sender=0x8ff7e80, m=0x80950c0, local_signal_index=0, argv=0xbfd84438) at kernel/qobject.cpp:3278
#19 0x004ef7c5 in MuonMainWindow::backendReady (this=0x8ff7e80, _t1=0x903e090) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/libmuon/MuonMainWindow.moc:168
#20 0x004ef933 in MuonMainWindow::initObject (this=0x8ff7e80) at /build/buildd/muon-1.2.1/libmuon/MuonMainWindow.cpp:79
#21 0x080654fc in ApplicationWindow::initObject (this=0x8ff7e80) at /build/buildd/muon-1.2.1/installer/ApplicationWindow.cpp:116
#22 0x0806a09f in ApplicationWindow::qt_metacall (this=0x8ff7e80, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd84564) at /build/buildd/muon-1.2.1/obj-i686-linux-gnu/installer/ApplicationWindow.moc:104
#23 0x0068fb7d in metacall (argv=0xbfd84564, idx=77, cl=QMetaObject::InvokeMetaMethod, object=0x8ff7e80) at kernel/qmetaobject.cpp:237
#24 QMetaObject::metacall (object=0x8ff7e80, cl=QMetaObject::InvokeMetaMethod, idx=77, argv=0xbfd84564) at kernel/qmetaobject.cpp:232
#25 0x0069ea6a in QMetaObject::activate (sender=0x9044ed0, m=0x7bf238, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3278
#26 0x006a6375 in QSingleShotTimer::timeout (this=0x9044ed0) at .moc/release-shared/qtimer.moc:82
#27 0x006a642c in QSingleShotTimer::timerEvent (this=0x9044ed0) at kernel/qtimer.cpp:308
#28 0x006a1994 in QObject::event (this=0x9044ed0, e=0xbfd8495c) at kernel/qobject.cpp:1181
#29 0x071d9d84 in notify_helper (e=0xbfd8495c, receiver=0x9044ed0, this=0x8ef3e18) at kernel/qapplication.cpp:4486
#30 QApplicationPrivate::notify_helper (this=0x8ef3e18, receiver=0x9044ed0, e=0xbfd8495c) at kernel/qapplication.cpp:4458
#31 0x071df133 in QApplication::notify (this=0xbfd8495c, receiver=0x9044ed0, e=0xbfd8495c) at kernel/qapplication.cpp:3886
#32 0x00f7e971 in KApplication::notify (this=0xbfd84c70, receiver=0x9044ed0, event=0xbfd8495c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0068919e in QCoreApplication::notifyInternal (this=0xbfd84c70, receiver=0x9044ed0, event=0xbfd8495c) at kernel/qcoreapplication.cpp:787
#34 0x006b9c10 in sendEvent (event=0xbfd8495c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8ef7074) at kernel/qeventdispatcher_unix.cpp:603
#36 0x006b7122 in timerSourceDispatch (source=0x8ef7040) at kernel/qeventdispatcher_glib.cpp:184
#37 0x0479225f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0x04792990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x04792c2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x006b7ada in QEventDispatcherGlib::processEvents (this=0x8ed2238, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#41 0x07291e7a in QGuiEventDispatcherGlib::processEvents (this=0x8ed2238, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x006881dd in QEventLoop::processEvents (this=0xbfd84bd4, flags=...) at kernel/qeventloop.cpp:149
#43 0x00688421 in QEventLoop::exec (this=0xbfd84bd4, flags=...) at kernel/qeventloop.cpp:201
#44 0x0068d19d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#45 0x071d7924 in QApplication::exec () at kernel/qapplication.cpp:3760
#46 0x0805db86 in main (argc=) at /build/buildd/muon-1.2.1/installer/main.cpp:61

Possible duplicates by query: bug 295682, bug 295215, bug 295188, bug 295179, bug 295163.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-03-11 00:06:54 UTC

*** This bug has been marked as a duplicate of bug 291262 ***